.titleBar { margin-bottom: 5px!important; }

Dropbear: suche Logdatei & config. Möglichkeit

Dieses Thema im Forum "FRITZ!Box Fon: Modifikationen" wurde erstellt von sheepy, 24 Dez. 2008.

  1. sheepy

    sheepy Neuer User

    Registriert seit:
    15 Aug. 2007
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi Leute,
    kann mir jemand sagen ob Dropbear standardmäsig eine Log führt in der steht, wer sich wann und mit welcher IP eingeloggt hat?

    Des Weiteren bin ich auf der Suche nach einer Konfigurationsdatei für Dropbear wo man z.b die Anzahl der erlaubten Verbindungen regeln kann. Gibt es solch eine? Oder ist das auch nur möglich, indem ich die "Patch"-Datei vor dem kompilieren bearbeite?


    Achja,frohe Weihnachten ;-)

    mfg sheepy
     
  2. sf3978

    sf3978 IPPF-Promi

    Registriert seit:
    2 Dez. 2007
    Beiträge:
    7,655
    Zustimmungen:
    5
    Punkte für Erfolge:
    38
    Dropbear loggt bei mir in syslog und zeigt alles an:
    Code:
    .....................
    Dec 24 14:27:06 82 authpriv.notice dropbear[3083]: password auth succeeded for 'root' from 192.168.xxx.xxx:50832
    ...............
    Dec 24 14:29:55 82 authpriv.info dropbear[3239]: Child connection from 192.168.xxx.xxx:50851
    Dec 24 14:29:59 82 authpriv.warn dropbear[3239]: bad password attempt for 'root' from 192.168.xxx.xxx:50851
    Dec 24 14:30:01 82 authpriv.warn dropbear[3239]: bad password attempt for 'root' from 192.168.xxx.xxx:50851
    Dec 24 14:30:01 82 authpriv.info dropbear[3239]: exit before auth (user 'root', 2 fails): Max auth tries reached - user 'root' from 192.168.xxx.xxx:50851
    
    Die config für den Dropbear sieht bei mir so aus:
    Code:
    # cat [COLOR="Red"]/var/mod/etc/conf/dropbear.cfg[/COLOR]
    export DROPBEAR_ENABLED='yes'
    export DROPBEAR_OPTIONS='ListenAddress 192.168.xxx.xxx'
    export DROPBEAR_PORT='yyyyy'
    export DROPBEAR_PWDAUTH='yes'
     
  3. sheepy

    sheepy Neuer User

    Registriert seit:
    15 Aug. 2007
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hey, die Config hab ich gefunden, Danke.

    Ich habe gemerkt, dass Syslogd garnicht als Deamon eingebunden ist...Das erklärt wohl auch, dass ich keine Log-Datei besitze :D


    mfg sheepy
     
  4. Eruvaer

    Eruvaer Neuer User

    Registriert seit:
    24 Dez. 2008
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Falls du die Logs ohne laufenden syslogd haben willst, kannst du dropbear auch mit -E als Parameter starten und dann den stderr-Kanal in eine Datei umleiten:
    Code:
    dropbear -E 2>> /var/tmp/dropbear_log
    ;)