.titleBar { margin-bottom: 5px!important; }

dsmod-0.2.9 mit 06.04.27, 08.04.27, 23.04.27, 25.04.27, 43.04.27, 12.04.26, 14.04.26

Dieses Thema im Forum "Freetz" wurde erstellt von olistudent, 27 Jan. 2007.

  1. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    #1 olistudent, 27 Jan. 2007
    Zuletzt bearbeitet: 5 März 2007
    Hi.

    Mit dem Patch aus dem Anhang sollte der dsmod auf den neuen Firmwares der 7050, Fon Wlan und Fon laufen. Der Patch (-p7) muss auf einen frisch ausgepackten dsmod angewendet werden. (-p6.1 ist für ds-0.2.9 mit -p5)

    Wie spiele ich einen Patch ein? -> Wiki

    MfG Oliver

    edit:
    Eumex 300 IP mit 15.04.27 läuft auch
    05.03, 9.40: Fehler mit 5140 gefixt
     

    Anhänge:

  2. mahowi

    mahowi Neuer User

    Registriert seit:
    8 Jan. 2007
    Beiträge:
    68
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Westerwald
    Sind in den neuen Patches irgendwelche Änderungen gegenüber dem svn-Backpatch von b.sander drin?
    Der größte Teil scheint ja der Patch-Ausgabe nach gleich zu sein.
     
  3. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Ich hab keine Ahnung was b.sander alles in sein svn-Backpatch gepackt hat. Aber die Änderungen von -p2 nach -p3 sind ja nur die 3 Firmware-Versionen und 2x der Patch fürs Webinterface.

    MfG Oliver
     
  4. morph027

    morph027 Neuer User

    Registriert seit:
    24 Jan. 2007
    Beiträge:
    70
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo und schon mal Danke für den Patch.

    Aber leider bekomme ich den Fehler 2 beim kompilieren :(

    Code:
    STEP 2: MODIFY
    applying patches
    make: *** [firmware] Fehler 2
     
  5. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Hi.
    Kannst du mal unter advanced options den verbose mode auf 2 stellen. Und dann vielleicht noch angeben mit welcher Firmware du das versuchst...

    MfG Oliver
     
  6. morph027

    morph027 Neuer User

    Registriert seit:
    24 Jan. 2007
    Beiträge:
    70
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #6 morph027, 28 Jan. 2007
    Zuletzt bearbeitet: 28 Jan. 2007
    Ja, gern ;)

    Code:
    STEP 2: MODIFY
    applying patches
      applying patches (300ip_as_fon-de)
        patching file etc/profile
        patching file usr/bin/system_status
        patching file etc/init.d/rc.net
        patching file etc/init.d/rc.voip
        patching file etc/init.d/rc.S
        patching file etc/init.d/rc.S
        patching file etc/init.d/rc.S
        patching file usr/www/all/html/de/first/first_Sip_3.frm
        Hunk #1 FAILED at 3.
        1 out of 1 hunk FAILED -- saving rejects to file usr/www/all/html/de/first/first_Sip_3.frm.rej
        patching file usr/www/all/html/de/first/first_Sip_3.js
        Hunk #1 succeeded at 246 (offset 23 lines).
        patching file usr/www/all/html/de/first/first_Sip_free.frm
        Hunk #1 FAILED at 19.
        1 out of 1 hunk FAILED -- saving rejects to file usr/www/all/html/de/first/first_Sip_free.frm.rej
        patching file usr/www/all/html/de/first/first_Sip_free.js
        Hunk #1 succeeded at 115 with fuzz 2 (offset 34 lines).
        patching file usr/www/all/html/de/fon/dial.js
        Hunk #1 succeeded at 20 (offset 1 line).
        patching file usr/www/all/html/de/fon/fonbuch.js
        Hunk #1 succeeded at 149 (offset 3 lines).
        patching file usr/www/all/html/de/fon/foncalls.js
        Hunk #1 succeeded at 96 (offset 5 lines).
        patching file usr/www/all/html/de/fon/fonlist.html
        patching file usr/www/all/html/de/fon/rulall1.frm
        patching file usr/www/all/html/de/fon/rulall1.js
        patching file usr/www/all/html/de/fon/rulall.frm
        patching file usr/www/all/html/de/fon/rulall.html
        patching file usr/www/all/html/de/fon/rulall.js
        patching file usr/www/all/html/de/fon/rul.frm
        patching file usr/www/all/html/de/fon/rul.html
        patching file usr/www/all/html/de/fon/rul.js
        patching file usr/www/all/html/de/fon/sip1.frm
        Hunk #1 succeeded at 59 with fuzz 2 (offset 2 lines).
        patching file usr/www/all/html/de/fon/sip1.js
        Hunk #1 succeeded at 825 (offset 62 lines).
        patching file usr/www/all/html/de/fon/wecker.js
        patching file usr/www/all/html/de/system/nacht.frm
        patching file usr/www/all/html/de/system/nacht.js
    make: *** [firmware] Fehler 2
    [edit]: Hm... ist wohl meine Schuld, denn ich ging leichtfertig davon aus, dass das auch für die 300IP_as_FON fluppt...als normale FON kann ich kompilieren, aber halt nicht als 300IP_as_FON.
     
  7. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Ich hab ja auch nicht geschrieben, dass ich die Firmware für die 300ip angepasst hab. Dazu muss der Patch für die 300ip aktualisiert werden.

    MfG Oliver
     
  8. morph027

    morph027 Neuer User

    Registriert seit:
    24 Jan. 2007
    Beiträge:
    70
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Jau, deswegen ja mein Fehler ;) Aber trotzdem Danke für die versuchte Mühe!
     
  9. Tokka

    Tokka Neuer User

    Registriert seit:
    1 Aug. 2006
    Beiträge:
    75
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Hello all, i've the same problem...make: *** [firmware] Error 2...i've tried to install the patch p3.1 (i've the p2 patch just installed), but now i can't ds-mod...i've worng some passage, but i don't know where is my mistake...
    Can you help me?
    Mant thanks ^_^
    MfG
    Tokka
     
  10. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    @Tokka
    Which Box? Which Firmware? I need more input...
    Can you post the output like morph027 did? menuconfig->advanced options->verbose mode 2

    Greets, Oliver
     
  11. DPR

    DPR Neuer User

    Registriert seit:
    2 Juli 2005
    Beiträge:
    173
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #11 DPR, 28 Jan. 2007
    Zuletzt bearbeitet: 28 Jan. 2007
    Also ich bekomme beim bauen des Images für die 5050 folgenden Fehler:
    Code:
      applying patches (fon_5050-de)
        patching file etc/profile
        patching file usr/bin/system_status
        patching file etc/init.d/rc.net
        patching file etc/init.d/rc.voip
        patching file etc/init.d/rc.S
        patching file etc/init.d/rc.S
        patching file etc/init.d/rc.S
        patching file usr/www/all/html/de/menus/menu2_fon.html
        Hunk #1 succeeded at 67 (offset -2 lines).
        patching file usr/www/all/html/de/menus/menu2_homehome.html
        patching file usr/www/all/html/de/menus/menu2.inc
        Hunk #1 FAILED at 7.
        1 out of 1 hunk FAILED -- saving rejects to file usr/www/all/html/de/menus/menu2.inc.rej
        patching file usr/www/all/html/de/menus/menu2_internet.html
        patching file usr/www/all/html/de/menus/menu2_system.html
    
    Außerdem kann ich mit exakt derselben Konfiguration für die 7050 das image auch nicht bauen, weil er mir sagt, dass das image zu groß wäre ... der Flash-Speicher ist doch auf der 5050 nicht größer als auf der 7050, oder ?!?!?!

    Ach ja: natürlich die neuesten Patches für die neue .26 Firmware.
     
  12. Tokka

    Tokka Neuer User

    Registriert seit:
    1 Aug. 2006
    Beiträge:
    75
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Hi Olistudent, and thanks ^_^
    i'm triyng to patch the fw 06.04.27 for the fbf, this is the result :(

    $ patch -p0 <ds-0.2.9-p3.1.patch
    can't find file to patch at input line 4
    Perhaps you used the wrong -p or --strip option?
    The text leading up to this was:
    --------------------------
    |diff -burN ds-0.2.9.orig/Config.in ds-0.2.9/Config.in
    |--- ds-0.2.9.orig/Config.in 2007-01-27 15:40:30.000000000 +0100
    |+++ ds-0.2.9/Config.in 2007-01-27 15:38:25.000000000 +0100
    --------------------------
    File to patch: 190-webmenu.patch
    patching file 190-webmenu.patch
    Hunk #1 FAILED at 662.
    Hunk #2 FAILED at 674.
    2 out of 2 hunks FAILED -- saving rejects to file 190-webmenu.patch.rej
    can't find file to patch at input line 31
    Perhaps you used the wrong -p or --strip option?
    The text leading up to this was:
    --------------------------
    |diff -burN ds-0.2.9.orig/patches/fon/de/190-webmenu.patch ds-0.2.9/patches/fon/
    de/190-webmenu.patch
    |--- ds-0.2.9.orig/patches/fon/de/190-webmenu.patch 2006-07-24 02:38:59.0000
    00000 +0200
    |+++ ds-0.2.9/patches/fon/de/190-webmenu.patch 2007-01-27 15:30:26.000000000 +0
    100
    --------------------------
    File to patch: 190-webmenu.patch
    190-webmenu.patch: No such file or directory
    Skip this patch? [y]



    i'm sure wrong myself...but i'm not much expert...
    Thanks very much
    Tokka
     

    Anhänge:

  13. kleinc

    kleinc Mitglied

    Registriert seit:
    1 Aug. 2005
    Beiträge:
    513
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi Oliver,

    ich hab den 0.2.9er Mod mit der 14.04.26 genauso gebaut (Patch -p2) wie für die 14.04.25. Hast du in dem -p3 noch mehr geändert außer die neue 26er FW als default Basisimage reinzuschreiben?

    Gruß,
    kleinc
     
  14. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    @DPR
    Ich hab für die 5050 auch nix angepasst. Ich schau mir das mal an. Ohne zu wissen was die 5050 kann würde ich mal sagen, dass die 7050 mehr kann und deshalb die Firmware eventuell größer sein könnte.

    @kleinc
    Nein, ich hab sonst nix geändert.

    @tokka
    Perhaps you are in the wrong directory. You have to execute the patch in the directory above ds-0.2.9.

    MfG Oliver
     
  15. kleinc

    kleinc Mitglied

    Registriert seit:
    1 Aug. 2005
    Beiträge:
    513
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Alles klar.
    Ganz allgemein ein großes Dankeschön für die super Arbeit!
     
  16. Tokka

    Tokka Neuer User

    Registriert seit:
    1 Aug. 2006
    Beiträge:
    75
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Ok, i've found the right directory :)
    So i have this reult

    $ patch -p0 < ds-0.2.9-p3.1.patch
    patching file ds-0.2.9/Config.in
    Reversed (or previously applied) patch detected! Assume -R? [n] y
    Hunk #1 succeeded at 642 with fuzz 1 (offset -20 lines).
    Hunk #2 FAILED at 654.
    1 out of 2 hunks FAILED -- saving rejects to file ds-0.2.9/Config.in.rej
    patching file ds-0.2.9/patches/fon/de/190-webmenu.patch
    patching file ds-0.2.9/patches/fon_wlan/de/190-webmenu.patch
    Reversed (or previously applied) patch detected! Assume -R? [n] y

    And with the make, on step 2, this:

    STEP 2: MODIFY
    applying patches
    applying patches (fon-de)
    patching file etc/profile
    patching file usr/bin/system_status
    can't find file to patch at input line 4
    Perhaps you used the wrong -p or --strip option?
    The text leading up to this was:
    --------------------------
    |diff -burN ds-0.2.9.orig/Config.in ds-0.2.9/Config.in
    |--- ds-0.2.9.orig/Config.in 2007-01-27 15:40:30.000000000 +0100
    |+++ ds-0.2.9/Config.in 2007-01-27 15:38:25.000000000 +0100
    --------------------------
    File to patch:
    Skip this patch? [y]
    Skipping patch.
    2 out of 2 hunks ignored
    can't find file to patch at input line 31
    Perhaps you used the wrong -p or --strip option?
    The text leading up to this was:
    --------------------------
    |diff -burN ds-0.2.9.orig/patches/fon/de/190-webmenu.patch ds-0.2.9/patches/
    fon/de/190-webmenu.patch
    |--- ds-0.2.9.orig/patches/fon/de/190-webmenu.patch 2006-07-24 02:38:59.0000
    00000 +0200
    |+++ ds-0.2.9/patches/fon/de/190-webmenu.patch 2007-01-27 15:30:26.0000
    00000 +0100
    --------------------------
    File to patch:
    Skip this patch? [y]
    Skipping patch.
    1 out of 1 hunk ignored
    can't find file to patch at input line 51
    Perhaps you used the wrong -p or --strip option?
    The text leading up to this was:
    --------------------------
    |diff -burN ds-0.2.9.orig/patches/fon_wlan/de/190-webmenu.patch ds-0.2.9/pat
    ches/fon_wlan/de/190-webmenu.patch
    |--- ds-0.2.9.orig/patches/fon_wlan/de/190-webmenu.patch 2006-07-24 02:46
    :58.000000000 +0200
    |+++ ds-0.2.9/patches/fon_wlan/de/190-webmenu.patch 2007-01-27 15:23:11.0000
    00000 +0100
    --------------------------
    File to patch:
    Skip this patch? [y]
    Skipping patch.
    1 out of 1 hunk ignored
    make: *** [firmware] Error 2

    So, i think...i've used the wrong version (3.1)?
    Thanks again :p
    MfG
    Tokka
     
  17. robspr

    robspr Neuer User

    Registriert seit:
    4 Okt. 2006
    Beiträge:
    84
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #17 robspr, 28 Jan. 2007
    Zuletzt bearbeitet: 28 Jan. 2007
    Hi Oliver,

    im Anhang die beiden Dateien die für die eumex 300IP angepasst werden mussten damit es auch mit der neuen AVM firmware passt.
     

    Anhänge:

  18. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    @Tokka
    p3.1 is only for people who used p2. When you have a fresh dsmod you should use p3.

    @robspr
    Das ist ja klasse. Ich dachte, dass das schon wieder an mir hängen bleibt.

    MfG Oliver
     
  19. dsteinkopf

    dsteinkopf Mitglied

    Registriert seit:
    29 Juli 2005
    Beiträge:
    263
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    ich habe
    - den ds-0.2.9-opensrc-04.06.tar.bz2 ausgepackt und
    - mit ds-0.2.9-p4.patch.bz2 gepatcht.

    Ist es normal, dass ich dann in make menuconfig immer noch nicht explizit die 14.04.26 angeboten bekomme? Ein make-Durchlauf fragt mich dann aber, ob ich die aktuelle Firmware (14.04.26) benutzen will und da sage ich Ja. Dann scheint alles zu klappen. Gut so?

    Noch eine Frage: Kann ich einfach die .config vom ds-0.2.8 rüberkopieren? Oder kann da Unerwartetes passieren? Mir geht es lediglich um die Aktualisierung auf die .26 wg. dem UDP-Bug.

    PS. Danke für Eure Arbeit und die unendliche Geduld mit der die immer gleichen Fragen, mit den immer gleichen fehlenden Infos beantwortet werden. Ich hoffe, meine Fragen gehören nicht zu dieser Sorte ;-)...

    Danke.


    Dirk
     
  20. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Du bekommst im menuconfig die Version vom AVM Open-Source-Package angeboten. Nicht die der Firmware. Eigentlich sollte nach dem Patch aber nicht mehr nach der Firmware gefragt werden.
    Du kannst die .config rüberkopieren. Aber danach musst du nochmal ein "make menuconfig" machen.

    MfG Oliver