.titleBar { margin-bottom: 5px!important; }

DTMF Ärger beim Weiterleiten (kein Stern, keine Raute)

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von tommew, 11 Dez. 2006.

  1. tommew

    tommew Neuer User

    Registriert seit:
    6 Dez. 2006
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #1 tommew, 11 Dez. 2006
    Zuletzt bearbeitet: 11 Dez. 2006
    Meine Asterisk Mini Setup sieht so aus:

    Asterisk 1.2 aus dem svn 1.2 branch (23.11.2006)
    -1 X Beronet BN8S0 (4 SO Amt PTP / 4 S0 intern PTM)
    -3 x Fritz Box Fon 5050 mit je 1 analogen Telefone am ersten Analog-Port ohne "Automatisches Amt"
    -2 ISDN Telefone direkt an der BN8SO.
    extensions.conf
    Code:
    [general]
    static=yes
    writeprotect=no
    
    [globals]
    
    [default]
    include => esc
    
    [esc]
    exten => 25,1,Dial(mISDN/4/25,25,rtT)
    exten => 26,1,Dial(mISDN/5/26,25,rtT)
    
    exten => 41,1,Dial(SIP/41,25,rtT)
    exten => 44,1,Dial(SIP/44,25,rtT)
    exten => 47,1,Dial(SIP/47,25,rtT)
    
    exten => _XX,n,Hangup
    
    sip.conf
    Code:
    [general]
    port = 5060
    bindaddr = 0.0.0.0
    qualify=no
    disable=all
    allow=alaw
    allow=ulaw
    allow=gsm
    allow=slinear
    
    canreinvite=no
    
    srvlookup=yes
    externip = 123.123.123.123
    localnet=192.168.237.0/255.255.255.0
    tos=lowdelay
    
    [41]
    type=friend
    username=41
    secret=geheim
    context=esc
    host=dynamic
    qualify=yes
    nat=yes
    callgroup=1
    pickupgroup=1
    
    [44]
    type=friend
    username=44
    secret=geheim
    context=esc
    host=dynamic
    qualify=yes
    nat=yes
    callgroup=1
    pickupgroup=1
    
    [47]
    type=friend
    username=47
    secret=geheim
    context=esc
    host=dynamic
    qualify=yes
    nat=yes
    callgroup=1
    pickupgroup=1
    
    
    
    features.conf
    Code:
    [general]
    parkext => 700		
    parkpos => 701-720		
    context => parkedcalls
    parkingtime => 180
    transferdigittimeout => 3
    ;courtesytone = beep
    ;xfersound = beep
    ;xferfailsound = beeperr
    ;adsipark = yes
    ;findslot => next
    pickupexten = *8
    ;featuredigittimeout = 500
    
    [featuremap]
    ;blindxfer => #1
    ;disconnect => *0
    ;automon => *1
    atxfer => ##
    
    [applicationmap]
    
    Wenn ich ein Gespräch zwischen zwei SIP Channels oder einem SIP und einem mISDN Channel führe, dann reagiert Asterisk überhaupt nicht auf "Töne". Alle DTMF Signale sind beim Gegenüber zu hören. Eine Reaktion wie in der feature.conf gesetzt kann ich nie initieren.

    Mit der R-Taste kann ich schön makeln und bekomme auch die Wartemusik von Asterisk, aber ich glaube, die Funktionalität übernimmt die Fritzbox. Der muß ich auch das automatische Amt abgewöhnen.

    Warum reagiert Asterisk weder an SIP noch an mISDN nicht auf DTMF???
    Der Setup ist doch simple.
     
  2. Schnabel

    Schnabel Neuer User

    Registriert seit:
    21 März 2005
    Beiträge:
    30
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Anwendungsentwickler
    Ort:
    Aachen
    Hi,

    versuch mal, ein dtmfmode=auto in die sip.conf einzufügen.

    Tschö,
    Schnabel
     
  3. tommew

    tommew Neuer User

    Registriert seit:
    6 Dez. 2006
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    [gelöst] Ich hab's !!

    Da der Server in einer Xen Domain läuft, habe ich in einer Kopie der Platte mal die Sourcen aktualisiert.

    make clean
    make install

    und die alten Configs.

    Alles funktioniert!!