.titleBar { margin-bottom: 5px!important; }

Eingehende Anrufe vom Festnetz aus

Dieses Thema im Forum "FreePBX, TrixBox (Asterisk@Home)" wurde erstellt von Schranz0r_23, 4 Nov. 2006.

  1. Schranz0r_23

    Schranz0r_23 Neuer User

    Registriert seit:
    4 Nov. 2006
    Beiträge:
    2
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo liebes Forum,

    ich habe folgendes Problem:
    Würde gerne dass eingehende Anrufe von einem Festnetz Telefon aus auch funktionieren :) - Von einem Handy kann ich die Telefonnummer (9776) und dann irgendeine Durchwahl (20) anrufen und es bimmelt.

    Aber wie gesagt von einem Festnetz Telefon nicht!

    Zur Hardware/Software:
    1x Primär Multiplexer
    1x Digium Te110P
    1x Fujitsu Siemens Primergy RX220 (Dual Opteron)

    Software:
    Trixbox 1.2

    ---
    Ergänzung:
    Ich hatte mal irgendwas gelesen dass das von einem Handy aus nur funktioniert, weil da die Rufnummer als kompletter Block oder irgendwie sowas versendet wird. KP mehr :)

    ---
    Wir hatten in meiner Agentur vorher die Telefonanlage auf einem SuSE Server mit einer etwas älteren asterisk Version. Da ging es, allerdings hatte ich das nicht eingerichtet:)

    ---

    Jetzt seid ihr dran, danke für die hilfe im vorraus
     
  2. Schranz0r_23

    Schranz0r_23 Neuer User

    Registriert seit:
    4 Nov. 2006
    Beiträge:
    2
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    prob solved

    hab das problem gelöst

    unter der /etc/asterisk/extensions_addition.conf gibt es einen
    eintrag der sich [ext-did] schimpft.

    hier stehen alle rufnummern drin die über die freepbx oberfläche
    hinzugefügt worden sind.

    Beispiel:
    die ganzen XXXX repräsentieren meine rufnummer (ich zeig sie euch nicht :) )
    Der fehler lag da dran, dass nach der 1 ein n folgte, dann habe ich anstatt
    n die anweisung 2 hinzugefügt und voilla der account bimmelte auch über
    das festnetz! blöd ist nur wenn man etwas über die freepbx oberfläche ändert,
    schreibt er die ganzen einstellungen wieder weg, also schön nen backup immer machen ;)
    exten => XXXXXXX,1,Set(FROM_DID=XXXXXX)
    exten => XXXXXXX,n,Goto(ext-local,XXXXXX,1)

    exten => XXXXXXX,1,Set(FROM_DID=XXXXXX)
    exten => XXXXXXX,2,Goto(ext-local,XXXXXX,1)