.titleBar { margin-bottom: 5px!important; }

[erledigt]asterisk von aussen nicht erreichbar

Dieses Thema im Forum "sipgate" wurde erstellt von daeda, 29 Okt. 2008.

  1. daeda

    daeda Neuer User

    Registriert seit:
    29 Okt. 2008
    Beiträge:
    8
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #1 daeda, 29 Okt. 2008
    Zuletzt bearbeitet: 31 Okt. 2008
    Hallo,

    ich teste gerade das Aufsetzen eines Asterisk Server. Grundlade ist ein Sidux (debian sid) server. Dieser läuft momentan in Virtualbox auf einem WinXP System. Die später hoffentlich gut laufende Konfiguation soll dann auf unseren echten debian server überspielt werden. Die Anfäge waren Prima, innerhalb kürzster Zeit hatte ich die ersten zwei Telefone (x-lite und ein siemens voip Telefon) miteinander verbunden. Das telefonieren nach draussen macht auch keine Probleme, leider schaffe ich es nicht angerufen zu werden...

    extensions.conf
    Code:
    extensions.conf
    
    [default]
    
    exten => 1001,1,Answer
    exten => 1001,2,Playback(hello-world)
    exten => 1001,3,Hangup
    
    exten => 2000,1,Dial(SIP/2000,20)
    exten => 2000,n,VoiceMail(2000,u)
    
    exten => 2001,1,Dial(SIP/2001,20)
    exten => 2001,n,VoiceMail(2000,u)
    
    exten => 2999,1,VoiceMailMain(${CALLERID(num)},s) ; damit wird beschrieben das bei eingabe der 2999 am telefon sich die mailbox mit sprachmenue meldet
    
    include => sipgate_de_out
    include => sipgate_de_in 
    
    [sipgate_de_out]
    exten => _0[1-9].,1,Dial(SIP/${EXTEN}@sipgate.de
    
    [sipgate_de_in]
    exten => SIPID,1,Dial(SIP/2000,20)
    exten => SIPID,n,VoiceMail(2000,u)
    sip.conf
    Code:
    [general]
    port=5060
    bindaddr=0.0.0.0
    externip=dyndns.adresse.de
    externhost=dyndns.adresse.de
    context=default
    localnet=192.168.0.0/255.255.255.0
    nat=no
    
    register => SIPID:SIDPWD@sipgate.de/SIPID
    
    [2000]
    type=friend
    secret=1234
    host=dynamic
    
    [2001]
    type=friend
    secret=1234
    host=dynamic
    
    [sipgate.de]
    type=friend
    username=SIPID
    fromuser=SIPID
    secret=SIDPWD
    host=sipgate.de
    fromdomain=sipgate.de
    qualify=yes
    insecure=very
    nat=no
    context=default
    
    [sipgate_de_in]
    type=peer
    fromdomain=sipgate.de
    host=sipgate.de
    disallow=all
    allow=ulaw
    context=default
    nat=no
    rtp.conf
    Code:
    [general]
    
    rtpstart=8000
    rtpend=8020
    
    wenn ich show registry eingebe dann kommt:

    Code:
    Host                         Username   Refresh     State
    sipgate.de:5060          SIPID        105           Registered
    
    Ich habe einen Lancom 1722 der als Voip Router wie auch Internet Router konfiguriert ist. Dort habe ich die Ports 5060 sowie 8000 - 8020 freigegeben. Die Firewall ist abgestellt.

    Wenn ich core set verbose 10 eintippe und mich selbst anrufe kommt keine meldung, daher gehe ich stark davon aus das ich nicht durch den Router komme.

    Langes suchen hat leider bisher zu keinem Ergebnis geführt... bin für jeden Rat dankbar.

    MfG


    NACHTRAG: Bei Sipgate.de unter Einstellugen steht merkwürdigerweise drin das kein telefon verbuden ist...

    NACHTRAG2: hier nochmals alle Meldungen die ich beim Start von Asterisk bekomme:

    Code:
    [ Booting...
    [ Reading Master Configuration ]
    [ Initializing Custom Configuration Options ]
    [Oct 30 15:10:49] NOTICE[18640]: cdr.c:1373 do_reload: CDR simple logging enabled.
    [Oct 30 15:10:49] NOTICE[18640]: loader.c:859 load_modules: 160 modules will be loaded.
    ....[Oct 30 15:10:49] WARNING[18640]: res_smdi.c:1335 load_module: No SMDI interfaces are available to listen on, not starting SMDI listener.
    .[Oct 30 15:10:49] NOTICE[18640]: res_odbc.c:235 load_odbc_config: Adding ENV var: INFORMIXSERVER=my_special_database
    [Oct 30 15:10:49] NOTICE[18640]: res_odbc.c:235 load_odbc_config: Adding ENV var: INFORMIXDIR=/opt/informix
    [Oct 30 15:10:49] NOTICE[18640]: res_odbc.c:716 load_module: res_odbc loaded.
    ...... Loading [Sub]Agent Module
    ....................  == No hardware transcoders found.
    ..............................[Oct 30 15:10:49] WARNING[18640]: chan_iax2.c:11115 load_module: Unable to open IAX timing interface: No such file or directory
    ..............[Oct 30 15:10:49] NOTICE[18640]: pbx_ael.c:4131 pbx_load_module: Starting AEL load process.
    [Oct 30 15:10:49] NOTICE[18640]: pbx_ael.c:4138 pbx_load_module: AEL load process: calculated config file name '/etc/asterisk/extensions.ael'.
    [Oct 30 15:10:49] NOTICE[18640]: pbx_ael.c:4146 pbx_load_module: AEL load process: parsed config file name '/etc/asterisk/extensions.ael'.
    [Oct 30 15:10:49] NOTICE[18640]: pbx_ael.c:4149 pbx_load_module: AEL load process: checked config file name '/etc/asterisk/extensions.ael'.
    [Oct 30 15:10:49] NOTICE[18640]: pbx_ael.c:4151 pbx_load_module: AEL load process: compiled config file name '/etc/asterisk/extensions.ael'.
    [Oct 30 15:10:49] NOTICE[18640]: pbx_ael.c:4154 pbx_load_module: AEL load process: merged config file name '/etc/asterisk/extensions.ael'.
    [Oct 30 15:10:49] NOTICE[18640]: pbx_ael.c:4157 pbx_load_module: AEL load process: verified config file name '/etc/asterisk/extensions.ael'.
    ..........[Oct 30 15:10:49] WARNING[18640]: chan_sip.c:16157 set_insecure_flags: insecure=very at line 30 is deprecated; use insecure=port,invite instead
    .......................[Oct 30 15:10:49] WARNING[18640]: pbx_config.c:2296 pbx_load_config: No closing parenthesis found? 'Dial(SIP/${EXTEN}@sipgate.de'
    .........[Oct 30 15:10:49] ERROR[18640]: chan_vpb.cc:2722 ast_module_load_result load_module(): No Voicetronix cards detected
    ........................................ ]
    Asterisk Ready.
    *CLI> [Oct 30 15:10:49] NOTICE[18663]: chan_sip.c:12669 handle_response_peerpoke: Peer 'sipgate.de' is now Reachable. (12ms / 2000ms)
    
    *CLI>
    
    Habe Asterisk testweise direkt auf den Sidux Server aufgespielt, zum Test ob nicht evtl. die Virtuelle Umgebung Zugriffe blockiert, leider weiterhin ohne Erfolg...


    Nachtrag: Habe ne fritzbox gegen das Lancom Gerät getauscht und nun gehts anstandlos. Komme scheinbar nicht am Router vorbei. Werde dann mit der Fritzbox weiter testen. Ist also erledigt.