.titleBar { margin-bottom: 5px!important; }

[erledigt] mISDN-Installation: keine Kommandos im CLI, Probleme beim mISDN restart

Dieses Thema im Forum "Asterisk ISDN mit mISDN" wurde erstellt von debitux, 27 Feb. 2009.

  1. debitux

    debitux Neuer User

    Registriert seit:
    21 Nov. 2007
    Beiträge:
    44
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Ort:
    Aachen
    #1 debitux, 27 Feb. 2009
    Zuletzt bearbeitet: 5 März 2009
    Hallo,


    habe misdn (mISDN-1_1_9.1) kompiliert/installiert, danach Asterisk (1.6.0.3) neu kompiliert.

    Allerdings sind keine misdn-Kommandos im *-CLI verfügbar und nach dem ersten mISDN start hängt mISDN restart, bzw. mISDN stop/start.

    mISDN start:
    Code:
    mISDN start
    -- Loading mISDN modules --
    >> /sbin/modprobe --ignore-install capi
    >> /sbin/modprobe --ignore-install mISDN_core debug=0
    >> /sbin/modprobe --ignore-install mISDN_l1 debug=0
    >> /sbin/modprobe --ignore-install mISDN_l2 debug=0
    >> /sbin/modprobe --ignore-install l3udss1 debug=0
    >> /sbin/modprobe --ignore-install mISDN_capi
    >> /sbin/modprobe --ignore-install hfcpci protocol=0x2 layermask=0xf
    >> /sbin/modprobe --ignore-install mISDN_dsp debug=0 options=0
    >> /sbin/modprobe --ignore-install mISDN_debugtool
    creating device node: /dev/mISDN
    
    misdnportinfo
    Code:
    Port  1: TE-mode BRI S/T interface line (for phone lines)
     -> Protocol: DSS1 (Euro ISDN)
     -> childcnt: 2
    --------
    
    mISDN_close: fid(3) isize(131072) inbuf(0x804c060) irp(0x804c060) iend(0x804c060)
    
    mISDN restart
    Code:
    -- Unloading mISDN modules --
    >> /sbin/modprobe -r --ignore-remove mISDN_dsp hfcpci mISDN_capi l3udss1 mISDN_l2 mISDN_l1
    /usr/sbin/mISDN: line 322:  6020 Speicherzugriffsfehler  /sbin/modprobe -r --ignore-remove mISDN_dsp hfcpci mISDN_capi l3udss1 mISDN_l2 mISDN_l1
    >> /sbin/modprobe -r --ignore-remove mISDN_debugtool
    >> /sbin/modprobe -r --ignore-remove mISDN_core
    FATAL: Module mISDN_core is in use.
    -- Loading mISDN modules --
    >> /sbin/modprobe --ignore-install capi
    >> /sbin/modprobe --ignore-install mISDN_core debug=0
    >> /sbin/modprobe --ignore-install mISDN_l1 debug=0
    >> /sbin/modprobe --ignore-install mISDN_l2 debug=0
    >> /sbin/modprobe --ignore-install l3udss1 debug=0
    >> /sbin/modprobe --ignore-install mISDN_capi
    >> /sbin/modprobe --ignore-install hfcpci protocol=0x2 layermask=0xf
    >> /sbin/modprobe --ignore-install mISDN_dsp debug=0 options=0
    
    Bei der ISDN-Karte handelt es sich um eine Longshine LCS-8501A mit hfc-Chipsatz.

    Andere ISDN-Treiber sind geblacklistet

    Auszug /etc/modprobe.d/blacklist
    blacklist hisax
    blacklist crc_ccitt
    blacklist capi
    blacklist kernelcapi
    blacklist capifs
    blacklist hisax_isac
    blacklist hisax_fcpcipnp

    Gleichwohl sind beim Start (lsmod)

    -capifs
    -crc-ccitt

    geladen (ebenso, wie ztdummy und zaptel (warum auch immer zaptel...))

    Gruß und Danke,

    debitux
     
  2. debitux

    debitux Neuer User

    Registriert seit:
    21 Nov. 2007
    Beiträge:
    44
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Ort:
    Aachen
    erledigt: mISDN-Installation: keine Kommandos im CLI, Probleme beim mISDN restart

    Hallo,

    nach langer (langer!) Suche habe ich möglicherweise die Ursache des Problem lokalisiert:

    Die Installation erfolgte auf einem debian (Kanotix-)Kernel 2.6.24-11 (von Signatur abweichender Rechner).
    Nachdem auch eine Installation auf Lenny (Kernel 2.6.26-1) fehlschlug, ergab die weitere Suche, daß misdn nicht auf Kernel >= 2.6.24x läuft.

    Ab Kernel 2.6.27 ist (wohl) mISDN im Kernel enthalten, allerdings V2. Das war mir mit der Anbindung per lcr zu umständlich (zumal der installierte Kernel 2.6.28 Probleme mit dem X-Server machte).

    Ich habe mich nun für die ISDN-Anbindung per Zaptel entschlossen.

    Gruß,

    debitux