.titleBar { margin-bottom: 5px!important; }

[Erledigt] Probleme Freetz Image erstellen

Dieses Thema im Forum "Freetz" wurde erstellt von Tho³n³, 14 Dez. 2008.

  1. Tho³n³

    Tho³n³ Neuer User

    Registriert seit:
    13 Dez. 2008
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #1 Tho³n³, 14 Dez. 2008
    Zuletzt bearbeitet: 14 Dez. 2008
    Moin,
    ich versuche gerade Freetz auf meine Fritz!Box zu bekommen.
    Habe eine FRITZ!Box Fon WLAN 7140 , Firmware-Version 30.04.33.

    Mein Problem ist wenn ich "make menuconfig" eingebe um einzustellen welche Mods ich möchte und wleche nicht, bekomme ich immer folgende Meldung:

    Code:
     
    /bin/bash: svnversion: command not found
    ERROR: The program autoconf was not found in path.
    ERROR: The program automake was not found in path.
    ERROR: The program g++ was not found in path.
    ERROR: The program patch was not found in path.
    WARNING: The program bison was not found in path.
    WARNING: The program flex was not found in path.
    WARNING: The program jam was not found in path.
    ERROR: The header file ncurses.h was not found in /usr/(local/)include.
    ERROR: The header file zlib.h was not found in /usr/(local/)include.
    Makefile:453: *** Some build prerequisites are missing! Please install the missing packages before trying again.  Schluss.
    
    
    obwohl ich eiglich alles mit :
    Code:
     
    sudo apt-get -y update
    sudo apt-get -y upgrade
    sudo apt-get -y dist-upgrade
    
    instaliert habe.

    Bei
    Code:
     
    sudo apt-get -y install subversion gcc g++ binutils autoconf automake automake1.9 automake1.8 libtool make bzip2 libncurses5-dev zlib1g-dev flex bison patch texinfo tofrodos gettext jam pkg-config jikes ecj-bootstrap fastjar realpath perl libstring-crc32-perl ruby ruby1.8 gawk python libusb-dev unzip
    
    kommt immer

    Code:
     
    [sudo] password for tho3n3: 
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut       
    Lese Status-Informationen ein... Fertig
    gcc ist schon die neueste Version.
    binutils ist schon die neueste Version.
    E: Konnte Paket automake1.8 nicht finden
    tho3n3@Mein-Linux:~/Desktop/freetz-1.0.1$ 
    
    Hoffe ihr könnt mir helfen weiß nicht was ich nun genau machen soll. Die Befehle habe ich von hier http://www.freetz.org/wiki/help/howtos/common/install

    Vllt kann mir auch jemand eine Image erstelle, muss nicht besonders eingestellt sein dürfen ruhig alles Mods eingeschaltet sein.

    Vielen Dank im voraus

    Mfg Tho³n³
     
  2. schmatke

    schmatke Mitglied

    Registriert seit:
    25 Juli 2006
    Beiträge:
    631
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Vogtland
    Erstens gehört das hierher und zweitens bekommst Du hier keine fertigen Images.

    Softwarevorraussetzungen stehen im Wiki. Deine Fehlermeldungen sind doch deutlich.
     
  3. Tho³n³

    Tho³n³ Neuer User

    Registriert seit:
    13 Dez. 2008
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Code:
    
    /bin/bash: svnversion: command not found
    ERROR: The header file ncurses.h was not found in /usr/(local/)include.
    ERROR: The header file zlib.h was not found in /usr/(local/)include.
    Makefile:453: *** Some build prerequisites are missing! Please install the missing packages before trying again.  Schluss.

    habe nur noch den fehler, wie bekomme ich den weg ?
     
  4. schmatke

    schmatke Mitglied

    Registriert seit:
    25 Juli 2006
    Beiträge:
    631
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Vogtland
    Steht doch da!
    ncurses-devel, zlib-devel.
    Je nach dem, was Du für ein Linux nutzt, können die Namen abweichen.
     
  5. Tho³n³

    Tho³n³ Neuer User

    Registriert seit:
    13 Dez. 2008
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #5 Tho³n³, 14 Dez. 2008
    Zuletzt bearbeitet: 14 Dez. 2008
    Ich hab jetzt durch andere Quellen geschafft.
     
  6. schmatke

    schmatke Mitglied

    Registriert seit:
    25 Juli 2006
    Beiträge:
    631
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Vogtland
    #6 schmatke, 14 Dez. 2008
    Zuletzt bearbeitet: 14 Dez. 2008
    Ich hab kein Ubuntu.
    Du musst halt mindestens noch die zwei Pakete installieren.
    ncurses-devel, zlib-devel oder nur dev. Was weiß ich, wie das bei Ubuntu heisst.

    Also:
    apt-get install ncurses-dev
    apt-get install zlib-dev

    Oder so ähnlich. Das Ubuntu-Wiki hilft Dir bestimmt weiter. Das is ja ziemlich gut!:)
     
  7. Tho³n³

    Tho³n³ Neuer User

    Registriert seit:
    13 Dez. 2008
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Oh hatte nciht gesehen dasze noch geschrieben, hast dnek für deine Antwort. Habe nur kapiert das ich die Sachen durch den Befehl sudo apt-get install die sachen einfahc instalieren kann wenn ich weiß wie die Pakete heißen, die namen habe ich dem im freetz wiki gefunden.