.titleBar { margin-bottom: 5px!important; }

[erledigt] snom 300 config

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von 2fast_driver, 23 Sep. 2008.

  1. 2fast_driver

    2fast_driver Neuer User

    Registriert seit:
    8 Aug. 2008
    Beiträge:
    62
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hallo Leute,

    ich habe seid 2 tagen probiert das snom 300 für asterisk server zu konfigurieren.:confused:
    Ich bekomme einfach nicht gebacken das snom 300 mit asterisk zu verbinden.

    Asterisk Server IP: 192.168.16.28
    Phone1 IP: 192.168.16.29
    Phone2 IP: 192.168.16.31


    Snom Einstellungen:

    Snom Phone 1:
    Login
    Identity 1:
    Displayname: Phone1
    Account: 50
    Password: geheim
    Registrar: 192.168.16.28

    Snom Phone 2:
    Login
    Identity 1:
    Displayname: Phone2
    Account: 51
    Password: geheim
    Registrar: 192.168.16.28



    extensions.conf
    Code:
    [general]
    static=yes
    writeprotect=no
    
    [local]
    exten => _5X,1,NoCDR()
    exten => _5X,n,Dial,SIP/${EXTEN}|55|Ttr
    
    
    [default]
    include => local
    
    
    sip.conf
    Code:
    
    [general]
    context=default
    bindport=5060
    bindaddr=0.0.0.0
    srvlookup=yes
    
    
    [50]
    callerid=Phone 1 <50>
    host=dynamic
    domain=192.168.16.29
    user=50
    secret=geheim
    type=friend
    mailbox=50
    nat=yes
    canreinvite=no
    
    
    [51]
    callerid=Phone 2 <51>
    host=dynamic
    domain=192.168.16.31
    user=51
    secret=geheim
    type=friend
    mailbox=51
    nat=yes
    canreinvite=no
    

    ich habe Asterisk auf ein Debian Linux installiert und Firewall die Ports freigegeben.

    Linux Firewall Ports Freigabe:

    Code:
    # SIP on UDP port 5060. Other SIP servers may need TCP port 5060 as well 
    iptables -A INPUT -p udp -m udp --dport 5060 -j ACCEPT 
    
    # IAX2- the IAX protocol 
    iptables -A INPUT -p udp -m udp --dport 4569 -j ACCEPT 
    
    # IAX - most have switched to IAX v2, or ought to 
    iptables -A INPUT -p udp -m udp --dport 5036 -j ACCEPT 
    
    # RTP - the media stream 
    iptables -A INPUT -p udp -m udp --dport 10000:20000 -j ACCEPT 
    
    # MGCP - if you use media gateway control protocol in your configuration 
    iptables -A INPUT -p udp -m udp --dport 2727 -j ACCEPT
    
    hat jemand eine Ahnung warum es nicht geht? oder was sollt ich eure Meinung nach einstellen.

    Vielen Dank.
     
  2. thisismyname

    thisismyname Neuer User

    Registriert seit:
    24 Sep. 2008
    Beiträge:
    78
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Student
    Ich geb zu, grosse Ahnung hab ich auch noch nicht... koennte aber sein das das Phone ueber Port 5062 raus geht und Asterisk auf Port 5060 Listened.

    Ueberpruefen kannst du das einfach wenn du mal einen Registrierungsvorgang mit Wireshark mitschneidest.

    greetz
     
  3. 2fast_driver

    2fast_driver Neuer User

    Registriert seit:
    8 Aug. 2008
    Beiträge:
    62
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    alles okey

    hallo,

    hat sich erledigt, der Router war dran schuld.


    jetzt gehts

    Danke