.titleBar { margin-bottom: 5px!important; }

extensions.conf / outbound calls

Dieses Thema im Forum "Asterisk Rufnummernplan" wurde erstellt von wprauchholz, 9 Nov. 2006.

  1. wprauchholz

    wprauchholz Neuer User

    Registriert seit:
    5 Aug. 2006
    Beiträge:
    22
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Barcelona
    Ich bin dabei einen Asterisk Server zu konfigurieren. Es ist alles korrekt kompiliert , interne Anrufe sowie Anrufe (inbound/outbound) üver Zip/1 Kanal funktionieren auch. Ich hänge jetzt mit der Konfiguration der Sip Kanäle fest. Ich bekomme die folgende Meldung:
    Nov 9 16:51:01 NOTICE[2848]: chan_sip.c:11330 handle_request: Unknown SIP command 'PUBLISH' from '192.168.1.5'
    Nov 9 16:51:02 NOTICE[2848]: chan_sip.c:11330 handle_request: Unknown SIP command 'PUBLISH' from '192.168.1.5'
    Nov 9 16:51:02 NOTICE[2848]: chan_sip.c:11330 handle_request: Unknown SIP command 'PUBLISH' from '192.168.1.5'
    -- Executing Dial("SIP/100-0a0a6868", "SIP/00496831000000@sip.peoplecall.com|45|r") in new stack
    -- Called 00496831000000@sip.peoplecall.com
    Nov 9 16:51:04 NOTICE[2848]: chan_sip.c:9750 handle_response_invite: Failed to authenticate on INVITE to '"100" <sip:100@192.168.1.3>;tag=as58f24a1a'
    -- SIP/sip.peoplecall.com-0a0abda8 is circuit-busy
    == Everyone is busy/congested at this time (1:0/1/0)
    Nov 9 16:51:14 WARNING[2931]: pbx.c:2415 __ast_pbx_run: Timeout, but no rule 't' in context 'internal'

    sip show peers gibr mit:
    srv02*CLI> sip show peers
    Name/username Host Dyn Nat ACL Port Status
    101/101 192.168.1.6 D 5060 OK (25 ms)
    100/100 192.168.1.5 D 2054 OK (39 ms)
    peoplecall/34700754265001 62.22.20.194 N 5060 OK (88 ms)
    sipgate/5550873 217.10.79.9 N 5060 Unmonitored

    sip show registriy:
    srv02*CLI> sip show registry
    Host Username Refresh State
    sip.peoplecall.com:5060 34700755555 105 Registered
    sipgate.de:5060 5555555 105 Registered

    Die entsprechende Stelle in der extension.conf für die Anrufe via peoplecall ist:
    ...
    [outbound-germany]
    exten => _0049.,1,Dial,SIP/${EXTEN}@sip.peoplecall.com|45|r


    und die sip.conf hat u.a.
    ...
    register => 34700755555001:70476972@sip.peoplecall.com
    ...
    ...
    [peoplecall]
    type=peer
    host=sip.peoplecall.com
    fromuser=34700755555001
    fromdomain=sip.peoplecall.com
    username=34700755555001
    secret=passwd
    dtmfmode=rfc2833
    qualify=yes
    disallow=all
    allow=g729
    allow=g723
    ;allow=gsm
    ;allow=ulaw
    insecure=very
    nat=yes
    ....

    Vielen Dank für Eure Hilfe
     
  2. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Hallo,

    mit der Fehlermeldung fallen mir zwei Möglichkeiten ein:

    1. dein passwort in der sip.conf lautet im Eintrag [peoplecall] nicht 70476972 oder
    2. die Rufnummer ist ungültig, oder du darfst sie nicht anrufen (z.B. kein Kredit)

    Dein Passwort für deinen peoplecall-Account solltest du schleunigst ändern, sonst benutztden wer um auf deine Kosten zu telefonieren.
     
  3. wprauchholz

    wprauchholz Neuer User

    Registriert seit:
    5 Aug. 2006
    Beiträge:
    22
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Barcelona
    Inzwischen habe ich rausgefunden, dass es bei der angerufenen Nummer geklingelt hat (meine Eltern sind schon richtig genervt von meinen Versuchen)
    Auf der anderen Seite habe ich die selben Probleme, wenn ich die Konfiguration auf sipgate wechsele.
    Kann es ewtas mit der firewall zu tun haben?
     
  4. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Hallo,

    die Fehlermeldung kommt nicht von einer Firewall.

    Erlaube mal als codec gsm!

    Dein Asterisk kann g723 und g729 nur durchleiten, nicht umsetzen.
    Du musst dir entsprechende Lizenzen kaufen, oder dein Telefon/Komputerprogramm muß diese Codecs können und dein Provider oder das Ziel auch.
     
  5. wprauchholz

    wprauchholz Neuer User

    Registriert seit:
    5 Aug. 2006
    Beiträge:
    22
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Barcelona
    Hallo,

    hatte endlich mal wieder Zeit mich ein bisschen Asterisk zuzuwenden. Ich bin wohl ein Schritt weiter, aber es funktioniert noch nicht. Ich bin mir sicher, dass er wohl nur eine Kleinigkeit ist.
    Erstmals habe ich mir den Codec g729 installiert.
    srv02*CLI> show g729
    0/0 encoders/decoders of 1 licensed channels are currently in use

    Alle sind angemeldet:
    srv02*CLI> sip show peers
    Name/username Host Dyn Nat ACL Port Status
    101/101 192.168.1.6 D 5060 OK (25 ms)
    100/100 192.168.1.5 D 2057 OK (40 ms)
    peoplecall/34700754265003 62.22.20.194 N 5060 OK (87 ms)
    sipgate/5550873 217.10.79.9 N 5060 Unmonitored
    4 sip peers [4 online , 0 offline]

    srv02*CLI> sip show registry
    Host Username Refresh State
    sip.peoplecall.com:5060 347007542650 105 Registered
    sipgate.de:5060 5550873 105 Registered


    Wenn ich mich jetzt aber versuch anzurufen über sipgate, bekomme ich die folgende Meldung:
    Nov 15 19:16:39 NOTICE[2404]: chan_sip.c:11330 handle_request: Unknown SIP command 'PUBLISH' from '192.168.1.5'
    Nov 15 19:16:40 NOTICE[2404]: chan_sip.c:11330 handle_request: Unknown SIP command 'PUBLISH' from '192.168.1.5'
    Nov 15 19:16:40 NOTICE[2404]: chan_sip.c:11330 handle_request: Unknown SIP command 'PUBLISH' from '192.168.1.5'
    Nov 15 19:16:40 NOTICE[2404]: chan_sip.c:11330 handle_request: Unknown SIP command 'PUBLISH' from '192.168.1.5'
    -- Executing Dial("SIP/100-0a1374a0", "SIP/0034616146306@sipgate.de|30") in new stack
    -- Called 0034616146306@sipgate.de
    Nov 15 19:16:45 NOTICE[2404]: chan_sip.c:9750 handle_response_invite: Failed to authenticate on INVITE to '"100" <sip:100@192.168.1.3>;tag=as7e5556fb'
    -- SIP/sipgate.de-0a13c9e0 is circuit-busy
    == Everyone is busy/congested at this time (1:0/1/0)
    Nov 15 19:16:55 WARNING[2619]: pbx.c:2415 __ast_pbx_run: Timeout, but no rule 't' in context 'internal'

    Da muss wohl ein Fehler entweder in der sip.conf oder in der extensions.conf sein. Die sehen so aus:
    sip.conf
    [general]
    context=default
    srvlookup=yes
    port = 5060 ; puerto donde escucha asterisk
    disallow=all ; por defecto todos fuera
    allow=g729 ; permitimos g729
    allow=g723 ; permitimos g723
    allow=gsm ; permitimos gsm
    useragent=IPN
    tos=0x18
    ...
    [sipgate]
    type=peer
    username=5550873
    fromuser=5550873
    secret=XXXXXXX
    host=sipgate.de
    fromdomain=sipgate.de
    insecure=very
    canreinvite=no
    nat=yes
    disallow=all
    allow=ulaw

    ...
    [100]
    type=friend
    secret=100
    qualify=yes ; Qualify peer is no more than 2000 ms away
    nat=yes ; This phone is not natted
    host=dynamic ; This device registers with us
    canreinvite=no ; Asterisk by default tries to redirect
    context=internal ; the internal context controls what we can do

    extensions.conf
    ....
    [internal]
    include => outbound-spain
    include => outbound-germany

    exten => 100,1,Dial(${100},,r)
    exten => 101,1,Dial(${101},,r)


    [outbound-spain]
    exten => _9XXXXXXXX,1,Dial(${OUTBOUNDPSTN}/${EXTEN})
    exten => _9XXXXXXXX,2,Congestion( )
    exten => _9XXXXXXXX,102,Congestion( )

    [outbound-germany]
    exten => _0034616146306,1,Dial(SIP/${EXTEN}@sipgate.de,30)

    Was mache ich falsch?
     
  6. stefanwillmerot

    stefanwillmerot Neuer User

    Registriert seit:
    6 Okt. 2006
    Beiträge:
    115
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Amsterdam
    Versuch mal, hier das .de wegzulassen, also Dial(SIP/${EXTEN}@sipgate,30)

    Könnt sein, dass der * sonst den Peer nicht erkennt und anonym rausgeht. Bei mir jedenfalls funktioniert es so.

    Saludos
    Stefan
     
  7. ich1234

    ich1234 Mitglied

    Registriert seit:
    12 Dez. 2004
    Beiträge:
    231
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Das heisst das du nur die Rufnummer 0034... anrufen kannst.

    in dieser Zeile wird festgelegt das sobald die nummer 0034.. gewählt wird diese über sipgate angerufen werden soll. außerdem sollte es @sipgate heissen da du diesen kontext in deiner sip.cof so definiert hast.
     
  8. wprauchholz

    wprauchholz Neuer User

    Registriert seit:
    5 Aug. 2006
    Beiträge:
    22
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Barcelona
    Ich weiss, aber ich habe die N ummer aus Testzwecken so reingeschrieben. Sobald es funktioniert werde ich _0034616146306 durch _0049. erzetzen


    Danke für Eure Hilfe. Werde ich jetzt mal probieren.
     
  9. wprauchholz

    wprauchholz Neuer User

    Registriert seit:
    5 Aug. 2006
    Beiträge:
    22
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Barcelona
    ¡Excelente!
    Da war der Tipp. Vielen Dank.
    Als nächstes jetzt die ankommenden Anrufe konfigurieren.....