[Problem] Führende Nullen fehlen...(Type of Number)

zu3st

Neuer User
Mitglied seit
17 Jul 2008
Beiträge
37
Punkte für Reaktionen
0
Punkte
0
Hallo,
Irgendwie wertet mein Asterisk den "Type of Number" nicht aus.
zumindest verschluckt er die führenden Nullen.
Die werden ja auch nicht gesendet sonder nur über den CALLINGTON signalisiert:
Normalerweise wertet der Asterisk das ja selbstständig aus und setzt entsprechend den national und internationalprefix. Aber hier nicht...
Deshalb habe ich mal den CALLINGTON ausgeben lassen und der ist immer 1.
was stimmt den hier nicht?
Ich weiß echt nicht mehr weiter, vielleicht habt ihr noch nen Tipp.
localdialplan und prilocaldialplan habe ich schon auf dynamic, normal, local und unknown gesetzt, ohne erfolg.
Wäre echt toll wenn ihr noch eine Idee habt.
folgende Konstellation:
Debian 6
verbaut ist eine Junghanns.Net SingleE1 (rev 1) Karte, dementsprechend der Treiber:
jnet-dahdi 1.0.11 (for DAHDI 2.5.0) (www.junghanns.net/en/download.html)
Rest selbst gebaut von asterisk.org:
LibPRI 1.4.12 Source Tarball (www.asterisk.org/downloads)
Asterisk 1.8.6.0 Source Tarball (www.asterisk.org/downloads)
Der Asterisk soll als VOIP-GW für eine HICOM dienen:
Er ist also als AMT EUROISDN eingerichtet.
/etc/dahdi/system.conf:
Code:
loadzone=de
defaultzone=de
span=1,1,0,ccs,hdb3,crc4
bchan=1-15,17-31
hardhdlc=16
echocanceller=oslec,1-15,17-31
/etc/asterisk/chan_dahdi.conf:
Code:
[channels]
language=de
switchtype = euroisdn
signalling = pri_net
overlapdial = both
immediate = no
pridialplan = dynamic
prilocaldialplan = dynamic
usecallerid = yes
usecallingpres = yes
nationalprefix = 0
internationalprefix = 00
echocancel = yes
group = 1
context = von_RFH_TK
channel => 1-15,17-31
 
Zuletzt bearbeitet:

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,162
Beiträge
2,030,813
Mitglieder
351,555
Neuestes Mitglied
nicklas2727