.titleBar { margin-bottom: 5px!important; }

Failed to authenticate on INVITE to...

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von Haendsche, 30 Sep. 2008.

  1. Haendsche

    Haendsche Neuer User

    Registriert seit:
    30 Sep. 2008
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #1 Haendsche, 30 Sep. 2008
    Zuletzt bearbeitet: 4 Nov. 2014
    Hi zusammen bin ganz frisch hier und hoffe auf ein wenig Hilfestellung;)

    Ich habe im Moment ein Problem aber ich weiß noch nicht ob es beim Anbieter oder an der Konfiguration liegt.

    Intern telefonieren funktioniert super aber sobald ich versuche raus zu telefonieren kommt folgende Meldung:

    Code:
    -- Executing AGI("SIP/30-08203ed0", "agi_rufnummernfreigabe.php|30|")
        -- Launched AGI Script /var/lib/asterisk/agi-bin/agi_rufnummernfreigabe.php
        -- AGI Script agi_rufnummernfreigabe.php completed, returning 0
        -- Executing GotoIf("SIP/30-08203ed0", "0?11")
        -- Executing GotoIf("SIP/30-08203ed0", "0?17")
        -- Executing GotoIf("SIP/30-08203ed0", "0?23")
        -- Executing GotoIf("SIP/30-08203ed0", "0?29")
        -- Executing GotoIf("SIP/30-08203ed0", "0?35")
        -- Executing GotoIf("SIP/30-08203ed0", "0?41")
        -- Executing GotoIf("SIP/30-08203ed0", "1?47")
        -- Goto (custom,)
        -- Executing Set("SIP/30-08203ed0", "CALLERID(num)=30")
        -- Executing GotoIf("SIP/30-08203ed0", "1?51")
        -- Goto (custom,)
        -- Executing Dial("SIP/30-08203ed0", "SIP/@5643179843")
        -- Called @5643179843
    [Sep 30 17:59:06] NOTICE[3732]: chan_sip.c:12322 handle_response_invite: Failed to authenticate on INVITE to '"30" <sip:30@90.100.100.40>;tag=as15bc6137'
        -- SIP/5643179843-08207e48 is circuit-busy
      == Everyone is busy/congested at this time (1:0/1/0)
        -- Executing Hangup("SIP/30-08203ed0", "")
      == Spawn extension (custom, , 52) exited non-zero on 'SIP/30-08203ed0'
    
    

    Hier noch die sip.conf

    Code:
    [general]
    videosupport=yes
    
    ; Abschnitt für SNOM-LEDs
    ; allowsubscribe=yes
    notifyringing=yes
    subscribecontext=custom
    ; notifyhold=yes
    ; useclientcode=yes
    ; //
    
    allowsubscribe=yes 
    notifybusy=yes 
    limitonpeer=yes 
    notifyhold=no 
    call-limit = 5
    ;incominglimit = yes
    
    port = 5060
    bindaddr = 0.0.0.0
    context = default
    realm = voip.name.ch
    externip = 90.100.100.40
    localnet = 192.168.0.0/255.255.255.0
    videosupport=yes
    srvlookup = yes
    nat = yes
    
    qualify=no
    canreinvite=no
    context=default
    
    relaxdtmf= yes
    language = de
    rtptimeout = 120
    maxexpirey = 2000
    defaultexpirey = 2000
    disallow = all 
    allow = ulaw 
    allow = alaw 
    allow = h263
    allow = h261
    allow = h263p
    allow = h264$
    
    ;[SIP-Anschluesse] <-- nicht löschen
    register => 5643179843:92365815@sip.dynamic-phone.ch/5643179843
    
    ;[Nebenstellen]
    [5643179843]
    context = custom
    type = friend
    secret = 92365815
    host = sip.dynamic-phone.ch
    dtmfmode = rfc2833
    nat = no
    sendrpid = yes
    subscribecontext = custom
    callerid = 
    canreinvite = no
    qualify = no
    insecure = very
    disallow = all
    allow = g726
    allow = g729
    allow = alaw
    allow = ulaw
    call-limit = 8
    
    
    [29]
    context = custom
    type = friend
    secret = 29
    host = dynamic
    dtmfmode = rfc2833
    nat = no
    sendrpid = yes
    subscribecontext = custom
    callerid = 29
    canreinvite = yes
    qualify = yes
    insecure = no
    disallow = all
    allow = ulaw
    allow = alaw
    allow = g729
    allow = g726
    call-limit = 8
    
    [30]
    context = custom
    type = friend
    secret = 30
    host = dynamic
    dtmfmode = rfc2833
    nat = no
    sendrpid = yes
    subscribecontext = custom
    callerid = 30
    canreinvite = yes
    qualify = yes
    insecure = no
    disallow = all
    allow = ulaw
    allow = alaw
    allow = g729
    allow = g726
    call-limit = 8
    
    

    und die extensions.conf

    Code:
    [general]
    static=yes
    writeprotect=no
    
    [custom]
    include => internal
    include => incoming
    include => outgoing
    include => callout
    
    exten => 29,hint,SIP/29
    exten => 30,hint,SIP/30
    
    
    [internal]
    switch => Realtime/internal@realtime_ext
    
    [incoming]
    switch => Realtime/incoming@realtime_ext
    
    [outgoing]
    switch => Realtime/outgoing@realtime_ext
    
    [callout]
    switch => Realtime/callout@realtime_ext
    
    Wie gesagt wenn ich Intern von 29 zu 30 und umgekehrt telefoniere klappt alles wunderbar nur wenn ich z.B. von 29 auf eine externe nummer anrufen will kommt die Meldung.

    Grüße Haensche


    Edit: Habe mit X-Lite, Snom M3 und Snom 300 getestet.

    Hat sich erledigt funktioniert wieder. danke für die tipps
     
  2. Burmann

    Burmann Mitglied

    Registriert seit:
    16 Feb. 2005
    Beiträge:
    372
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ein bisschen viele ***** in deiner config. So kann ich nur vermuten, dass du nicht über den registrierten Account 'raustelefonieren willst.
     
  3. Haendsche

    Haendsche Neuer User

    Registriert seit:
    30 Sep. 2008
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    will halt nicht wegen der sicherheit etc zuviel preisgeben, wo soll ich denn mehr angaben lassen damit es besser ersichtlich ist?
     
  4. Burmann

    Burmann Mitglied

    Registriert seit:
    16 Feb. 2005
    Beiträge:
    372
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    1.) Überprüfe ob du richtig angemeldet bist
    "sip show registry" und wenn "qualify=yes" setht wird permanet überprüft ob der Provider erreichbat ist
    2.) Es ist nicht ersichtlich was Passiert, wenn du "5643179843" von einem Anderen Telefon anruftst. Evtl felt
    "exten => 5643179843,hint,SIP/29" (o.ä.)
    in Sektion [custom]. Also teste was passiert wenn man den Sip-Account (z.B. vom Handy aus) anruft.

    3.) Vieleicht stört sich dein Provider an deiner CID. Füge vor dem Dial
    '-- Executing Dial("SIP/30-08203ed0", "SIP/0795800779@5643179843")' ein 'Set(CALLERID(all)=""<5643179843>)' ein.
     
  5. Haendsche

    Haendsche Neuer User

    Registriert seit:
    30 Sep. 2008
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    danke für die tipps

    sip show registry zeigt an das ich angemeldet bin

    sip.dynamic-phone.ch:5060 5643179843 585 Registered Wed, 01 Oct 2008 18:57:46

    von einem anderen telefon komme ich im moment noch gar nicht rein da ist die rufgruppe noch nicht richtig eingestellt.

    aber habe exten => .... mal sicherheitshalber hinzugefügt

    und mit der callerid vor dem dial also dann nur

    Set(CALLERID(all)=""<5643179843>)

    oder in verbindung mit

    Set(CALLERID(num)=30

    und am anbieter wirds nicht liegen auf einem anderen server mit dem sip trunk hat alles funktioniert nur was komisch ist das die sip extensions.conf gleich sind auch der anrufplan stimmt überein. werde es sonst mal noch mit einer neueren version von asterisk probieren habe im moment 1.4.21.1 ev geht es mit 1.4.21.2 wieder.
     
  6. Burmann

    Burmann Mitglied

    Registriert seit:
    16 Feb. 2005
    Beiträge:
    372
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Vielleicht schnappt auch dein Router irgendwelche Sip-Nachrichten deinem Asterisk weg...