.titleBar { margin-bottom: 5px!important; }

FB 7170 + OpenVPN tun device nicht gefunden

Dieses Thema im Forum "FRITZ!Box Fon: Modifikationen" wurde erstellt von nero-15, 10 März 2009.

  1. nero-15

    nero-15 Neuer User

    Registriert seit:
    10 März 2009
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Guten Mittag,
    ich bin dabei mittels openvpn auf meiner Fritz!Box einen VPN-Server mit preshared key einzurichten.
    Alle Dateien liegen auf einem USB-Stick (Fat-32).
    Firmware auf der Fritzbox 7170: 29.04.67
    Ich glaube es handelt sich um eine 7170v2 bin mir allerdings nicht sicher.

    vpn_server.config von www.tecchannel.de
    Code:
    dev tun0
    dev-node /dev/misc/net/tun
    ifconfig 192.168.200.2 192.168.200.1
    tun-mtu 1500
    float
    mssfix
    
    #Pfad zum Key File
    secret ./secret.key
    
    #Protokoll auf TCP und Port 1194
    proto tcp-server
    port 1194
    
    #Protokollierung auf 4
    verb 4
    
    #Routen setzen, bei route Subnetz des Clients eintragen
    route 192.168.1.0 255.255.255.0
    
    #Verbindung erhalten
    ping 15
    ping-restart 120
    
    Ich starte den server als daemon mit:

    ./openvpn --config ./vpn_server.config &

    Folgende Fehlermeldungen erhalte ich dann:

    Code:
    Tue Mar 10 15:17:35 2009 us=718499 OpenVPN 2.1_rc15 mipsel-linux [SSL] [LZO2] [EPOLL] built on Feb 20 2009
    Tue Mar 10 15:17:35 2009 us=722438 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
    Tue Mar 10 15:17:35 2009 us=729555 WARNING: file './secret.key' is group or others accessible
    Tue Mar 10 15:17:35 2009 us=795581 Static Encrypt: Cipher 'BF-CBC' initialized with 128 bit key
    Tue Mar 10 15:17:35 2009 us=796502 Static Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
    Tue Mar 10 15:17:35 2009 us=798508 Static Decrypt: Cipher 'BF-CBC' initialized with 128 bit key
    Tue Mar 10 15:17:35 2009 us=799171 Static Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
    Tue Mar 10 15:17:35 2009 us=808892 Note: Cannot open TUN/TAP dev /dev/misc/net/tun: No such file or directory (errno=2)
    Tue Mar 10 15:17:35 2009 us=809365 Note: Attempting fallback to kernel 2.2 TUN/TAP interface
    Tue Mar 10 15:17:35 2009 us=809978 Cannot open TUN/TAP dev /dev/misc/net/tun: No such file or directory (errno=2)
    Tue Mar 10 15:17:35 2009 us=811114 Exiting
    
    Das tun device wird also nicht gefunden. Im Ordner /dev befindet sich auch kein Unterordner misc. Ich frage mich nur wo ist das device hin bzw warum existiert es auf meiner Fritzbox nicht? In keinem Howto wurde ein solches Szenario erwähnt.

    Über einen hilfreichen Kommentar wäre ich sehr glücklich.

    Niklas
     
  2. colonia27

    colonia27 Guest

    Hallo und ein Herzliches
    [​IMG]

    auf die schnelle habe das hier gefunden, könnte/sollte dir helfen. klick
     
  3. nero-15

    nero-15 Neuer User

    Registriert seit:
    10 März 2009
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Vielen Dank für die schnelle Antwort

    Das war genau der Hinweis, der mir gefehlt hat.
    Vielen Dank!
     
  4. colonia27

    colonia27 Guest

    Freut mich geholfen zu haben.
    Dann hau doch noch bitte ein [Gelöst] in den Titel deines Ersten posts.
    Einfach auf Button Ändern --> Erweitert