FB 7270+Openvpn - Neustart nach Verbindungsherstellung

freeetzer

Neuer User
Mitglied seit
22 Jun 2011
Beiträge
6
Punkte für Reaktionen
0
Punkte
0
Hallo,

ich versuche meine Fritzbox als OpenVPN-Server einzurichten. Mit einem tun-interface funktioniert dies auch. Ich möchte aber ein tap-Interface (->PC-Spiele) verwenden. Das Problem dabei: Nachdem erfolgreichen anmelden an OpenVPN von außen (sogar Ping funktioniert) stürzt die Fritzbox nach ca. 5 Sekunden ab und startet sich neu.

Hier das Startscript:
Code:
# Add a nobody user
echo 'nobody:x:65534:65534:nobody:/:/bin/false' >> /var/tmp/passwd
 
# Add some groups
echo 'root:x:0:' > /var/tmp/group
echo 'nobody:x:65534:' >> /var/tmp/group

# tap-Device anlegen, falls noch nicht vorhanden
echo Creating TAP device
mknod /var/tmp/tap0 c 10 200

# ServerOnly: Create virtual ethernet device for accessibility from the internet (192.168.9.3)
sleep 2
ifconfig lan:1 192.168.9.3 netmask 255.255.255.0 broadcast 192.168.9.255 up
sleep 2

# start OpenVPN
echo Starting OpenVPN
cd /var/media/ftp/TE-USB-00/addons
./openvpn/bin/openvpn --config ./openvpn/keys/fritz.tap.ovpn --daemon

# Bridge network
./brctl/bin/brctl addif lan tap0
Die Fritzbox/Server-Config
Code:
# set the path to the tap device
dev tap
dev-node /var/tmp/tap0

mssfix
tun-mtu 1500

# TCP or UDP server
proto udp
port 444

# CA and key files
ca /var/media/ftp/TE-USB-00/addons/openvpn/keys/ca.crt
cert /var/media/ftp/TE-USB-00/addons/openvpn/keys/server.crt
key /var/media/ftp/TE-USB-00/addons/openvpn/keys/server.key

# Diffie hellman parameters
dh /var/media/ftp/TE-USB-00/addons/openvpn/keys/dh1024.pem

# bridge setup
ifconfig 192.168.9.2 255.255.255.0
mode server
tls-server
server-bridge 192.168.9.1 255.255.255.0 192.168.9.200 192.168.9.220
#push "dhcp-option DNS 192.168.9.1"

#ifconfig-pool-persist ipp.txt
client-to-client

# compression?
comp-lzo

# The maximum number of concurrently connected clients we want to
# allow.
max-clients 20

# It's a good idea to reduce the OpenVPN daemon's privileges after
# initialization.
user nobody
group nobody

# Put openvpn in a jail.
chroot /var/media/ftp/TE-USB-00/addons/openvpn

# The persist options will try to avoid accessing certain resources on
# restart that may no longer be accessible because of the privilege
# downgrade.
persist-key
persist-tun

# where to log
log-append /var/media/ftp/TE-USB-00/addons/openvpn/openvpn.log

# verbose level for debugging
verb 4

# make sure the connection is kept alive
keepalive 10 120
Und die Client-Config:
Code:
client

dev tap
proto udp

remote garfield.dyndns-server.com 444
resolv-retry infinite

nobind
persist-key
persist-tun

ca ca.crt
cert flol.crt
key flol.key

ns-cert-type server
comp-lzo
verb 3
Ich hoffe, ihr könnt mir helfen.
 

µRaCoLi

Mitglied
Mitglied seit
22 Sep 2005
Beiträge
239
Punkte für Reaktionen
0
Punkte
0
Nutzt du WLAN? Deaktivier das ggf. mal. Is n Bug in der FW.
 

kiwig

Neuer User
Mitglied seit
5 Sep 2011
Beiträge
18
Punkte für Reaktionen
0
Punkte
1
at dies mit der openvpn geklappt?
 

freeetzer

Neuer User
Mitglied seit
22 Jun 2011
Beiträge
6
Punkte für Reaktionen
0
Punkte
0
Sry, dass ich mich erst jetzt melde, aber ich hatte noch keine Zeit das zu testen: Bis jetzt. Und es liegt tatsächlich am WLan.
Danke dafür!
Wenn ich von unterwegs nun mal auf die Fritzbox zugreifen will, dann muss ich halt über den web-ssl-zugang das wlan deaktivieren und dann auf das NAS, etc. zugreifen.

Weiß vielleicht jemand, ob das demnächst gefixt wird, oder ob avm das egal ist und sich da nix dran ändern wird mit der nächsten Firmware?
Ergänzung: Firmware in der Signatur war nicht aktuell, es ist bereits die 54.05.05 drauf.