.titleBar { margin-bottom: 5px!important; }

FB 7270 VPN dyndns funktioniert - Nur wie eine weiterer IP für Zugriff hinzufügen

Dieses Thema im Forum "FRITZ!Box Fon: Modifikationen" wurde erstellt von derklausi, 20 Sep. 2011.

  1. derklausi

    derklausi Neuer User

    Registriert seit:
    17 Dez. 2006
    Beiträge:
    27
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich weiss nicht mehr wie ich das gemacht habe, aber ich kann über VPN auf eine feste IP in meinem Homenetzwerk von Aussen zugreifen.

    Genauer, unter Verwendung von dyndns.org und der angepasste VPN-Konfigurationsdatei (.cfi) für die Fritzbox hatte ich das so eingerichtet.

    Öffne ich den Browser eines entfernten Rechners über VPN-Verbindung, und gebe die IP in die Adressleiste ein, so öffnet sich die Benutzeroberfläche des Gerätes mit dieser IP in meinem Home-Netzwerk.
    Bei dem Gerät handelt es sich um eine Steckdosenleiste mit Lan-Anschluss, an der ich dann 4 Verbraucher individuell Ein-/Aus-schalten kann.
    Funktioniert prima.

    Alle anderen IPs in meinem Home-Netzwerk werden trotz Eingabe in die Adressleiste des Browsers NICHT erkannt.
    Das war damals auch so gewollt.

    Ich weiss aber ehrlich gesagt nicht, wie ich das genau gemacht habe.
    Durch Herumprobiererei möchte ich jetzt aber nichts verstellen (Don't touch a running System)

    Was will ich ändern:
    Ich möchte von Aussen zusätzlich noch auf eine LAN-Festplatte in meinem Home-Netzwerk zugreifen.
    Nur muss ich diese IP der Festplatte ja irgendwie/irgendwo eingeben.
    Nur wo?
    Soweit ist ja die grundsätzliche Funktion wie beschrieben gegeben.

    Danke für einen Tip.
     
  2. andilao

    andilao IPPF-Promi

    Registriert seit:
    8 Juni 2006
    Beiträge:
    4,340
    Zustimmungen:
    30
    Punkte für Erfolge:
    48
    Da wir nicht wissen, wo Du was in den .cfg-Dateien angepasst hast, erstelle sie doch bitte einfach nach AVM-Anleitung neu. Es sind nur ein paar kleine Schritte.
    1. lösche alles
    2. für einen Benutzer einrichten
    3. Email-Adr. des Benutzers oder beliebige andere Bezeichnung
    4. DynDNS Deiner Box
    5a. Werkseinstellungen übernehmen wenn Deine Box-IP 192.168.178.1 ist oder
    5b. dein IP-Netzwerk eintragen (ja mit .0 am Ende) und IP-Adr. des Benutzers eintragen (außerhalb DHCP-Bereich keine vorhandene IP!)

    Jetzt wäre Dein gesamtes Netzwerk vom VPN-Client aus erreichbar und wenn Du das einschränken willst, änderst Du die "accesslist" der Box-vpncfg:
    Code:
    accesslist = 
               "permit ip 192.168.178.0 255.255.255.0 192.168.178.201 255.255.255.255";
    z.B. für nur 2 IP-Adressen:
    Code:
    accesslist = 
               "permit ip 192.168.178.[B][COLOR="red"]4[/COLOR][/B] 255.255.255.[B][COLOR="red"]255[/COLOR][/B] 192.168.178.201 255.255.255.255"
               "permit ip 192.168.178.[B][COLOR="red"]8[/COLOR][/B] 255.255.255.[B][COLOR="red"]255[/COLOR][/B] 192.168.178.201 255.255.255.255";
    (Beispiel mit Werkseinstellungen!)
     
  3. derklausi

    derklausi Neuer User

    Registriert seit:
    17 Dez. 2006
    Beiträge:
    27
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #3 derklausi, 20 Sep. 2011
    Zuletzt bearbeitet: 20 Sep. 2011
    Hier meine angepasste Konfigurationsdatei, die ich damals in die FRITZ!Box importiert habe.
    Damit funktioniert bislang NUR diese eine IP der Lan-Steckdose. Ist ja soweit OK.
    Andere IPs von Geräten die über Lan an die FritzBox angeschlossen sind funktionieren nicht.


    vpncfg {
    connections {
    enabled = yes;
    conn_type = conntype_user;
    name = "Meine Benutzer-eMail@me.com"; (habe ich geändert in "Meine Benutzer-eMail@me.com")
    always_renew = no;
    reject_not_encrypted = no;
    dont_filter_netbios = yes;
    localip = 0.0.0.0;
    local_virtualip = 0.0.0.0;
    remoteip = 0.0.0.0;
    remote_virtualip = 192.168.133.201;
    remoteid {
    key_id = "Benutzer-eMail@me.com"; (habe ich geändert von "user_fqdn" in "key_id")
    }
    mode = phase1_mode_aggressive;
    phase1ss = "all/all/all";
    keytype = connkeytype_pre_shared;
    key = "Mein VPN Kennwort"; (habe ich geändert von "key" in "Mein VPN Kennwort")
    cert_do_server_auth = no;
    use_nat_t = yes;
    use_xauth = yes; (habe ich geändert von "no" in "yes")
    use_cfgmode = no;
    xauth {
    valid = yes;
    username = "Mein VPN Benutzername"; (habe ich geändert in "Mein VPN Benutzername")
    passwd = "Mein VPN Kennwort"; (habe ich geändert in "Mein VPN Kennwort")
    }
    phase2localid {
    ipnet {
    ipaddr = 0.0.0.0; (habe ich geändert in "0.0.0.0")
    mask = 0.0.0.0; (habe ich geändert in "0.0.0.0")
    }
    }
    phase2remoteid {
    ipaddr = 192.168.133.201;
    }
    phase2ss = "esp-all-all/ah-none/comp-all/no-pfs"; (habe ich geändert in ……no-pfs")
    accesslist =
    "permit ip 0.0.0.0 0.0.0.0 192.168.133.201 255.255.255.255"; (habe ich so geändert)
    }
    ike_forward_rules = "udp 0.0.0.0:500 0.0.0.0:500",
    "udp 0.0.0.0:4500 0.0.0.0:4500";
    }



    Weil ich VPN-Verbindungen unter iOS (iPhone) nutze habe ich im Wert des Eintrags "acesslist" wie folgt ändern:
    acesslist = "permit ip 0.0.0.0 0.0.0.0 192.168.133.201 255.255.255.255";



    Wie gesagt, so funktioniert es bislang.