.titleBar { margin-bottom: 5px!important; }

FB3070 hängt sich durch Mod auf

Dieses Thema im Forum "FRITZ!Box Fon: Modifikationen" wurde erstellt von Domyo, 25 Sep. 2008.

  1. Domyo

    Domyo Neuer User

    Registriert seit:
    19 März 2007
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo zusammen.
    Mein Ziel ist es OpenVPN auf meiner FB zum laufen zu bringen.
    Dafür habe ich mir eine debug.cfg geschrieben, die meiner Meinung nach alles beinhaltet, was dafür nötig ist.
    Allerdings ist die FB nach einem reboot mit dieser debug.cfg nach kurzer Zeit nicht mehr erreichbar und ich muss nach dem reseten ganz schnell per Weboberfläche die debug.cfg leeren.

    1. Warum hängt sich die FB auf?
    2. Ist die cfg in Bezug auf Open VPN korrekt? Gerade was den virtuellen Adapter betrifft bin ich mir nicht sicher ob das so funktioniert.
    Mein Netz:
    192.168.1.0 / 24
    FB: 192.168.1.10
    DHCP: 192.168.1.1 - 192.168.0.8
    IP des OpenVPN Clients: 192.168.2.1


    Hier der Code:
    Code:
    #### Erstellen von Tunnel Device
    mknod /var/tmp/tun c 10 200
    
    ### Erstellen des virtuellen Devices
    sleep 10
    ifconfig eth0:1 192.168.3.1 netmask 255.255.255.0 broadcast 192.168.3.255 up
    
    ### Erstellen des secret.key
    cat > /var/tmp/secret.key << 'ENDSECRETKEY'
    
    -----BEGIN OpenVPN Static key V1-----
    :)
    -----END OpenVPN Static key V1-----
    
    ENDSECRETKEY
    
    ### Erstellen der server.ovpn
    cat > /var/tmp/server.ovpn << 'ENDSERVERCONF'
    dev tun0
    dev-node /dev/misc/net/tun
    ifconfig 192.168.2.2 192.168.2.1
    tun-mtu 1500
    float
    mssfix
    
    #Pfad zum Key File
    secret /var/tmp/secret.key
    
    #Protokoll auf TCP und Port 1194
    proto tcp-server
    port 1194
    
    #Protokollierung auf 4
    verb 4
    
    #Route auf Subnetz des Clients
    route 192.168.1.0 255.255.255.0
    
    #Verbindung erhalten
    ping 15
    ping-restart 120
    ENDSERVERCONF
    
    #### Laden der Dateien
    wget -qO /var/tmp/busybox http://192.168.1.9/fritzbox/busybox
    wget -qO /var/tmp/openvpn http://192.168.1.9/fritzbox/openvpn
    
    #Ausführbar machen
    chmod +x /var/tmp/busybox
    chmod +x /var/tmp/openvpn
    chmod 0600 /var/tmp/server.ovpn
    chmod 0600 /var/tmp/secret.key
    
    #### Starten der Dienste
    /usr/sbin/telnetd -l /sbin/ar7login
    /var/tmp/openvpn --config /var/tmp/server.ovpn
    Zudem kann ich, warum auch immer, keine Pseudo Firmware mehr von the-construct.org einspielen.
    Früher ging das mal aber auch nach einem recover funktioniert es nicht.
    Die telnet Aktivierung funktioniert, dafür habe ich aber eine andere Pseudo Firmware.
    Deswegen muss ich alles per telnet erledigen!

    Hoffe auf eure Hilfe, sitze schon seit 3 Tagen an der Geschichte.
     
  2. Domyo

    Domyo Neuer User

    Registriert seit:
    19 März 2007
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Vielen Dank ! ...
     
  3. Ecki-No1

    Ecki-No1 IPPF-Promi

    Registriert seit:
    28 Mai 2006
    Beiträge:
    6,280
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    selbständiger PC-Techniker
    Ort:
    im geilen Süden (48.04°N 11.52°O)
    Und, wie hast Du es gelöst?
     
  4. Bibie

    Bibie Aktives Mitglied

    Registriert seit:
    4 Juli 2008
    Beiträge:
    2,872
    Zustimmungen:
    4
    Punkte für Erfolge:
    0
    Beruf:
    Bürokauffrau, jetzt Hausfrau
    Ort:
    im Grünen Herzen Deutschlands
    @ecki, ich glaube gar nicht, er hat sich wohl für die "Nichthilfe" bedankt...
     
  5. Domyo

    Domyo Neuer User

    Registriert seit:
    19 März 2007
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Nicht gelöst, werde mir jetzt die 3170 zulegen, die unterstützt vpn von Haus aus.