.titleBar { margin-bottom: 5px!important; }

FBF WLAN hinter fli4l (3.0.0) kommt nicht (richtig) ins Internet

Dieses Thema im Forum "FRITZ!Box Fon: DSL, Internet und Netzwerk" wurde erstellt von Linus_Pauling, 20 Nov. 2006.

  1. Linus_Pauling

    Linus_Pauling Neuer User

    Registriert seit:
    13 Mai 2005
    Beiträge:
    116
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #1 Linus_Pauling, 20 Nov. 2006
    Zuletzt bearbeitet: 20 Nov. 2006
    Hallo,

    ich habe ein Problem mit einer Fritzbox FON WLAN (08.04.15).
    Sie sitzt hinter einem fli4l 3.0.0 in einem maskierten LAN per Kabel am Switch.

    Ziel: Über die FBF per Sipgate VoIP zu machen. Sonst nichts!

    Allerdings kann sich die FBF nicht bei sipgate anmelden. Habe schon viel Fehlersuche betrieben und bemerkt, dass die FBF nur vom Intranet ansprechbar ist, aber nicht ins Internet senden kann.

    Habe mich dazu per Telnet auf die FBF geloggt und versucht, ins Internet zu pingen mit folgendem Ergebnis:

    # ping www.heise.de
    PING www.heise.de (193.99.144.85): 56 data bytes
    ping: sendto: Network is unreachable

    DNS geht anscheinend, aber raus komme ich nicht.

    Ergo klappt auch die Anmeldung bei sipgate nicht. Die Telnetkonsole zeigt bei einem Anmeldeversuch der FBF folgendes (Anmeldedaten für sipgate auf 1234567 geändert):

    Code:
    # Sep 10 10:05:59 voipd[443]: 0.0.0.0:5060: failed to send UDP-datagram to 217.10.79.2:3478 - Network is unreachable (128)
    Sep 10 10:06:00 voipd[443]: 0.0.0.0:5060: failed to send UDP-datagram to 217.10.79.2:3478 - Network is unreachable (128)
    Sep 10 10:06:02 voipd[443]: 0.0.0.0:5060: failed to send UDP-datagram to 217.10.79.2:3478 - Network is unreachable (128)
    Sep 10 10:06:06 voipd[443]: 0.0.0.0:5060: failed to send UDP-datagram to 217.10.79.2:3478 - Network is unreachable (128)
    Sep 10 10:06:15 voipd[443]: BUG csock_senddgram: called with NULL socket
    Sep 10 10:06:15 voipd[443]: sipudp: senddgram failed (217.10.79.9:5060)
    Sep 10 10:06:15 voipd[443]: BUG csock_senddgram: called with NULL socket
    Sep 10 10:06:15 voipd[443]: sipudp: senddgram failed (217.10.79.9:5060)
    Sep 10 10:06:15 voipd[443]: 1234567@sipgate.de: REGISTER failed 5 status 0 (try again in 1800 seconds)
    
    Ich wäre froh, wenn mir jemand helfen könnte, denn ich finde den Fehler einfach nicht.

    Nachfolgend mal meine Configs, in der jemand vielleicht den Fehler findet.

    fli4l-Config in Auszügen:

    Code:
    [...]
    FORWARD_POLICY='REJECT'
    FORWARD_ACCEPT_DEF='yes'
    FORWARD_LOG='yes'
    FORWARD_LOG_LIMIT='3/minute:5'
    FORWARD_REJ_LIMIT='1/second:5'
    FORWARD_UDP_REJ_LIMIT='1/second:5'
    FORWARD_LIST_N='16'
    FORWARD_LIST_1='tmpl:samba DROP'
    FORWARD_LIST_2='192.168.182.2 ACCEPT' #FBF
    FORWARD_LIST_3='192.168.182.3 ACCEPT' #Server
    FORWARD_LIST_4='192.168.182.10 ACCEPT' #Client 1
    FORWARD_LIST_5='192.168.182.30 ACCEPT'
    FORWARD_LIST_6='192.168.182.40 ACCEPT'
    FORWARD_LIST_7='192.168.182.50 ACCEPT'
    FORWARD_LIST_8='192.168.182.51 ACCEPT'
    FORWARD_LIST_9='192.168.182.60 ACCEPT'
    FORWARD_LIST_10='192.168.182.70 ACCEPT'
    FORWARD_LIST_11='1214 DROP'
    FORWARD_LIST_12='4661-4672 DROP'
    FORWARD_LIST_13='6881-6889 DROP'
    FORWARD_LIST_14='6346 DROP'
    FORWARD_LIST_15='4200 DROP'
    FORWARD_LIST_16='192.168.182.20 ACCEPT'
    POSTROUTING_LIST_N='1'
    POSTROUTING_LIST_1='IP_NET_1 MASQUERADE'
    [...]
    PORTFW_N='13'
    PORTFW_1_TARGET='4992'
    PORTFW_1_NEW_TARGET='192.168.182.3:4992'
    PORTFW_1_PROTOCOL='tcp'
    PORTFW_2_TARGET='6884'
    PORTFW_2_NEW_TARGET='192.168.182.3:6884'
    PORTFW_2_PROTOCOL='tcp'
    PORTFW_3_TARGET='6346'
    PORTFW_3_NEW_TARGET='192.168.182.3:6346'
    PORTFW_3_PROTOCOL='tcp'
    PORTFW_4_TARGET='5190'
    PORTFW_4_NEW_TARGET='192.168.182.10:5190'
    PORTFW_4_PROTOCOL='tcp'
    PORTFW_5_TARGET='10369'
    PORTFW_5_NEW_TARGET='192.168.182.10:10369'
    PORTFW_5_PROTOCOL='tcp'
    PORTFW_6_TARGET='10369'
    PORTFW_6_NEW_TARGET='192.168.182.10:10369'
    PORTFW_6_PROTOCOL='udp'
    PORTFW_7_TARGET='5060-5065'
    PORTFW_7_NEW_TARGET='192.168.182.2'
    PORTFW_7_PROTOCOL='udp'
    PORTFW_8_TARGET='5070-5072'
    PORTFW_8_NEW_TARGET='192.168.182.2'
    PORTFW_8_PROTOCOL='udp'
    PORTFW_9_TARGET='3478-3479'
    PORTFW_9_NEW_TARGET='192.168.182.2'
    PORTFW_9_PROTOCOL='udp'
    PORTFW_10_TARGET='8000-8012'
    PORTFW_10_NEW_TARGET='192.168.182.2'
    PORTFW_10_PROTOCOL='udp'
    PORTFW_11_TARGET='5000-5004'
    PORTFW_11_NEW_TARGET='192.168.182.2'
    PORTFW_11_PROTOCOL='udp'
    PORTFW_12_TARGET='30000-30021'
    PORTFW_12_NEW_TARGET='192.168.182.2'
    PORTFW_12_PROTOCOL='udp'
    PORTFW_13_TARGET='10000-10012'
    PORTFW_13_NEW_TARGET='192.168.182.2'
    PORTFW_13_PROTOCOL='udp'
    [...]
    HOSTS_N='11'
    HOST_1_NAME='Router'
    HOST_1_IP='192.168.182.1'
    HOST_1_ALIAS_N='1'
    HOST_1_ALIAS_1='router.xxx.home'
    HOST_2_NAME='Fritzbox'
    HOST_2_IP='192.168.182.2'
    HOST_2_ALIAS_N='1'
    HOST_2_ALIAS_1='fritzbox.xxx.home'
    [...]


    FBF WLAN - Config:

    Firmware: 08.04.15

    [​IMG]


    Sipgate-Config:
    [​IMG]

    ifconfig auf der FBF meldet:

    Code:
    eth0      Link encap:Ethernet  HWaddr 00:04:0E:82:E7:32
              UP BROADCAST RUNNING PROMISC ALLMULTI MULTICAST  MTU:1500  Metric:1
              RX packets:860 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1131 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:100
              RX bytes:94853 (92.6 KiB)  TX bytes:924729 (903.0 KiB)
    
    lan       Link encap:Ethernet  HWaddr 00:04:0E:82:E7:32
              inet addr:192.168.182.2  Bcast:192.168.182.255  Mask:255.255.255.0
              UP BROADCAST RUNNING ALLMULTI MULTICAST  MTU:1500  Metric:1
              RX packets:858 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1137 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:100
              RX bytes:82721 (80.7 KiB)  TX bytes:925001 (903.3 KiB)
    
    lan:0     Link encap:Ethernet  HWaddr 00:04:0E:82:E7:32
              inet addr:192.168.178.254  Bcast:192.168.178.255  Mask:255.255.255.0
              UP BROADCAST RUNNING ALLMULTI MULTICAST  MTU:1500  Metric:1
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:540 errors:0 dropped:0 overruns:0 frame:0
              TX packets:540 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:64893 (63.3 KiB)  TX bytes:64893 (63.3 KiB)
    
    usbrndis  Link encap:Ethernet  HWaddr 00:04:0E:82:E7:35
              UP BROADCAST ALLMULTI MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:100
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

    Um der Sache auf die Spur zu kommen, habe ich mal X-Lite, das Softphone, auf meinen Client 192.168.182.10 installiert und die VoIP-Ports testweise auf 192.168.182.10 geforwarded. Klappte problemlos in beide Richtungen. Danach alles wieder in den Ursprungszustand versetzt. Ich wußte nun, dass sipgate nicht offline ist und es an der FBF oder am fli4l liegen muß.

    Allerdings komme ich mit allen anderen Clients (192.168.182.3 etc.) nach draussen und habe keinerlei Probleme.

    Ebenfalls getestet habe ich, mir mal auf einem Client die IP der FBF zu geben (FBF vorher natürlich aus). Als WinXP-Client kann ich mit der IP der FBF alles machen. Komme ins Internet etc. Es muß also an der FBF liegen in meinen Augen. Der fli4l macht anscheinend alles richtig.

    Wie gesagt, ich wäre sehr dankbar für einen Hinweis...
    Euer Linus
     
  2. Linus_Pauling

    Linus_Pauling Neuer User

    Registriert seit:
    13 Mai 2005
    Beiträge:
    116
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Boah, jetzt habe ich mir die ganze Arbeit gemacht und bin auf das Naheliegendste nicht gekommen, nämlich mal ein Factory-Reset zu machen und alles neu einzutragen.

    Es geht alles...
    Hat sich also insofern erledigt.
     
  3. voipd

    voipd IPPF-Promi

    Registriert seit:
    5 Mai 2005
    Beiträge:
    3,184
    Zustimmungen:
    1
    Punkte für Erfolge:
    38
    Komisch, sollte aber evtl. nicht gehen. :)

    Der fli4l 3.0.0 hat Probleme mit der Aufloesung der DNS Eintraege die fuer VoIP notwendig sind. (RPT Anfragen oder wie hiessen die nochmal?)

    Deshalb an besten in der Box externe DNS Server eintragen.

    Ich hoffe die Portforwardings passen.

    Also viel Spass damit und obwohl es kein QoS gibt kann man problemlos VoIP und Surfen gleichzeitig. :)


    voipd.
     
  4. Linus_Pauling

    Linus_Pauling Neuer User

    Registriert seit:
    13 Mai 2005
    Beiträge:
    116
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Also bis jetzt läuft es wirklich einwandfrei. Rein wie raus.
    Und wieso gibts kein qos? Also bei mir läuft qos super mit 3.0.0.
     
  5. voipd

    voipd IPPF-Promi

    Registriert seit:
    5 Mai 2005
    Beiträge:
    3,184
    Zustimmungen:
    1
    Punkte für Erfolge:
    38
    Achso,

    ich habe auf dem Router kein QoS aktiviert und kann trotzdem problemlos VoIP und "Internet" gleichzeitig machen. Anscheinen schiebt der Router die Pakete schon richtig weiter und weiss von selbst was wichig ist. :) :)

    voipd.
     
  6. Linus_Pauling

    Linus_Pauling Neuer User

    Registriert seit:
    13 Mai 2005
    Beiträge:
    116
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Dann schick mal ne 20 MB Mail los und mach gleichzeitig VoIP. Das müßte dann rucken...