fehler beim starten von lighttpd + mod_fastcgi

Heisst dies also, dass mein "PHP lässt sich nicht starten"-Problem am Dateisystem auf dem USB Stick liegt??? Welches Dateisystem würdet ihr mir also empfehlen?
 
ext2 am besten. Das ist auf der Box am performantesten. Oder aber auch ext3. Ein wenig sicherer als exct2, aber einen Tucken weniger Performant. Versuch dein Glück, zumindest die eine Fehlermeldung wirst du loswerden, denke ich. Ergo: Step by step oder so ähnlich.
 
Gesagt, getan. Habe den Stick ext3 formatiert und siehe da, die o.g. Fehlermedlungen
sind weg!

PHP lässt sich allerdings immer noch nicht starten!

Hier mal die php.ini (ich könnte schwören, dass der Eintrag "php.ini" unter "Einstellungen"
vorher noch nicht da war...):

Code:
[PHP]
magic_quotes_gpc = Off
engine = On
zend.ze1_compatibility_mode = Off
short_open_tag = Off
asp_tags = Off
precision    =  14
y2k_compliance = On
output_buffering = 4096
zlib.output_compression = On
implicit_flush = Off
unserialize_callback_func=
serialize_precision = 100
allow_call_time_pass_reference = Off
safe_mode = Off
safe_mode_gid = Off
safe_mode_include_dir =
safe_mode_exec_dir =
safe_mode_allowed_env_vars = PHP_
safe_mode_protected_env_vars = LD_LIBRARY_PATH
disable_functions =
disable_classes =
expose_php = On
max_execution_time = 30
max_input_time = 60
memory_limit = 16M
error_reporting  =  E_ALL
display_errors = Off
display_startup_errors = Off
log_errors = On
log_errors_max_len = 1024
ignore_repeated_errors = Off
ignore_repeated_source = Off
report_memleaks = On
track_errors = Off
variables_order = "GPCS"
register_globals = Off
register_long_arrays = Off
register_argc_argv = Off
auto_globals_jit = On
post_max_size = 8M
magic_quotes_gpc = Off
magic_quotes_runtime = Off
magic_quotes_sybase = Off
auto_prepend_file =
auto_append_file =
default_mimetype = "text/html"
doc_root =
user_dir =
extension_dir = "./"
enable_dl = On
file_uploads = On
upload_tmp_dir = /var/tmp/php
upload_max_filesize = 2M
allow_url_fopen = On
allow_url_include = Off
default_socket_timeout = 60
cgi.fix_pathinfo = 1 ;This option is relevant for lighttpd
[Date]
[filter]
[iconv]
[sqlite]
[xmlrpc]
[Pcre]
[Syslog]
define_syslog_variables  = Off
[mail function]
SMTP = localhost
smtp_port = 25
[SQL]
sql.safe_mode = Off
[ODBC]
odbc.allow_persistent = On
odbc.check_persistent = On
odbc.max_persistent = -1
odbc.max_links = -1
odbc.defaultlrl = 4096
odbc.defaultbinmode = 1
[MySQL]
mysql.allow_persistent = On
mysql.max_persistent = -1
mysql.max_links = -1
mysql.default_port =
mysql.default_socket =
mysql.default_host =
mysql.default_user =
mysql.default_password =
mysql.connect_timeout = 60
mysql.trace_mode = Off
[MySQLi]
mysqli.max_links = -1
mysqli.default_port = 3306
mysqli.default_socket =
mysqli.default_host =
mysqli.default_user =
mysqli.default_pw =
mysqli.reconnect = Off
[mSQL]
msql.allow_persistent = On
msql.max_persistent = -1
msql.max_links = -1
[PostgresSQL]
pgsql.allow_persistent = On
pgsql.auto_reset_persistent = Off
pgsql.max_persistent = -1
pgsql.max_links = -1
pgsql.ignore_notice = 0
pgsql.log_notice = 0
[Sybase]
sybase.allow_persistent = On
sybase.max_persistent = -1
sybase.max_links = -1
sybase.min_error_severity = 10
sybase.min_message_severity = 10
sybase.compatability_mode = Off
[Sybase-CT]
sybct.allow_persistent = On
sybct.max_persistent = -1
sybct.max_links = -1
sybct.min_server_severity = 10
sybct.min_client_severity = 10
[bcmath]
bcmath.scale = 0
[browscap]
[Informix]
ifx.default_host =
ifx.default_user =
ifx.default_password =
ifx.allow_persistent = On
ifx.max_persistent = -1
ifx.max_links = -1
ifx.textasvarchar = 0
ifx.byteasvarchar = 0
ifx.charasvarchar = 0
ifx.blobinfile = 0
ifx.nullformat = 0
[Session]
session.save_handler = files
session.use_cookies = 1
session.name = PHPSESSID
session.auto_start = 0
session.cookie_lifetime = 0
session.cookie_path = /
session.cookie_domain =
session.cookie_httponly = 
session.serialize_handler = php
session.gc_probability = 1
session.gc_divisor     = 1000
session.gc_maxlifetime = 1440
session.bug_compat_42 = 0
session.bug_compat_warn = 1
session.referer_check =
session.entropy_length = 0
session.entropy_file =
session.cache_limiter = nocache
session.cache_expire = 180
session.use_trans_sid = 0
session.hash_function = 0
session.hash_bits_per_character = 5
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=fakeentry"
[MSSQL]
mssql.allow_persistent = On
mssql.max_persistent = -1
mssql.max_links = -1
mssql.min_error_severity = 10
mssql.min_message_severity = 10
mssql.compatability_mode = Off
mssql.secure_connection = Off
[Assertion]
[COM]
[mbstring]
[FrontBase]
[gd]
[exif]
[Tidy]
tidy.clean_output = Off
[soap]
soap.wsdl_cache_enabled=1
soap.wsdl_cache_dir="/tmp"
soap.wsdl_cache_ttl=86400


Ich kenne mich leider zu wenig damit aus aber ist es ok, dass z.B. bei
doc_root =
user_dir =
nichts hiner den "=" Zeichen steht?

Was könnte ich noch machen/probieren, um mein PHP zum laufen zu kriegen?
Vielen Dank schonmal für eure Hilfe soweit...
 
Ich habe weiter getestet...

Also es war so: Ich habe unter "Dienste" bei PHP auf "Start" geklickt - ich denke/dachte, man muss PHP manuell starten.

Daraufhin kam als Ausgabe "Starte php:" und eine leere Textbox. Wenn ich dann wieder in der Übersicht der Dienste war, stand bei PHP immer noch "stopped".

Ich habe jetzt aber mal eine PHP Datei mit phpinfo() als Inhalt erstellt und siehe da, wenn ich die Datei im Browser aufrufe, kommen Infos zu PHP...

Also scheint PHP ja doch zu funktionieren, obwohl es als "stopped" markiert ist...
Kann ich mich darauf verlassen das alles funktioniert oder ist dieses Verhalten
merkwürdig??

Vielen dank nochmal für alle Infos und sorry, falls ich unnötig Verwirrung gestiftet habe...
 
php-cgi wird aufgerufen, sobald der Webserver ein PHP-File erkennt. Ergo läuft das Binary nicht. "stopped" scheint da sinnig zu sein.
 
Sollen wir php auch aus den Diensten ausblenden? Ist ja eigentlich kein Daemon.

MfG Oliver
 
@Silent-Tears & @olistudent: habe jetzt keinen Zugang zu meiner Box, aber ich bin mir zu 99,9999% sicher, dass der/die php-Prozess(e) ständig laufen (werden von lighttpd gestartet). Wäre dies nicht der Fall, wäre es kein _fast_cgi mehr.

Schaut' euch das spawn-fcgi-Paket an, welches ich dieses WE eingecheckt habe. Dieses soll meiner Meinung nach die Aufgabe übernehmen, php-cgi zu starten. Vorteile wären:
  • man kann php-cgi direkt kontrollieren und nicht über lighttpd
  • man kann lighttpd sowohl mit php als auch ohne betreiben, ohne ständig die Konfiguration anpassen zu müssen (es reicht einfach php-"dienst" zu beenden)
  • man kann denselben php-cgi-Prozess auch mit anderen Web-Servern teilen bzw. die Integration mit diesen wäre einfacher
 
Kostenlos!

Statistik des Forums

Themen
248,922
Beiträge
2,305,234
Mitglieder
378,647
Neuestes Mitglied
sararararara