Festnetz per SIP nicht erreichbar, per IAX2 ja !?

snakeseven

Neuer User
Mitglied seit
17 Mrz 2006
Beiträge
120
Punkte für Reaktionen
0
Punkte
0
Hi,
wieder ein Rätsel. Auch diesmal komme ich einfach nicht drauf.
Folgendes Call-File funktioniert mit allen SIP-Telefonen, auch dem, welches
an der FB hängt und über VoIP versorgt wird. Nur mit dem Apparat
an der Telekomleitung will es nicht. Genauer gesagt, es klingelt erst gar nicht.
Beim Anrufer wird aber ein Klingeln signalisiert. Über IAX2 gehts, muss also
mit meinen SIP-Einstellungen zu tun haben !?

sip.conf
Code:
[general]
bindport=5060
bindaddr= 85.xx.xx.xx
allow=all

[gmx_out]
type=peer 
username=49303xxxxxx
fromuser=49303xxxxxx
secret=xxxxxx
host=sip.gmx.net
fromdomain=sip.gmx.net
canreinvite=no
nat=no
Call-File (SIP):
Code:
Channel: SIP/[email protected]_out
MaxRetries: 3
RetryTime: 600
WaitTime: 30
Extension: s
Priority: 1
Call-File (IAX2):
Code:
Channel: IAX2/iax_channel/03061xxxxx
MaxRetries: 3
RetryTime: 600
WaitTime: 30
Extension: s
Priority: 1
Kann mir einer sagen, wie ich den Call per SIP auch
aufs Festnetz bekomme, gibt es da was zu beachten ?

Gruss, Seven
 

snakeseven

Neuer User
Mitglied seit
17 Mrz 2006
Beiträge
120
Punkte für Reaktionen
0
Punkte
0
OK, daß es nicht bimmelt lag daran, daß die Nummer in der FB noch als Internetnummer eingetragen war, obwohl das Telefon an der Festnetzbuchse des Splitters hing, da wurde natürlich versucht, übers Internet Verbinung herzustellen. Nachdem ich die Nummer als Festnetznummer festgelegt habe, bimmelt es zwar, aber es werden keine Audiodaten ausgetauscht ? Über IAX geht das alles. Keine Fehlermeldungen im SIP-Debug.

Seven

Update:
Stelle ich als Codec ulaw, alaw, g726 oder gsm ein, passiert gar nichts, nicht einmal Klingeln.
Stelle ich auf allow=all, wird laut SIP-Debug versucht, über g723 zu verbinden, was natürlich nicht klappt, da ich den
auf meinem Asterisk nicht lizensiert habe. Wieso das mit dem ISDN-Codec ulaw(=g711) nicht klappen will, verstehe
ich allerdings nicht !?
 
Zuletzt bearbeitet:

snakeseven

Neuer User
Mitglied seit
17 Mrz 2006
Beiträge
120
Punkte für Reaktionen
0
Punkte
0
Es muss an GMX liegen. Mal gehts mal nicht. Bescheuert.
Seven

Update: Aha, es scheint wohl immer zu gehen, aber sehr oft braucht Asterisk ? GMX ? sehr(!) lange, um beim Verbinden zweier
Teilnehmer sich auf den richtigen Codec zu einigen. Solange ist Stille, mitunter Sekunden. Irgendwann hört man plötzlich die Gegenseite.
Hier nochmal die aktuellen Einstellungen:

sip.conf:
bindport=5060
bindaddr= 85.xx.xx.xx
disallow=all
allow=ulaw
allow=alaw
allow=g726
allow=gsm

[callback]
type=peer
username=493037xxxxx
fromuser=493037xxxxx
secret=passwort
host=sip.gmx.net
fromdomain=sip.gmx.net
canreinvite=no
nat=no
extensions.conf:
[cb]
exten => s,1,Monitor(wav,${MONITOR},mb)
exten => s,n,Dial(${TNR}@callback,,r)
exten => s,n,Hangup
Call-File:
Channel: SIP/[email protected]
Context: cb
Extension: s
Priority: 1
SetVar: MONITOR=Pfad
SetVar: TNR=SIP/030xxxxx
 
Zuletzt bearbeitet:

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,047
Beiträge
2,018,218
Mitglieder
349,337
Neuestes Mitglied
thsem