Fon5010 bootet nicht / Debug Möglichkeiten

frounzn

Neuer User
Mitglied seit
11 Okt 2008
Beiträge
4
Punkte für Reaktionen
0
Punkte
0
Hallo,

Nach einem anscheinend erfolgreichen Firmware-Update von einem feetz Image, bootet die Box nicht mehr. Ich muss dann nimmer das Recovery Image installieren.

Ich habe jetzt auch schon ein Default freetz Image gebaut ( nur "Hardware type" und "Firmware language" gesetzt). Aber die Box startet nach dem flashen trotzdem nicht. Es geht kein dhcp kein Ping etc. Es leuchtet nur die "Power Led" auf der Box.

Welche Möglichkeiten habe ich, das Problem zu lösen ? Gibt es da irgendwelche Debug Möglichkeiten ?

Ich mache das Image unter andLinux mit freetz 1.0. Meine Befehle zum bauen: "make menuconfig und make"

Danke für eure Hilfe.
 
Zuletzt bearbeitet:

matze1985

Aktives Mitglied
Mitglied seit
17 Feb 2007
Beiträge
1,537
Punkte für Reaktionen
0
Punkte
0
um welche Box handelt es sich?
Es wäre auch gut ne config hier anzuhängen.
Welche Brandings hast du ausgewählt? Welches ist auf der Box?


edit: Willkommen im Forum :)
 

frounzn

Neuer User
Mitglied seit
11 Okt 2008
Beiträge
4
Punkte für Reaktionen
0
Punkte
0
FRITZ!Box Fon 5010 Annex A, Firmware-Version 48.04.43
Branding ist AVM.

Config als Attachment hochgeladen.
 

Anhänge

Zuletzt bearbeitet:

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Hi.
Ohne serielle Konsole ist sowas immer schwierig, wenn man nicht auf die Box kommt. Da du wirklich keine Module ausgewählt hast muss es entweder an der uClibc oder busybox liegen.
Du kannst ja mal probieren ob es geht, wenn du in der .config folgende Zeilen änderst:
Code:
FREETZ_INSTALL_BASE=n
FREETZ_REPLACE_BUSYBOX=n
Danach einfwach nochmal "make" eingeben.

Ich kann dir jedoch nicht sagen, ob Freetz damit überhaupt läuft...


MfG Oliver
 

frounzn

Neuer User
Mitglied seit
11 Okt 2008
Beiträge
4
Punkte für Reaktionen
0
Punkte
0
Hallo,

Geht leider nicht:
Code:
STEP 2: MODIFY
applying patches
ERROR: installation of base system is mandatory
make: *** [firmware-nocompile] Error 1
Es müssen beide Optionen auf "y" sein, sonst geht das make nicht durch.

mfg
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Code:
--- fwmod       (Revision 2646)
+++ fwmod       (Arbeitskopie)
@@ -751,7 +751,7 @@
                modlang "${BASE_DIR}/.language" "${FILESYSTEM_MOD_DIR}"
        else
-               error 1 "installation of base system is mandatory"
+               echo1 "installation of base system is mandatory"
        fi
        if [ "$FREETZ_REPLACE_BUSYBOX" == "y" ]; then
@@ -803,7 +803,7 @@
                        error 1 "could not create link for $link"
                done || exit 1
        else
-               error 1 "installation of busybox replacement is mandatory"
+               echo1 "installation of busybox replacement is mandatory"
        fi
        if [ "$FREETZ_REPLACE_KERNEL" == "y" ]; then
Gehts denn so?

MfG Oliver
 

frounzn

Neuer User
Mitglied seit
11 Okt 2008
Beiträge
4
Punkte für Reaktionen
0
Punkte
0
Ja, das Image läßt sich so erstellen, ist sogar über 100 Kb kleiner. Allerdings startet die Box trotzdem nicht an.

Ich teste zuerst immer im Browser http://fritz.box:81 (geht nichts)
dannmache ich ein "ipconfig /release" und ein "ipconfig /renew", aber ich bekomme keine IP-Adresse. Auf der Box leuchtet nur die Power Led. ( so wie nach dem einspielen des Recovery Images, wenn keine Konfiguration vorhanden ist...)

btw: bei mir waren es die Zeilen zu ändern:
730: installation of base system is mandatory
782: installation of busybox replacement is mandatory
in dem File freetz-1.0/fwmod
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Sorry. Ich hab dann keine Idee mehr. Wenn du auf Löten und Basteln stehst, dann kannst du es mit einer seriellen Konsole probieren. ;-)

MfG Oliver
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,904
Beiträge
2,027,994
Mitglieder
351,045
Neuestes Mitglied
linux76