.titleBar { margin-bottom: 5px!important; }

Freenet und Cisco 7960 IP Phoene

Dieses Thema im Forum "Freenet VoIP" wurde erstellt von jojo123, 26 Nov. 2004.

  1. jojo123

    jojo123 Neuer User

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    56
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    ich habe eine Cisco IP Phoen 7960 und betreube den mit Web.de und Sipgate.
    Freenet als dritten Provider kriege ich nicht angemeldet. Es erscheint immer ein X unter den Namen Freenet auf dem Telefon Dispaly das heißt das die Anmeldung nicht da ist. Gibt es was besonderes bei Freenet zu beachten.

    Bitte um Info

    danke
     
  2. RB

    RB Aktives Mitglied

    Registriert seit:
    22 Juni 2004
    Beiträge:
    1,311
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Selbständiger Bitbeißer
    Ort:
    40883 Ratingen
    Moin, Moin!

    Habe zwar selbst keinen Freenet-Zugang, aber trotzdem gerade mal bei Freenet reingeguckt. Liest sich ja gar nicht schlecht...

    Also ich konnte keine Spezialitäten bei den Einstellungen finden! Poste doch mal den entsprechenden Abschnitt aus deiner cnf-Datei. Wenn ich da nix auffälliges finden kann, richte ich mir auch mal einen Zugang ein und probier's selber :wink:

    Übrigens: Was war denn mit den Problemen aus der Cisco-Abteilung? Alle inzwischen gelöst? Wo hat's denn dran gelegen?

    Gruß,
    Ralf
     
  3. jojo123

    jojo123 Neuer User

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    56
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo R.Bisges,

    nach dem Router update geht der Sipgate Account mit

    UDP 5060
    UDP 5004-5007

    aber der Freenet und der WEB.de account hegt nicht. Auf Cisco Dispaly erscheint unter den Namen ein X.

    Hier meine Konfig.

    Vielleicht siehtst du einen Fehler:

    SIPMAC
    Code:
    phone_label: " IP Phoene XXX "
    
    ######################################### Line 1 - Sipgate
    
    proxy1_address: "sipgate.de"
    
    proxy1_port: 5060
    
    line1_name: "XXX"
    
    line1_authname: "XXX"
    
    line1_password: "XXX"
    
    line1_displayname: "XXX"
    
    line1_shortname: "Sipgate"
    
    
    ######################################### Line 2 - UNPROVISIONED
    
    proxy2_address: "sip.web.de"
    
    proxy2_port: 5060
    
    line2_name: "XXX"
    
    line2_authname: "XXX"
    
    line2_password: "XXX"
    
    line2_displayname: "XXX"
    
    line2_shortname: "Web.de"
    
    
    ######################################### Line 3 - UNPROVISIONED
    
    proxy3_address: "iphone.freenet.de"
    
    proxy3_port: 5060
    
    line3_name: "XXX"
    
    line3_authname: "XXX"
    
    line3_password: "XXX"
    
    line3_displayname: "XXX"
    
    line3_shortname: "Freenet"
    
    
    ######################################### Line 4 - UNPROVISIONED
    
    proxy4_address: "UNPROVISIONED"
    
    proxy4_port: 5060
    
    line4_name: "UNPROVISIONED"
    
    line4_authname: "UNPROVISIONED"
    
    line4_password: "UNPROVISIONED"
    
    line4_displayname: "UNPROVISIONED"
    
    line4_shortname: "UNPROVISIONED"
    
    
    ######################################### Line 5 - UNPROVISIONED
    
    proxy5_address: "UNPROVISIONED"
    
    proxy5_port: 5060
    
    line5_name: "UNPROVISIONED"
    
    line5_authname: "UNPROVISIONED"
    
    line5_password: "UNPROVISIONED"
    
    line5_displayname: "UNPROVISIONED"
    
    line5_shortname: "UNPROVISIONED"
    
    
    ######################################### Line 6 - Web.de
    
    proxy6_address: "UNPROVISIONED"
    
    proxy6_port: 5060
    
    line6_name: "UNPROVISIONED"
    
    line6_authname: "UNPROVISIONED"
    
    line6_password: "UNPROVISIONED"
    
    line6_displayname: "UNPROVISIONED"
    
    line6_shortname: "UNPROVISIONED"
    
    
    ######################################### New Parameters added in Release 2.2
    
    voip_control_port: 5060
    
    start_media_port: 5004
    
    end_media_port: 5007
    
    ######################################### New Parameters added in Release 3.0
    
    phone_prompt:   "Cisco7960"
    
    phone_password: "cisco"
    
    user_info: phone
    
    autocomplete: 0
    
    messages_uri: 50000
    

    SIPDEFAULT
    Code:
    ######################################### SIP Default Generic Configuration File
    
    image_version: P0S3-07-2-00
    
    proxy_register: 1
    
    timer_register_expires: 3600
    
    preferred_codec: g711ulaw
    
    tos_media: 5
    
    dtmf_inband: 0
    
    dtmf_outofband: avt
    
    dtmf_db_level: 3
    
    timer_t1: 500
    
    timer_t2: 4000
    
    sip_retx: 10
    
    sip_invite_retx:
    
    timer_invite_expires: 180
    
    #########################################New Parameters added in Release 2.0
    
    tftp_cfg_dir: ""
    
    dial_template: "dialplan"
    
    sntp_server: "ntp.sipgate.net"
    
    sntp_mode: directedbroadcast
    
    time_zone: CET
    
    dst_offset: 1
    
    dst_start_month: April
    
    dst_start_day: ""
    
    dst_start_day_of_week: Sunday
    
    dst_start_week_of_month: 1
    
    dst_start_time: 02
    
    dst_stop_month: Oct
    
    dst_stop_day: ""
    
    dst_stop_day_of_week: Sunday
    
    dst_stop_week_of_month: 8
    
    dst_stop_time: 2
    
    dst_auto_adjust: 1
    
    date_format: YY-M-D
    
    time_format_24hr: 1
    
    dnd_control: 0
    
    callerid_blocking: 0
    
    anonymous_call_block: 0
    
    dtmf_avt_payload: 101
    
    sync: 1
    
    ######################################### New Parameters added in Release 2.1 
    
    ######################################### New Parameters added in Release 2.2
    
    nat_enable: 1
    
    nat_address: "stun.sipgate.net:10000"
    
    nat_received_processing: 1
    
    ######################################### New Parameter added in Release 3.0
    
    cnf_join_enable : 1
    
    ######################################### New Parameters added in Release 3.1
    
    semi_attended_transfer: 1
    
    telnet_level: 2
    
    ######################################### New Parameters added in Release 4.0
    
    services_url: ""
    
    http_proxy_addr: ""
    
    http_proxy_port: 80
    
    dyn_dns_addr_1: ""
    
    dyn_dns_addr_2: ""
    
    dyn_tftp_addr: ""
    
    remote_party_id: 1
    
    ######################################### New Parameters added in Release 4.4
    
    call_hold_ringback: 1
    
    ######################################### New Parameters added in Release 6.0
    
    stutter_msg_waiting: 1
    
    call_stats: 1
    
    autocomplete: 0
    

    Kann es sein das in der SIP DEFAULt dewr Eintrag NAT Adress (ich habe sipgate eingetragen ) die anderen Provider stört.??

    Danke
     
  4. RB

    RB Aktives Mitglied

    Registriert seit:
    22 Juni 2004
    Beiträge:
    1,311
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Selbständiger Bitbeißer
    Ort:
    40883 Ratingen
    Moin!

    Ich habe nat_address auf "" gesetzt und alles funktioniert. Die STUN-Geschichte kann das Cisco definitiv nicht. Wenn schon da ein Eintrag reinkommt, dann die externe(öffentliche) IP-Adresse, die man z.B. über einen DynDNS-Eintrag übermitteln könnte.

    In den *.cfg-Dateien ist erstmal nix böses zu entdecken. Ich weiß jetzt die benötigten Eintragungen für Web.de und Freenet nicht so genau, aber sieht erstmal OK aus.

    Im ersten Posting in diesem Thread sagst Du, daß Freenet als Dritter nicht geht. Daraus hatte ich eigentlich geschlossen, daß Web.de geklappt hat. War das so? Hat es jemals geklappt?

    Bei Web.de könnte man alternativ statt "sip.web.de" auch nur mal "web.de" eintragen. Glaube aber nicht so recht, daß es damit was zu tun hat. Sollte beides gehen.

    Wie war das mit Log-Einträgen im Router? Gibt's bei dem Ding sowas? Waenn ja, was steht drin?

    Letzte Maßnahme: Die Debug-Funktionen des Telefons per Telnet ausnutzen. Damit sollte auf jeden Fall klar werden, was passiert...

    Gruß,
    Ralf
     
  5. muecke77

    muecke77 Neuer User

    Registriert seit:
    5 Jan. 2005
    Beiträge:
    25
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Freenet und Cisco 7960 IP Phone

    Ich habe das gleiche Problem wie beschrieben:

    SIpgate und Web.de laufen sauber, nur mit freenet.de klappt die Anmeldung mit meinem 7960. Gibt es jemanden der freenet mit einem 7960 nutzt?
     
  6. RB

    RB Aktives Mitglied

    Registriert seit:
    22 Juni 2004
    Beiträge:
    1,311
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Selbständiger Bitbeißer
    Ort:
    40883 Ratingen
    Hallo @muecke77 und willkommen im Forum!

    Da keine Antwort mehr kam. habe ich mich auch nicht weiter drum gekümmert. Prinzipiell sollte es gehen. Bist Du in der Lage, per Telnet auf dem Telefon eine Debug-Session zu machen? Das würde auf dem Telefon etwa so aussehen (für freenet == Line 3):
    Code:
    undebug all
    register 0 3
    debug sip-messages
    register 1 3
    ... und nach einer gewissen Zeit (10-20 Sekunden)
    undebug all
    und das Ganze als Mitschnitt hier posten oder per PN an mich senden. Falls Du mehr Infos brauchst, bitte melden :)
     
  7. muecke77

    muecke77 Neuer User

    Registriert seit:
    5 Jan. 2005
    Beiträge:
    25
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    CISCO 7960 und Freenet

    Anbei der Mittschnitt der Authentifizierung:

    register 1 1
    Registering line 1
    [20:44:59] sip_sm_cc_channel_send_buf_fcn: Opened a one-time UDP send channel to
    server <194.97.54.97>:<5060>, handle = 8
    [20:44:59] sip_sm_cc_channel_send_buf_fcn:Sent SIP message to <194.97.54.97>:<50
    60>, handle=<8>:
    message=
    <REGISTER sip:iphone.freenet.de SIP/2.0
    Via: SIP/2.0/UDP 84.135.133.29:5060;branch=z9hG4bK1ed9f25d
    From: sip:xxx@iphone.freenet.de
    To: sip:xxx@iphone.freenet.de
    Call-ID: 00115c40-74580002-34e6003e-7f487074@84.135.133.29
    Date: Fri, 07 Jan 2005 19:44:59 GMT
    CSeq: 102 REGISTER
    User-Agent: CSCO/7
    Contact: <sip:xxx@84.135.133.29:5060>
    Content-Length: 0
    Expires: 500

    >, length=<390>
    [20:44:59] sip_sm_cc_channel_send_buf_fcn: Closed a one-time UDP send channel ha
    ndle = 8
    SIP Phone> [20:44:59] SIPProcessUDPMessage: recv UDP message from <194.97.54.97>
    :<50195>:
    <SIP/2.0 403 Anruf nicht erlaubt
    Via: SIP/2.0/UDP 84.135.133.29:5060;branch=z9hG4bK1ed9f25d
    From: sip:xxx@iphone.freenet.de
    To: sip:xxx@iphone.freenet.de;tag=5f61617ce4661383c5d475661db5b4db.a932
    Call-ID: 00115c40-74580002-34e6003e-7f487074@84.135.133.29
    CSeq: 102 REGISTER
    Content-Length: 0

    >, length=310
    [20:44:59] sipSPICheckResponse: Response match: callid=00115c40-74580002-34e6003
    e-7f487074@84.135.133.29, cseq=102, cseq_method=REGISTER
    [20:44:59]
    %E640 REG msg unsupported: in 403, request failure



    Mein SIPMAC. cnf sieht wie folgt aus:

    proxy1_address: "iphone.freenet.de"
    proxy1_port: 5060
    line1_name: "xxx"
    line1_authname: "xxx"
    line1_password: "passwort"
    line1_displayname: ""
    line1_shortname: "Freenet"


    Hat jemand einen Hinweis, wo der Fehler liegt? Mit der Freenetsoftware klappt es, so dass der Account als solches ok sein sollte.

    Die Meldung %E640 REG msg unsupported: in 403, request failure
    kommt alle paar Sekunden, wobei sie auch erscheint, wenn ich erfolgreich mit GMX, Sipgate oder Web.de angemeldet bin.

    Gruesse
    Muecke
     
  8. muecke77

    muecke77 Neuer User

    Registriert seit:
    5 Jan. 2005
    Beiträge:
    25
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Freenet und Cisco 7960 IP Phoene (geloest )

    Die Zeile

    proxy1_address: "iphone.freenet.de"

    muss

    proxy1_address: "freenet.de"

    lauten.

    Muecke77
     
  9. RB

    RB Aktives Mitglied

    Registriert seit:
    22 Juni 2004
    Beiträge:
    1,311
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Selbständiger Bitbeißer
    Ort:
    40883 Ratingen
    Danke für die Rückmeldung. Ich werde das ganze nächste Woche mal in meine Beispiel-Konfigurationen übernehmen. Da muß sowieso noch der Hinweis rein, daß man die Kommentare für den echten Einsatz entfernen sollte, damit kein Puffer-Überlauf entsteht...
     
  10. kevin79

    kevin79 Neuer User

    Registriert seit:
    19 März 2005
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hey..
    also ich nutze mein 7960 mit freenet... bei mir lag das problem anfangs an den ports..
    wer fragen hat... nur zu!
    viele grüße
    kevin
     
  11. muecke77

    muecke77 Neuer User

    Registriert seit:
    5 Jan. 2005
    Beiträge:
    25
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Wie hast Du denn proxy1_address eingestellt?

    - Muecke77
     
  12. kevin79

    kevin79 Neuer User

    Registriert seit:
    19 März 2005
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    freenet.de (statt iphone.freenet.de)

    Viele Grüße

    Kevin