[Problem] Freetz Devel und PPTP Client, pppd error?

eicher16ps

Neuer User
Mitglied seit
10 Apr 2011
Beiträge
12
Punkte für Reaktionen
0
Punkte
0
Hey,

seit nun ca 5 stunden versuch ich auf meiner alten fritzbox fon und meiner fritzbox 7170 den pptp client zum rennen zu bringen.
Compilen und alles ging auch alles glatt, nur wenn ich den client starten will kommt:

Code:
modprobe: can't load module ppp_generic (kernel/drivers/net/ppp_generic.ko): unknown symbol in module, or unknown parameter
modprobe: can't load module ppp_async (kernel/drivers/net/ppp_async.ko): unknown symbol in module, or unknown parameter
modprobe: can't load module ppp_deflate (kernel/drivers/net/ppp_deflate.ko): unknown symbol in module, or unknown parameter
modprobe: can't load module ppp_mppe_mppc (kernel/drivers/net/ppp_mppe_mppc.ko): unknown symbol in module, or unknown parameter
pppd: Sorry - this system lacks PPP kernel support
Der pppd daemon und alles ist ausgewählt in der menuconfig, wird auch später bei der zusammenfassung mit angezeigt :(

Kennt sich jemand von euch mit der Geschichte pptp und freetz aus?

Danke schonmal
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Was sagt denn "dmesg" zu den Versuchen? Häng bitte deine .config an. Welche Freetz Version verwendest du?

Gruß
Oliver
 

eicher16ps

Neuer User
Mitglied seit
10 Apr 2011
Beiträge
12
Punkte für Reaktionen
0
Punkte
0
Also dmesg sagt:

Code:
ppp_generic: Unknown symbol slhc_toss
ppp_generic: Unknown symbol slhc_compress
ppp_generic: Unknown symbol slhc_free
ppp_generic: Unknown symbol slhc_uncompress
ppp_generic: Unknown symbol slhc_remember
ppp_generic: Unknown symbol slhc_init
ppp_async: Unknown symbol ppp_channel_index
ppp_async: Unknown symbol ppp_register_channel
ppp_async: Unknown symbol ppp_input
ppp_async: Unknown symbol ppp_input_error
ppp_async: Unknown symbol ppp_output_wakeup
ppp_async: Unknown symbol ppp_unregister_channel
ppp_async: Unknown symbol crc_ccitt_table
ppp_async: Unknown symbol ppp_unit_number
ppp_deflate: Unknown symbol ppp_register_compressor
ppp_deflate: Unknown symbol ppp_unregister_compressor
ppp_mppe_mppc: Unknown symbol ppp_register_compressor
ppp_mppe_mppc: Unknown symbol ppp_unregister_compressor
Die freetz version ist die neuste devel aus dem svn branch, habs eben nochmal neu probiert mit der revision 7943 :?
 

Anhänge

RalfFriedl

IPPF-Urgestein
Mitglied seit
22 Apr 2007
Beiträge
12,343
Punkte für Reaktionen
1
Punkte
0
Sieht aus, als würden da Module fehlen, insbesondere crc_ccitt und slhc. Mit etwas Glück sind die anderen Meldungen nur Folgefehler.
 

eicher16ps

Neuer User
Mitglied seit
10 Apr 2011
Beiträge
12
Punkte für Reaktionen
0
Punkte
0
Mhhh hab gerade nochmal die ganze menuconfig und .config durchsucht. Also module slhc und crc_ccitt sind aktiviert. Kann es sein das er beim compilen die config nicht richtig einliest und die module vergisst :? ?
 

eicher16ps

Neuer User
Mitglied seit
10 Apr 2011
Beiträge
12
Punkte für Reaktionen
0
Punkte
0
Also auf der fritzbox sind sie:
Code:
[email protected]:/var/mod/root# ls /lib/modules/2.6.13.1-ohio/kernel/drivers/net/
ppp_async.ko      ppp_generic.ko    rfcntl            wireless
ppp_deflate.ko    ppp_mppe_mppc.ko  slhc.ko

Ich glaub ich habs, ich hab gerade einfach mal ausprobiert wenn ich die module nach und nach lade und hab festgestellt das das startscript einen fehler hat.
Die module müssen irgendwie in einer ganz bestimmten reihenfolge geladen werden,
ich habs in dieser gemach:

slhc
ppp_generic
ppp_deflate
ppp_mppe_mppc
crc_ccitt
ppp_async

Nun kommen keine fehler mehr. Wodurch kann sowas kommen? Erkennen die module ihre eigenen abhängigkeiten nicht?

[EDIT]

es ist doch noch nicht ganz gelöst.
Auf meiner 7170 geht pptp nun, nur auf meiner alten Fritz!Fon box kommt wenn ich pppd ausführen will:
-sh: pppd: Permission denied
Die Rechte lassen sich ja wegen des read only speichers nicht ändern, wo liegt da der fehler?

grüße
 
Zuletzt bearbeitet:

RalfFriedl

IPPF-Urgestein
Mitglied seit
22 Apr 2007
Beiträge
12,343
Punkte für Reaktionen
1
Punkte
0
Mit welchem Befehl werden denn die Module geladen?

Die Rechte der Programme muss man beim Erstellen richtig setzen, das solle aber normalerweise passieren. Du kannst das Image mal neu erstellen.
 

eicher16ps

Neuer User
Mitglied seit
10 Apr 2011
Beiträge
12
Punkte für Reaktionen
0
Punkte
0
modprobe hab ich es gemacht, auch in dem rc-script werden sie so geladen, nur in der falschen reihenfolge irgendwie :?

Werden die rechte neu gesetzt wenn ich das image neu erstelle?
 

RalfFriedl

IPPF-Urgestein
Mitglied seit
22 Apr 2007
Beiträge
12,343
Punkte für Reaktionen
1
Punkte
0
Bei einem neuen Image wird alles neu erstellt. Du kannst vor dem Flashen in build/modified/filesystem nach den Rechten schauen.

Modprobe berücksichtigt die Abhängigkeiten, die in der Datei modules.dep festgehalten sind. Was sagt denn diese Datei zu den ppp Modulen?
 

eicher16ps

Neuer User
Mitglied seit
10 Apr 2011
Beiträge
12
Punkte für Reaktionen
0
Punkte
0
In meiner modules.dep ist die reihenfolge bis auf eine Sache falsch:
Code:
cat /lib/modules/2.6.13.1-ar7/modules.dep
kernel/crypto/sha1.ko:
kernel/drivers/atm/avm_atm/tiatm.ko:
kernel/drivers/userman/userman_mod.ko:
kernel/lib/crc-ccitt.ko:
kernel/crypto/aes.ko:
kernel/crypto/arc4.ko:
kernel/net/sched/sch_cbq.ko:
kernel/drivers/net/ppp_async.ko:
kernel/drivers/net/ppp_generic.ko:
kernel/net/sched/sch_htb.ko:
kernel/drivers/net/slhc.ko:
kernel/drivers/net/ppp_mppe_mppc.ko:
kernel/drivers/dsld/kdsldmod.ko:
kernel/drivers/net/ppp_deflate.ko:
kernel/drivers/isdn/isdn_fon/zzz/isdn_fbox.ko:
Das slhc modul muss vor dem ppp_generic geladen werden.

Das mit dem image neu erstellen hat geklappt, die rechte stimmen jetzt ;)

EDIT:

Weißt auch jemand wie man jetzt die PC's im lan mit dem tunnel verbindet? Ein einfaches route add -net bringts irgendwie nicht :(

EDIT:

Hab das mit dem verbinden zum Lan mit iptables und masquerading nun gemacht: iptables -t nat -A POSTROUTING -j MASQUERADE.
Außerdem muss der MTU wert von dem pptp device auf 1400 gesenkt werden, sonst kann man über die Lan-Clients keine Remotedesktopverbindung aufbauen.
 
Zuletzt bearbeitet:

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Bei mir sehen die Zeilen etwas anders aus:
Code:
...
kernel/drivers/net/ppp_generic.ko: kernel/drivers/net/slhc.ko
...
Gruß
Oliver
 

eicher16ps

Neuer User
Mitglied seit
10 Apr 2011
Beiträge
12
Punkte für Reaktionen
0
Punkte
0
Achso, ich dachte auf die reihenfolge auch?
Dann fehlen nur die abhängigkeiten. Ist aber das einzige was noch fehlt, der rest läuft nun ;)

Danke schonmal an euch beide
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Und warum fehlen die Abhängigkeiten in deiner modules.dep? Stimmt vielleicht was mit deinem Perl nicht?

Gruß
Oliver
 

eicher16ps

Neuer User
Mitglied seit
10 Apr 2011
Beiträge
12
Punkte für Reaktionen
0
Punkte
0
Mhh wie kann ich das am besten rausfinden? Also Perl ist installiert und funktioniert auch glaube soweit ;)
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Du könntest mal folgenden Patch auf fwmod anwenden:
Code:
--- fwmod	(revision 7957)
+++ fwmod	(working copy)
@@ -836,10 +836,11 @@
 			sizeinfo mod "$ko_file"
 		fi
 	done
-
+set -x
 	echo1 "generating modules.dep"
 	${TOOLS_SUBDIR}/depmod.pl -b "$MODULES_DIR" \
-		-F ${KERNEL_REP_DIR}/System-${FREETZ_KERNEL_LAYOUT}-${FREETZ_KERNEL_REF}-${FREETZ_AVM_VERSION_STRING}.map 2> /dev/null
+		-F ${KERNEL_REP_DIR}/System-${FREETZ_KERNEL_LAYOUT}-${FREETZ_KERNEL_REF}-${FREETZ_AVM_VERSION_STRING}.map
+set +x
 	# add plugin kernel modules for 7270 if plugins are not enabled
 	if [ "$FREETZ_TYPE_FON_WLAN_7270_V1" == "y" -a ! "$FREETZ_AVMPLUGINS_ENABLED" == "y" ]; then
 		echo -e "kernel/drivers/net/rfcntl/rfcntl.ko: kernel/drivers/char/audio/avm_audio.ko\nkernel/drivers/char/audio/avm_audio.ko:\n" >> $MODULES_DIR/modules.dep
Gruß
Oliver
 

eicher16ps

Neuer User
Mitglied seit
10 Apr 2011
Beiträge
12
Punkte für Reaktionen
0
Punkte
0
Mhhh, nun kommt dieser fehler bei allen modulen:

Code:
nm: build/modified/filesystem/lib/modules/2.6.13.1-ar7/kernel/net/sched/sch_htb.ko: File format is ambiguous
nm: Matching formats: elf32-littlemips elf32-littlemips-vxworks elf32-tradlittlemips
Glaub irgendwas stimmt mit meiner binutils umgebung nicht?

EDIT:
Wenn ich in der depmod.pl die $nm var auf die uclibc-nm bin lege, gehts. Irgendwie stimmt was mit meinem host system nicht. Trotzdem danke soweit ;)
 
Zuletzt bearbeitet:

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Das passt ja auch zu deinem Problem mit ar. Kannst du bitte mal die Einstellungen in deinem Environment posten? Da ist doch sicher was faul. Welches Linux-System setzt du nochmal ein?

Gruß
Oliver
 

eicher16ps

Neuer User
Mitglied seit
10 Apr 2011
Beiträge
12
Punkte für Reaktionen
0
Punkte
0
Ich benutze Gentoo auf einem x86_64 system.

Welche einstellungen brauchst du genau?
 

Zurzeit aktive Besucher

3CX PBX - GRATIS
Linux / Win / Cloud

Neueste Beiträge

Statistik des Forums

Themen
234,050
Beiträge
2,042,051
Mitglieder
353,385
Neuestes Mitglied
Hans-R