[Problem] Freetz lässt sich sogar nach orig. AVM-Recover nicht installieren.

PsychoMantis

Aktives Mitglied
Mitglied seit
18 Dez 2005
Beiträge
2,525
Punkte für Reaktionen
5
Punkte
38
Folgendes: Ich habe freetz (u.a. mit dem Packet mini_fo) gebaut und installiert (also geflasht). Alles hat funktioniert, bis auf mini_fo. Also wollte ich es aktivieren. Aber der Radiobutton war ausgegraut. Also war ich so schlau und habe ihn mit Firebug aktiviert und angeklickt. Nach einem Reboot ging gar nichts mehr. Alle 3-5 Minuten Reboot. Also dies und jenes Versucht - alles ohne Erfolg. Dann habe ich meine 7390er mit dem orig. AVM-tool recovert und nun geht alles wieder. Aber ich will ja freetz aufspielen. Wenn ich das tue, dann geht wieder nichts mehr (alle 3-5 Min ein reboot). Das sieht so aus, als ob die Box sich die kaputten freetz-Einstellungen irgendwie gemerkt hat.
Was kann ich hier machen?
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Wir haben derzeit Probleme mit dem 7390 Kernel und Dateisystem Modulen. Ich habe momentan leider kein 3 Tage Zeit das zu untersuchen...

Im Trac gibt es ein Ticket zu mini_fo auf der 7390.

Gruß
Oliver
 

PsychoMantis

Aktives Mitglied
Mitglied seit
18 Dez 2005
Beiträge
2,525
Punkte für Reaktionen
5
Punkte
38
@ RalfFriedl: Liege ich richtig in der Annahme, dass das was du meinst irgendwo im mtd2 steht und dieser natürlich nicht vom AVM-Recover überschrieben wird?
Wie genau schaue ich nach den Kernel-Args? Ich meine telnet-Konsole unter orig. AVM-Firmware kann ich öffnen, und dann?
 

KunterBunter

IPPF-Urgestein
Mitglied seit
12 Okt 2005
Beiträge
23,648
Punkte für Reaktionen
209
Punkte
63
Und dann: cat /proc/sys/urlader/environment
 

PsychoMantis

Aktives Mitglied
Mitglied seit
18 Dez 2005
Beiträge
2,525
Punkte für Reaktionen
5
Punkte
38
@ KunterBunter: Danke
Code:
Console Ausgaben auf dieses Terminal umgelenkt
# cat /proc/sys/urlader/environment
HWRevision      156
HWSubRevision   3
ProductID       Fritz_Box_7390
SerialNumber    0000000000000000
annex   B
autoload        yes
bootloaderVersion       1.819
bootserport     tty0
cpufrequency    500000000
firstfreeaddress        0x810D952C
firmware_info   84.05.05
firmware_version        avm
flashsize       0x01000000
kernel_args     init=/etc/init.d/rc.mini_fo
kernel_args1    mini_fo=jffs2
maca    BC:05:43:BF:SD:VX
macb    BC:05:43:BF:WX:YZ
macwlan BC:05:43:BF:DF:DZ
macwlan2        BC:05:43:BF:GH:JK
macdsl  BC:05:43:BG:HI:JK
memsize 0x08000000
modetty0        38400,n,8,1,hw
modetty1        38400,n,8,1,hw
mtd0    0x9F000000,0x9F000000
mtd1    0x9F020000,0x9FF00000
mtd2    0x9F000000,0x9F020000
mtd3    0x9FF00000,0x9FF80000
mtd4    0x9FF80000,0xA0000000
my_ipaddress    192.168.178.1
prompt  Eva_AVM
req_fullrate_freq       166666666
sysfrequency    166666666
urlader-version 1819
usb_board_mac   BC:05:43:BG:HI:JK
usb_device_id   0x0000
usb_manufacturer_name   AVM
usb_revision_id 0x0000
usb_rndis_mac   BC:05:43:BG:HI:JK
wlan_key        BLABLABLABLAB
#
Das steht da momentan drin. Wie kann ich das auf original (so wie die 7370er vom Werk kommt) zurücksetzen?
 

PsychoMantis

Aktives Mitglied
Mitglied seit
18 Dez 2005
Beiträge
2,525
Punkte für Reaktionen
5
Punkte
38
Danke, genau das Eingeben dieser zwei Zeilen hat das Problem gelöst. Nun läuft freetz (Firmware-Version 84.05.05freetz-devel-7802M). Zwar ohne mini_fo, aber lieber so als gar nicht.
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
234,362
Beiträge
2,045,480
Mitglieder
354,008
Neuestes Mitglied
jagr