Freetz on FB7530

Sberta

Neuer User
Mitglied seit
28 Nov 2020
Beiträge
11
Punkte für Reaktionen
0
Punkte
1
Hi,

I recently bought an FB 7530 and discovered modding with Freetz, my goal would be to install a torrent client to download the router files to the HDD which is connected to it.

Now I am preparing my PC with the virtual machine and will create a new modified firmware asap, the only thing I cannot understand is how to install the Freetz firmware on the FB7530 if it requires a file.

Any help with that?

Thanks in advance.

Sorry for speaking English but I'm Italian.
 
Zuletzt bearbeitet:

NDiIPP

IPPF-Promi
Mitglied seit
13 Apr 2017
Beiträge
3,976
Punkte für Reaktionen
743
Punkte
113
Please write in English or German.
 
Zuletzt bearbeitet:

Sberta

Neuer User
Mitglied seit
28 Nov 2020
Beiträge
11
Punkte für Reaktionen
0
Punkte
1
Sorry, the Google Auto Translator changed the text from English to Italian, first post updated.
 

Sberta

Neuer User
Mitglied seit
28 Nov 2020
Beiträge
11
Punkte für Reaktionen
0
Punkte
1
Thanks for the guide, it's super clear, but I can't get there, I'm having trouble downloading Freetz Stable 2.0

When I type: svn checkout http://svn.freetz.org/branches/freetz-stable-2.0
I get this: svn: E170000: Illegale Projektarchiv-URL »%e2%80%8bhttp://svn.freetz.org/branches/freetz-stable-2.0«

Any idea why?
 

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
13,550
Punkte für Reaktionen
1,168
Punkte
113
Freetz-stable-2.0 is completely outdated and doesn't support 7530 anyhow.

You have to use Freetz (up to 07.13 - https://github.com/Freetz/freetz/blob/master/FIRMWARES#L291) and its "master" branch or you may use Freetz-NG (https://github.com/Freetz-NG/freetz-ng/blob/master/docs/FIRMWARES.md#fritzbox-fon-wlan-75xx).

Both have their (dis-)advantages - but "stable-2.0" was current in 2013 last (there were only some real minor corrections later) and where the f*ck have you found the - completely outdated, too - URL for the SVN server?
 

Sberta

Neuer User
Mitglied seit
28 Nov 2020
Beiträge
11
Punkte für Reaktionen
0
Punkte
1
Thanks Peter, I was looking on the freetz.github.io, that's where an Italian website regarding FritzBoxs sent me to.

Now I'm thinking that the steps I'm following are way outdated, is there a new How-To for building a Freetz firmware around here?
 

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
13,550
Punkte für Reaktionen
1,168
Punkte
113
You've found the right info already ... but it's not maintained any further.


Following a link to the (english) page regarding source code download, you should be led (sorry, ashaming mistake before and "leaded" looked something odd from the beginning - because "lead" is an irregularly conjugated verb) hereto:


and the checkout of sources from GitHub is described there, too.

Further steps should be covered by the rest of the existing documents (you HAVE to use the developer version - none of the existing projects has a new "stable" branch) or you should have a look on Freetz-NG instead - its documentation was a bit updated in the last 18 month (but there's no "stable version", too, and the maintainer isn't sure himself, how his fork should be seen from others).
 
Zuletzt bearbeitet:

Sberta

Neuer User
Mitglied seit
28 Nov 2020
Beiträge
11
Punkte für Reaktionen
0
Punkte
1
Awesome! I made a few steps, had to download the original firmare 07.13 and put it in dl/fw, when I launch "make" it gives me a few errors 4 and 8 when trying to download "libevent-2.1.11-stable.tar.gz".

Edit:

I downloaded it from github and put i in the folder "dl", it went further now.
 
Zuletzt bearbeitet:

Sberta

Neuer User
Mitglied seit
28 Nov 2020
Beiträge
11
Punkte für Reaktionen
0
Punkte
1
I finally found the time to flash after building the firmware.
When I launch the command to write

Code:
c:\YourFritz\master\eva_tools\EVA-FTP-Client.ps1 -Verbose -Debug -ScriptBlock { BootDeviceFromImage c:\YourFritz\Images\firmware.image.in-memory 0 }
I get this error:

Code:
Ausnahme beim Aufrufen von ".ctor" mit 2 Argument(en): "Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte 192.168.178.1:21".
Could it be possibile that my FB IP address is 192.168.188.1 instead of the usual 178.1?
 

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
13,550
Punkte für Reaktionen
1,168
Punkte
113
Could it be possibile that my FB IP address is 192.168.188.1 instead of the usual 178.1?
Don't mix up different IP addresses - the address used while running a FRITZ!OS instance (where 192.168.188.1 is a possible selection, especially for a cascaded router) has nothing in common with the IP address used by boot loader. If the system used to flash the box has really an IP address for its Ethernet adapter, that's from the 192.168.188.0/24 network segment, then your assumption COULD be true - but that would be rather rare circumstances.

But you may set the IP address used by the boot loader yourself - simply try the "EVA-Discover.ps1" script. But take my additional hints regarding the needed firewall rules into account - somewhere here's a thread (it's pinned, too) describing the use of the scripts from "eva_tools" subdirectory. Using EVA-Discover.ps1 requires the right for the PowerShell host to listen on UDP port 5035 - there should be shown a dialog automatically to allow access (at first attempt to do so).

BTW: Why has your PowerShell instance German message texts?
 

Sberta

Neuer User
Mitglied seit
28 Nov 2020
Beiträge
11
Punkte für Reaktionen
0
Punkte
1
I translated the error in German :D

I tried with EVA-Discover and got this:

Code:
DETTAGLIATO: Sending discovery packet (1) ...
DEBUG: Received UDP packet from 192.168.178.1:5035 ...
DETTAGLIATO: Trying to connect to the FTP port to hold up the device in bootloader ...
DEBUG: Error during FTP connection attempt ...
EVA_IP=192.168.178.1
True
Firewall is disabled.
 

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
13,550
Punkte für Reaktionen
1,168
Punkte
113
As you can see, your device uses 192.168.178.1 as IP address from boot loader (if there's an unicast answer to the broadcast on port 5035, the device is in bootloader mode).

But it's nearly impossible to find the box at the very first broadcast attempt already, if you've followed the right procedure. And this procedure would require to connect the computer system and the FRITZ!Box device with an Ethernet cable, switch off the FRITZ!Box device (disconnect power chord) and start the discovery script. Afterwards connect the power chord to the box and wait until the bootloader is ready to answer the first broadcast packet (these packets are sent out in a regularly manner, up to 30 times, if not changed with the "MaxWait" argument).

If you follow these directions (and have no other software on your (Windows) system, which examines and potentially blocks FTP connections), the FTP connection from the 4th line of your log should be made successfully and you may continue with the "EVA-FTP-Client.ps1" script.

The error pattern from your log is typically from some software, that blocks FTP connections at the system (that may be any "security suite", which claims to be "disabled" but still jams the connection) or from an earlier FTP connection to the boot loader, which wasn't finished with the correct command (QUIT).

Start over again ... and show the complete logs next time, please.

BTW: If your computer does not use a static IP address from 192.168.178.0/24 segment for its Ethernet adapter, you should:

- set a static address and specify it (and the desired box address) while calling the scripts
or
- use an Ethernet switch between the FRITZ!Box router and your computer

... but there are some other possible pitfalls better to know (and to consider), too, which are unrelated to the used tool(s).
 
Zuletzt bearbeitet:

Sberta

Neuer User
Mitglied seit
28 Nov 2020
Beiträge
11
Punkte für Reaktionen
0
Punkte
1
I used the "third method" in your guide to set the FB in the bootloader, with the help of the AVM Recovery Tool. Is that ok?
 

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
13,550
Punkte für Reaktionen
1,168
Punkte
113
That should be correct, too. But when you use this tool, it should show you the correct IP address for your FTP connection in its window, after it had found the (wrong) device? Where was the doubt (above) from?

If this address (192.168.188.1) was really shown by AVM recovery program, simply use it while calling the FTP client script.
 

Sberta

Neuer User
Mitglied seit
28 Nov 2020
Beiträge
11
Punkte für Reaktionen
0
Punkte
1
I made it! The AVM Recovery method was not working for me. I tried with the first method and connected to the bootloader.
I flashed the firmware and everything works fine, but I can't find Transmission in the Freetz area.
 

Zurzeit aktive Besucher

3CX

Statistik des Forums

Themen
237,067
Beiträge
2,087,300
Mitglieder
359,085
Neuestes Mitglied
Stinger18