.titleBar { margin-bottom: 5px!important; }

Freetz OPenVPN Problem

Dieses Thema im Forum "Freetz" wurde erstellt von lewej, 16 März 2009.

  1. lewej

    lewej Neuer User

    Registriert seit:
    22 Aug. 2007
    Beiträge:
    40
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Leute,

    ich habe bei mir auf der Box OPenVPn installiert.

    Server Config:
    Code:
    #  OpenVPN 2.1 Config, Mon Mar 16 16:41:30 CET 2009
    proto tcp-server
    dev tun
    ca /tmp/flash/ca.crt
    cert /tmp/flash/box.crt
    key /tmp/flash/box.key
    dh /tmp/flash/dh.pem
    crl-verify /tmp/flash/crl.pem
    tls-server
    port 1194
    mode server
    ifconfig-pool 10.0.15.3 10.0.15.254
    push "route 10.0.15.0 "
    ifconfig 10.0.15.1 10.0.15.2
    push "route 192.168.1.0 255.255.255.0"
    tun-mtu 1500
    mssfix
    log /var/tmp/debug_openvpn.out
    verb 3
    daemon
    cipher AES-256-CBC
    comp-lzo
    keepalive 10 120
    ifconfig-pool-linear
    route 10.0.15.0 255.255.255.0 10.0.15.1
    
    Client.conf:
    Code:
    client
    dev tun
    proto tcp
    remote my-server.de 1194
    resolv-retry infinite
    nobind
    ca Y:/vpn/ca.crt
    cert Y:/vpn/client03.crt
    key Y:/vpn/client03.key
    auth SHA1
    cipher AES-256-CBC
    verb 4
    
    Wenn ich mich mit einem Linux Client connecte funktioniert alles, wenn ich mich aber mit einem Windows Client connecte, bekomme ich folgende Fehler Meldung:
    Code:
    There is a problem in your selection of --ifconfig endpoints [local=10.0.15.3, remote=10.0.15.1].  The local and remote VPN endpoints cannot use the first or last address within a given 255.255.255.252 subnet.  This is a limitation of --dev tun when used with the TAP-WIN32 driver.  Try 'openvpn --show-valid-subnets' option for more info.
    
    Hat jemand eine IDee?
    OpenVPN Server Version: OpenVPN 2.1_rc13 mipsel-linux [SSL] [LZO2] [EPOLL] built on Mar 12 2009
    OpenVPN Client Version: 2.1 rc15
     
  2. MaxMuster

    MaxMuster IPPF-Promi

    Registriert seit:
    1 Feb. 2005
    Beiträge:
    6,924
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    #2 MaxMuster, 16 März 2009
    Zuletzt bearbeitet: 16 März 2009
    Eine Idee? Wenn du das über die GUI eingestellt hast, dann hast du die GUI-Seite bei den Experteneinstellungen nicht richtig gelesen ;-) ;-):
    Im Ernst: Die Fehlermeldung sagt dir, dass du versuchst Punkt-zu-Punkt IP-Adressen zu vergeben, was der Windowstreiber nicht unterstützt. Das hast du mit dem Parameter "ifconfig-pool-linear" bewirkt, der das OpenVPN anweist, dass es sich nicht um Windowsclients zu kümmern braucht (Hervorhebung von mir):
    PS: Die Client-Config wird so wohl nicht funktionieren, da "comp-lzo" nur beim Server steht...

    Jörg
     
  3. lewej

    lewej Neuer User

    Registriert seit:
    22 Aug. 2007
    Beiträge:
    40
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    [Edit frank_m24: Sinnfreies Vollzitat vom Beitrag direkt darüber gelöscht. Lies noch mal die Forumregeln.]
    Super, funktioniert jetzt, danke