[Problem] freetz PHP fsockopen

dko6

Neuer User
Mitglied seit
6 Mrz 2012
Beiträge
2
Punkte für Reaktionen
0
Punkte
0
ich habe einen freetz-trunk auf meiner 7170 mit PHP laufen. PHP-Scripte und Html laufen grundsätzlich. Nun will ich auf eine NetIO zugreifen, bekomme aber beim fsockopen(192.168.0.91, 64400 .....)

Failed to parse address

Ich habe mich dann mit putty auf die 7170 eingeloggt und mit netcat nc 192.168.0.91 64400 das NetTO angesprochen. Alles Ok, aber warum klappt es nicht mit fsockopen ?

Mit XAMPP auf einer windowsmaschine funktioniert der Zugriff mit fsockopen.
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Wie wäre es mit einem Ausschnitt aus dem Code? Und der exakten Fehlermeldung aus dem php_error.log? Sonst raten wir nur rum.

Gruß
Oliver
 

dko6

Neuer User
Mitglied seit
6 Mrz 2012
Beiträge
2
Punkte für Reaktionen
0
Punkte
0
Wie wäre es mit einem Ausschnitt aus dem Code? Und der exakten Fehlermeldung aus dem php_error.log? Sonst raten wir nur rum.

Gruß
Oliver
konnte mein Problem lösen.

die php-Scripte laufen problemlos auf einem Windowsrechner mit xampp. Da die gleichen Scripte auf der 7170 nicht liefen, hatte ich die php-Umgebung in Verdacht. Leider falsch gedacht. Die connectparameter habe ich in einer eigenen Konfigdatei. Nachdem ich die Parameter global definiert habe, läuft der Open durch.

Gruss
Dieter
 

RalfFriedl

IPPF-Urgestein
Mitglied seit
22 Apr 2007
Beiträge
12,343
Punkte für Reaktionen
1
Punkte
0
Für zukünftige Probleme:

Vollzitate sind hier nicht erwünscht.

Wenn Du ein Problem mit der Laufzeitumgebung vermutest, versuchst Du erstmal einen möglichst einfachen Testfall zu erstellen, bei dem das Problem auftritt. Damit hättest Du in diesem Fall schon selbst gemerkt, dass es damit funktioniert. Wenn dem aber nicht so ist, dann schreibst Du exakt, was Du gemacht hast.
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Und damit hier zu.

Gruß
Oliver