.titleBar { margin-bottom: 5px!important; }

freetz-stable-1.0-rev-2644 & NTFS-3G 1.2712

Dieses Thema im Forum "Freetz" wurde erstellt von Saphir, 11 Okt. 2008.

  1. Saphir

    Saphir Neuer User

    Registriert seit:
    13 Nov. 2006
    Beiträge:
    21
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi,

    hab versucht ein mir für meine 7170 eine Firmware mit dem NTFS-Modue zu erstellen. Hab beim make lauf eine Fehlermeldung bekommen dass das file http://www.ntfs-3g.org/ntfs-3g-1.2712.tgz nicht downgeloadet werden kann.

    Hab auf der Web-Seite eine aktuelle Version ntfs-3g-1.2918.tgz gefunden.

    Auf die Frage wie ich diese Version einbaue habe ich im trac für freets folgenden Eintrag gefunden:

    http://www.freetz.org/changeset/2609

    Habe die Files Config.in und ntfs.mk in einem "frischen" Ceckout (freetz-stable-1.0-rev-2644) manuell angepasst und dann das make menuconfig und make durchlaufen lassen.

    Lief diesmal ohne Probleme durch. :)

    Bevor ich die Firmware in die Box lade wollt ich fragen ob's das war oder ob's noch was zubeachten gibt?

    Gruß, Henry
     
  2. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,761
    Zustimmungen:
    5
    Punkte für Erfolge:
    38
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Sollte so funktionieren.

    MfG Oliver
     
  3. tomey

    tomey Neuer User

    Registriert seit:
    19 Okt. 2006
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi,

    ich hänge mich mal in diesen Thread, weil ich das Problem auch hatte. Habe die Änderungen auch vorgenommen und nun gibt es folgendes Problem:

    Code:
    sg3_utils-1.26/archive/
    sg3_utils-1.26/archive/rescan-scsi-bus.sh
    sg3_utils-1.26/archive/o_scsi_logging_level
    sg3_utils-1.26/archive/README
    sg3_utils-1.26/archive/llseek.c
    sg3_utils-1.26/archive/llseek.h
    sg3_utils-1.26/autogen.sh
    sg3_utils-1.26/COPYING
    shopt -s nullglob; for i in make/sg3_utils/patches/*.patch; do tools/freetz_patc h source/sg3_utils-1.26 $i; done
    applying patch file make/sg3_utils/patches/100-sg3_utils-cflags.patch
    can't find file to patch at input line 4
    Perhaps you used the wrong -p or --strip option?
    The text leading up to this was:
    --------------------------
    |diff -burN no_lib/Makefile.linux no_lib/Makefile.linux
    |--- no_lib/Makefile.linux      2007-04-18 20:31:14.000000000 +0200
    |+++ no_lib/Makefile.linux      2007-05-23 12:32:35.000000000 +0200
    --------------------------
    File to patch:
    Skip this patch? [y]
    Skipping patch.
    1 out of 1 hunk ignored
    ----------------------------------------------------------------------
    ERROR: modpatch: Error in patch-file make/sg3_utils/patches/100-sg3_utils-cflags .patch
    make: *** [source/sg3_utils-1.26/.unpacked] Fehler 2
    slightly@StinkyLinux:/var/tmp/freetz-1.0$
    
    Als Anfänger stehe ich nun auf dem Schlauch.

    Was kann ich tun ?

    Gruß
    Thomas
     
  4. laptel

    laptel Neuer User

    Registriert seit:
    2 Okt. 2008
    Beiträge:
    27
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    lösche mal den Patch unter make/sg3_utils/patches dann sollte es gehen

    mfg laptel
     
  5. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,761
    Zustimmungen:
    5
    Punkte für Erfolge:
    38
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Huch. Hab ich das immer noch nicht gemacht. Hatte ich vergessen. Sorry.

    MfG Oliver
     
  6. tomey

    tomey Neuer User

    Registriert seit:
    19 Okt. 2006
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Danke laptel

    Make ist dann ohne Probleme durchgelaufen.

    Gruß
    Thomas