.titleBar { margin-bottom: 5px!important; }

[Problem] Freetz und Fhem

Dieses Thema im Forum "Freetz" wurde erstellt von piet_pit, 2 Sep. 2012.

  1. piet_pit

    piet_pit Neuer User

    Registriert seit:
    29 Dez. 2008
    Beiträge:
    112
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Zusammen,
    Ich habe auf meinem Speedport 920, der mit der Firmware 75.04.91 läuft, Freetz installiert. Klappt alles bestens. Nun versuche ich, FHEM zu installieren, gehe dabei nach folgender Anleitung vor, das klappt aber nicht.

    http://www.wehavemorefun.de/fritzbox/FHEM_installieren

    Perl wird erst einmal nicht gestartet. Kann es sein, dass meine Fw-Kombi hier nicht richtig ist und ich ein 7270 Image via S2F erst einmal auf die Box spielen muss.

    VG
    Pit
     
  2. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,779
    Zustimmungen:
    10
    Punkte für Erfolge:
    38
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Was passiert denn nach dem Aufruf von Perl? Gibt es eine Fehlermeldung?

    Gruß
    Oliver
     
  3. piet_pit

    piet_pit Neuer User

    Registriert seit:
    29 Dez. 2008
    Beiträge:
    112
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,
    danke für die Antwort.
    Ich habe mittlerweile weiter recherchiert und im Forum einen Ansatz gefunden (Nachinstallation von Dropbear), um fehlende Dateien zu laden. Ich bin gerade dabei, eine neue Freetz-Version zu "produzieren" und werde diese im Laufe der Woche mal ausprobieren und melde mich dann.

    VG
    Pit
     
  4. Joe82

    Joe82 Aktives Mitglied

    Registriert seit:
    22 März 2007
    Beiträge:
    1,113
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Lehrer
    Ort:
    Rinteln
    Hallo,

    hast du mal hier geschaut?

    http://fhem.de/fritzbox.html

    Ich würde da einfach den für die 7170 bzw. 7270 beschriebenen Weg gehen.

    LG Joe
     
  5. piet_pit

    piet_pit Neuer User

    Registriert seit:
    29 Dez. 2008
    Beiträge:
    112
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo, ja, diese Anleitung habe ich auch gesehen, bin mir aber nicht sicher, ob das für mich passt.
    Ich habe ja einen Speedport 920, und weiterhin habe ich gelesen, dass auf einer 7270v2 nur mit Freetz Fhem läuft.
    Also habe ich ein Freetz-Image (54.04.90) gebaut (wie in der Anleitung von Royalblue beschrieben) und diese dann mit S2F zu einem Image verarbeitet, dass dann auf dem Speedport läuft. Soweit klappt, nur FHEM läuft halt nicht. Habe jetzt mal das Package Dropbear in Freetz eingebaut, so soll eine Fehlermeldung, die auf eine fehlende Datei hinweist, nicht mehr erscheinen. Ich kann das aber erst diese Woche ausprobieren.
    Vg
    Pit
     
  6. piet_pit

    piet_pit Neuer User

    Registriert seit:
    29 Dez. 2008
    Beiträge:
    112
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,
    ich habe jetzt einmal den von Joe82 vorgeschlagenen Weg probiert, auch hier geht es ab einem bestimmten Punkt nicht mehr weiter. Also, alles auf einen Stick (FAT32) kopiert, diesen an die FB angestöpselt. mit df den Stick gecheckt, die startfhem angepasst, also "home with hardcoded path" versehen, dann hänge ich an folgendem Problem:

    in der Startfhem wird der Befehl "modprobe kernel/cdc-acm.ko" aufgerufen, es kommt folgende Fehlermeldung:


    modprobe: module kernel/cdc-acm.ko not found in modules.dep

    Diese Datei liegt aber definitiv im Verzeichnis kernel, ich habe diese auch nochmals neu erzeugt und neu eingespielt.

    Wenn ich den kompletten Pfad eingebe (in die Startfhem), kommt die gleiche Fehlermeldung.

    Irgendwie weiß ich nicht mehr weiter...
    VG
    Pit
     
  7. RalfFriedl

    RalfFriedl IPPF-Urgestein

    Registriert seit:
    22 Apr. 2007
    Beiträge:
    12,343
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Die Meldung besagt auch nicht, dass die Datei im Verzeichnis kernel nicht vorhanden sei.
    Wenn Du den kompletten Pfad eingibst, nimm insmod statt modprobe.
     
  8. piet_pit

    piet_pit Neuer User

    Registriert seit:
    29 Dez. 2008
    Beiträge:
    112
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,
    dake für den Tip, habe ich direkt versucht, nun kommt eine weitere Fehlermeldung:

    "attrib global port: can't open server port at 7072: adress already in use"

    Dieses attrib global port steht ja in der fhem.cfg, muß ich diese auch anpassen:confused:

    Davon habe ich bis jetzt in dieser konkreten Anleitung von Eyk nichts gelesen..

    Tja, echt ne Herausforderung, wenn man Anfänger in Sachen Linux ist..
    VG
    Pit
     
  9. piet_pit

    piet_pit Neuer User

    Registriert seit:
    29 Dez. 2008
    Beiträge:
    112
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #9 piet_pit, 13 Sep. 2012
    Zuletzt bearbeitet: 13 Sep. 2012
    Hallo,

    ich habe jetzt mal einen Auszug aus dem Log-file beigefügt, evtl. kann hier jemand helfe


    Code:
    2012.09.13 14:53:46 2: Telnet port 7072 opened
    2012.09.13 14:53:47 2: FHEMWEB port 8083 opened
    2012.09.13 14:53:47 2: FHEMWEB port 8084 opened
    2012.09.13 14:53:47 2: FHEMWEB port 8085 opened
    2012.09.13 14:53:50 3: Opening TCM310 device /dev/ttyUSB0
    2012.09.13 14:53:52 3: Can't open /dev/ttyUSB0: No such device
    2012.09.13 14:53:53 3: Opening TCM310 device /dev/ttyUSB1
    2012.09.13 14:53:53 3: Can't open /dev/ttyUSB1: No such device
    2012.09.13 14:53:53 3: Opening TCM310 device /dev/ttyUSB2
    2012.09.13 14:53:53 3: Can't open /dev/ttyUSB2: No such device
    2012.09.13 14:53:53 3: Opening TCM310 device /dev/ttyUSB3
    2012.09.13 14:53:53 3: Can't open /dev/ttyUSB3: No such device
    2012.09.13 14:53:53 0: Server started (version 5.2 from 2011-12-31 ($Id: fhem.pl 1159 2011-12-31 13:31:58Z rudolfkoenig $), pid 2821)
    2012.09.13 14:53:55 1: attr global port: Can't open server port at 7072: Address already in use
    2012.09.13 14:53:58 0: Strange call for nonexistent TCM310: ReadyFn

    der FHEM-Server scheint ja zu starten; ich verstehe nicht warum der Port 7072 von telnet schon "in use" ist, liegt aber sicher an meinem Linux-nicht Wissen...

    VG
    Pit
     
  10. sf3978

    sf3978 IPPF-Promi

    Registriert seit:
    2 Dez. 2007
    Beiträge:
    7,732
    Zustimmungen:
    7
    Punkte für Erfolge:
    38
    Poste mal die Ausgabe von:
    Code:
    netstat -tulpen
    
    oder die Ausgabe von:
    Code:
    lsof -nPi
    
    wenn lsof auf der Box.
     
  11. piet_pit

    piet_pit Neuer User

    Registriert seit:
    29 Dez. 2008
    Beiträge:
    112
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    hier die Ausgabe...

    Code:
    tcp        0      0 0.0.0.0:7072            0.0.0.0:*               LISTEN      3738/perl
    tcp        0      0 0.0.0.0:51111           0.0.0.0:*               LISTEN      -
    tcp        0      0 0.0.0.0:51112           0.0.0.0:*               LISTEN      -
    tcp        0      0 0.0.0.0:139             0.0.0.0:*               LISTEN      2409/inetd
    tcp        0      0 0.0.0.0:8083            0.0.0.0:*               LISTEN      3738/perl
    tcp        0      0 127.0.0.1:1011          0.0.0.0:*               LISTEN      2081/telefon
    tcp        0      0 0.0.0.0:8084            0.0.0.0:*               LISTEN      3738/perl
    tcp        0      0 0.0.0.0:8085            0.0.0.0:*               LISTEN      3738/perl
    tcp        0      0 0.0.0.0:21              0.0.0.0:*               LISTEN      2409/inetd
    tcp        0      0 127.0.0.1:8888          0.0.0.0:*               LISTEN      2081/telefon
    tcp        0      0 0.0.0.0:445             0.0.0.0:*               LISTEN      2409/inetd
    tcp        0      0 :::49443                :::*                    LISTEN      741/upnpd
    tcp        0      0 :::5060                 :::*                    LISTEN      2104/voipd
    tcp        0      0 :::49000                :::*                    LISTEN      741/upnpd
    tcp        0      0 :::49100                :::*                    LISTEN      1678/mediasrv
    tcp        0      0 :::8080                 :::*                    LISTEN      736/ctlmgr.bin
    tcp        0      0 :::80                   :::*                    LISTEN      736/ctlmgr.bin
    tcp        0      0 :::81                   :::*                    LISTEN      2282/httpd-webcfg
    tcp        0      0 :::23                   :::*                    LISTEN      2084/telnetd
    udp        0      0 0.0.0.0:1027            0.0.0.0:*                           748/multid
    udp        0      0 127.0.0.1:323           0.0.0.0:*                           2651/chronyd
    udp        0      0 0.0.0.0:67              0.0.0.0:*                           748/multid
    udp        0      0 0.0.0.0:5060            0.0.0.0:*                           2104/voipd
    udp        0      0 0.0.0.0:1900            0.0.0.0:*                           741/upnpd
    udp        0      0 0.0.0.0:1900            0.0.0.0:*                           741/upnpd
    udp        0      0 0.0.0.0:1900            0.0.0.0:*                           1678/mediasrv
    udp        0      0 0.0.0.0:1900            0.0.0.0:*                           741/upnpd
    udp        0      0 0.0.0.0:1900            0.0.0.0:*                           741/upnpd
    udp        0      0 0.0.0.0:1900            0.0.0.0:*                           741/upnpd
    udp        0      0 0.0.0.0:123             0.0.0.0:*                           2651/chronyd
    udp        0      0 :::1024                 :::*                                748/multid
    udp        0      0 :::1025                 :::*                                748/multid
    udp        0      0 :::1026                 :::*                                736/ctlmgr.bin
    udp        0      0 :::7077                 :::*                                2104/voipd
    udp        0      0 :::53                   :::*                                748/multid
    udp        0      0 :::5353                 :::*                                748/multid
    udp        0      0 :::5353                 :::*                                748/multid
    udp        0      0 :::5355                 :::*                                748/multid
    udp        0      0 :::5355                 :::*                                748/multid

    VG
    Pit
     
  12. sf3978

    sf3978 IPPF-Promi

    Registriert seit:
    2 Dez. 2007
    Beiträge:
    7,732
    Zustimmungen:
    7
    Punkte für Erfolge:
    38
    Auf Port 7072 wird gelauscht:
     
  13. piet_pit

    piet_pit Neuer User

    Registriert seit:
    29 Dez. 2008
    Beiträge:
    112
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,
    ja, du hast recht...

    Ich hatte eine Fehlermeldung vermutet, und wohl erneut versucht, startfhem auszuführen, weil irgendwie nichts passiert ist..

    Was soll ich sagen, via http://fritz.box:8083/fhem konnte ich das WEb-Interface aufrufen, es läuft also...:bier:

    Danke an alle.., jetzt geht es weiter..
    VG
    Pit