.titleBar { margin-bottom: 5px!important; }

[Problem] Fritz!Box 7170 flash nicht, sondern startet direkt neu

Dieses Thema im Forum "Freetz" wurde erstellt von lucki007, 27 Aug. 2011.

  1. lucki007

    lucki007 Neuer User

    Registriert seit:
    9 Juni 2008
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hei Leute...

    Ich habe heute versucht mit freetz meine 7170 zu flashen.

    Doch leider gibt es ein paar Probleme, hier mal der Ablauf wie ich geflasht habe:

    Ubuntu -> freetz 1.2 geholt

    -> make menuconfig (Nur Gerät ausgewählt, SONST NICHTS!!)

    -> make

    -> keine Fehler, image wurde in /images/ erstellt

    -> Fritz!box (FW 29.04.87) -> System -> Firmwareupdate -> Image hochgeladen -> "Firmware nicht ovn AVM Meldung" -> auf Weiter geklickt -> fritzbox startet direkt neu ;/

    ich habe das auch schon mit dem neuesten Dev. Snapshot von Freetz ausprobiert. Selbes Problem, die Box starte einfach neu. Auch schon alle Tricks aus dem Wiki ausprobiert.. immernoch das selbe Problem ;/

    Kann mir da vielleicht jemand helfen

    MfG
     
  2. sf3978

    sf3978 IPPF-Promi

    Registriert seit:
    2 Dez. 2007
    Beiträge:
    7,667
    Zustimmungen:
    5
    Punkte für Erfolge:
    38
    Evtl. mit push_firmware versuchen zu flashen.
     
  3. lucki007

    lucki007 Neuer User

    Registriert seit:
    9 Juni 2008
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Das habe ich schon versucht ;D aber irgendwie nicht ganz verstanden:

    Ich habe das so gemacht:

    push_firmware.sh "pfad zu .image" 192.168.178.10 (Fritz.box adresse)


    Das habe ich schon versucht.. das hat aber nicht geklappt... war das richtig oder muss ich die .kernel datei extrahieren damit das klappt ?

    MfG
     
  4. sf3978

    sf3978 IPPF-Promi

    Registriert seit:
    2 Dez. 2007
    Beiträge:
    7,667
    Zustimmungen:
    5
    Punkte für Erfolge:
    38
    Fast richtig.
    Code:
    :~/myfreetz/freetz7293/freetz-trunk> tools/[COLOR=red]push_firmware[/COLOR]
    
    Usage: tools/push_firmware <[COLOR=red]firmware[/COLOR]> [ -f ] [ <[COLOR=red]ip[/COLOR]> ] [ -hn ]
    
    firmware          firmware file to flash (mostly kernel.image)
    -f        disable safety prompt
    ip        bootloader IP address ([COLOR=red]default: 192.168.178.1[/COLOR])
    -hn       flash image to an "Alice/HanseNet" Version of 7570
     
  5. lucki007

    lucki007 Neuer User

    Registriert seit:
    9 Juni 2008
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0

    Habe das gleiche auch mit der 7170_04.87freetz-1.2-stable.de_20110827-200740.image probiert..

    MfG
     
  6. sf3978

    sf3978 IPPF-Promi

    Registriert seit:
    2 Dez. 2007
    Beiträge:
    7,667
    Zustimmungen:
    5
    Punkte für Erfolge:
    38
    Dann solltest Du weiter mit dem AVM-WEB-IF versuchen zu flashen. Manchmal sind mehrere Versuche (Anläufe) erforderlich. Warum hast Du nach dem recovery deiner Box, die IP-Adresse der Box von 192.168.178.1 auf 192.168.178.10 geändert?
     
  7. lucki007

    lucki007 Neuer User

    Registriert seit:
    9 Juni 2008
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hei ;D

    Danke für deine Antwort...

    Was ist denn "AVM-WEB-IF" ;D

    Ich habe das deswgen geändert, weil wir hier im Haus noch eine zweite Fritzbox haben ;D Die andere hier, (7170) habe ich geschenkt bekommen, und benutze sie für den Netzwerkdrucker.. und wollte sie mit freetz um ein paar Coole funktionen erweitern. Ich musste sie auf 192.168.178.10 ändern, das es sonst Probleme mit der anderen Box gegeben hätte ;)

    MfG
     
  8. sf3978

    sf3978 IPPF-Promi

    Registriert seit:
    2 Dez. 2007
    Beiträge:
    7,667
    Zustimmungen:
    5
    Punkte für Erfolge:
    38
    AVM-Web-Interface
    OK. Ich ändere die IP-Adresse meiner Boxen auch, aber erst nachdem ich das Freetz-Image erfolgreich, auf die Box geflasht habe.
     
  9. lucki007

    lucki007 Neuer User

    Registriert seit:
    9 Juni 2008
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    mit dem interface habe ich das ja schon mehrmals probiert ;)

    mmh.. ich setze die Box morgen mal auf Werkseinstellungen zurück, und probiere es dann nochmal...

    Danke ;D

    MfG
     
  10. sf3978

    sf3978 IPPF-Promi

    Registriert seit:
    2 Dez. 2007
    Beiträge:
    7,667
    Zustimmungen:
    5
    Punkte für Erfolge:
    38
    recovery it besser als Werkseinstellungen.;)
     
  11. sven@mainz

    sven@mainz Guest

    Hast Du denn die Box mit den original 29.04.87 Image geflasht? Funktioniert das denn?
     
  12. RalfFriedl

    RalfFriedl IPPF-Urgestein

    Registriert seit:
    22 Apr. 2007
    Beiträge:
    12,343
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Zum einen braucht man die Datei kernel.image, nicht die fertig gepackte Datei für einen Update über das Web-Interface.
    Zum anderen hat die Box nach dem Neustart in den ersten 5 Sekunden eine Adresse, die unabhängig von der Adresse im regulären Betrieb ist. Mit hoher Wahrscheinlichkeit ist das die 192.168.178.1. Wenn diese Adresse anderweitig genutzt wird, solltest Du die andere Box ausschalten, während Du push_firmware laufen lässt.
     
  13. sf3978

    sf3978 IPPF-Promi

    Registriert seit:
    2 Dez. 2007
    Beiträge:
    7,667
    Zustimmungen:
    5
    Punkte für Erfolge:
    38
    Es gibt Beiträge hier im Forum, aus denen ersichtlich ist, dass das Flashen mit push_firmware unter Benutzung der firmware.image-Datei und einer anderen IP-Adresse als im urlader/environment, auch funktionieren kann:
    Code:
    ./tools/push_firmware ./images/[COLOR=red]7390_04.84freetz-devel-5289.de_20100727-113329.image[/COLOR] -f 192.168.[COLOR=red]0.254[/COLOR]
    Wenn es aber nicht funktioniert, sollte man es schon mit der kernel.image-Datei und der IP-Adresse aus dem environment versuchen.
    Code:
    root@fritz:/var/mod/root# grep "my_ipaddress" /proc/sys/urlader/environment
    my_ipaddress    192.168.178.1