Fritz!box 7520 bricked nach Firmware-Upload

st.esser

Neuer User
Mitglied seit
10 Sep 2006
Beiträge
22
Punkte für Reaktionen
1
Punkte
3
Zuerst einmal: Eigentlich dachte ich, einige Erfahrung mit verschiedenen Fritz!box-Modellen, u.a. auch mit Speed2Fritz (Speedport 920 zu Fritz!box 7570) und Freetz.

Ich wollte diesmal für jemand anderen eine Fritz!box 7520 auf 7530 umstellen, und zwar per FTP da das Recovery-Tool keine Verbindung herstellen konnte.

Das Environment hatte ich schon angepasst, danach FRITZ.Box_7530-07.27-recover.exe gestartet, in einem parallelen Fenster per ping auf 192.168.178.1 beobachtet, wann ADAM2 erreichbar wird. Aber wie gesagt, das hat mit 2 verschiedenen Windows-Rechnern nicht funktioniert. FTP zum Environment-Ändern war kein Problem, aber das Recovery-Tool wollte einfach nicht ...

Also habe ich kernel.image und filesystem.image aus einem aktuellen Update-Image für die 7530 heraus geholt.

Dann per FTP:

Code:
$ ftp 192.168.178.1
Connected to 192.168.178.1.
220 ADAM2 FTP Server ready
Name (192.168.178.1:se): adam2
331 Password required for adam2
Password:
230 User adam2 successfully logged in
Remote system type is AVM.
ftp> bin
200 Type set to BINARY
ftp> quote media flsh
200 Media set to MEDIA_FLASH
ftp> put kernel.image "kernel.image mtd1"
local: kernel.image remote: kernel.image mtd1
227 Entering Passive Mode (192,168,178,1,233,221)
501 unknown variable kernel.image
ftp> put kernel.image mtd1
local: kernel.image remote: mtd1
227 Entering Passive Mode (192,168,178,1,227,93)
150 Opening BINARY data connection
100% |*************************************************************************************************************************************************************|  3034 KiB    2.97 MiB/s    00:00 ETA
226 Transfer complete
3107336 bytes sent in 00:00 (2.96 MiB/s)
ftp> put filesystem.image mtd0
local: filesystem.image remote: mtd0
227 Entering Passive Mode (192,168,178,1,168,69)
150 Opening BINARY data connection
100% |*************************************************************************************************************************************************************| 25396 KiB    3.31 MiB/s    00:00 ETA
426 Data connection closed
26005512 bytes sent in 00:07 (3.31 MiB/s)
ftp> quote reboot
221 Thank you for using the FTP service on ADAM2
ftp>

Ergebnis: Die Box bootet nicht mehr, keine LED leuchtet, das Netzteil pfeift etwas, die Box scheint als mehr Strom zu ziehen als normal.

Offensichtlich habe ich es geschafft, den Boot-Loader zu überschreiben. Und vielleicht hätte die Fehlermeldung "501 unknown variable kernel.image" Warnung genug sein sollen, es nicht weiter auf diesem Wege zu versuchen. Die 7520 ist ja auch schon ganz schön (gewesen) ...

Ich habe jetzt auf der Suche nach einer Erklärung in einem anderen Thread den Hinweis gelesen, dass die Bezeichnungen der Flash-Regionen sich geändert haben könnten (MTD0 und MTD1 ausgetauscht?).

Noch ein paar Informationen, die ich vor dem Schreiben der Images abgefragt hatte:

Code:
ftp> quote getenv firmware_info
firmware_info         175.07.14
200 GETENV command successful
ftp> quote getenv mtd0
mtd0                  0x0,0x2C00000
200 GETENV command successful
ftp> quote getenv mtd1
mtd1                  0xB00000,0xF0 0000
200 GETENV command successful
ftp> quote getenv mtd2
mtd2                  0x0,0x2C0000
200 GETENV command successful

Der Überlapp von mtd0 und mtd2 hatte mich etwas irritiert, aber die größere Länge von mtd0 schien mir ein klares Indiz zu sein, dass dies das Filesystem sein muss, und mtd1 der Kernel.

Wenn es noch eine Möglichkeit zur Recovery ohne funktionierenden ADAM2-Zugriff gibt, dann würde ich sie unbedingt versuchen wollen!

Ansonsten war das teuer erkauftes Wissen, dass die Flash-Partitionen nicht mehr so zugeordnet sind, wie das überall beschrieben ist ...

Die Recovery-Methode per FTP PUT scheint jedenfalls für aktuelle Boxen nicht mehr möglich zu sein.
Oder ging die ohnehin nur, wenn man nicht gleichzeitig eine Umstellung von 7520 auf 7530 versucht?
 

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
13,937
Punkte für Reaktionen
1,301
Punkte
113
Es gibt hier so viele Wiederholungen davon, wie man eine 7520 richtig in eine 7530 verwandelt und dabei noch die aktuelle Firmware installiert, daß es (meiner bescheidenen Meinung nach jedenfalls) keine weitere braucht.

Wer sich VOR dem Loslegen mit Aktionen, die (bis auf seltene Ausnahmen wie bei der 40x0-Serie) zuletzt bei Modellen vor sieben Jahren und mehr (zuletzt praktisch bei der 7390 und die 7490 erschien 2014) funktionierten, erst einmal hier im Board einliest, der sollte auch keine Schwierigkeiten haben, eine richtige(!) Anleitung dafür zu finden.

Es tut mir zwar leid, wenn mal wieder jemand eine eigentlich funktionsfähige FRITZ!Box erlegt hat, aber das liegt sicherlich nicht an einem Mangel an korrekten Anleitungen/Beschreibungen, wie man dabei vorgehen sollte. Selbst bei heise.de kann man das - mit viel Brimborium gewürzt - mittlerweile nachlesen und ich wüßte keine (ernstzunehmende!) Quelle, die für eine 7520/7530 tatsächlich das Beschreiben von MTD1 (oder MTD0 oder was auch immer) als zielführend angegeben würde. Wenn das so funktionieren würde, wäre das vermutlich auch der Weg, den AVM mit dem Recovery-Programm anwenden würde ... und daß dieses nicht der Fall ist, ist verbürgt.
 

st.esser

Neuer User
Mitglied seit
10 Sep 2006
Beiträge
22
Punkte für Reaktionen
1
Punkte
3
Es gibt hier so viele Wiederholungen davon, wie man eine 7520 richtig in eine 7530 verwandelt und dabei noch die aktuelle Firmware installiert, daß es (meiner bescheidenen Meinung nach jedenfalls) keine weitere braucht.

Wer sich VOR dem Loslegen mit Aktionen, die (bis auf seltene Ausnahmen wie bei der 40x0-Serie) zuletzt bei Modellen vor sieben Jahren und mehr (zuletzt praktisch bei der 7390 und die 7490 erschien 2014) funktionierten, erst einmal hier im Board einliest, der sollte auch keine Schwierigkeiten haben, eine richtige(!) Anleitung dafür zu finden.

Es tut mir zwar leid, wenn mal wieder jemand eine eigentlich funktionsfähige FRITZ!Box erlegt hat, aber das liegt sicherlich nicht an einem Mangel an korrekten Anleitungen/Beschreibungen, wie man dabei vorgehen sollte. Selbst bei heise.de kann man das - mit viel Brimborium gewürzt - mittlerweile nachlesen und ich wüßte keine (ernstzunehmende!) Quelle, die für eine 7520/7530 tatsächlich das Beschreiben von MTD1 (oder MTD0 oder was auch immer) als zielführend angegeben würde. Wenn das so funktionieren würde, wäre das vermutlich auch der Weg, den AVM mit dem Recovery-Programm anwenden würde ... und daß dieses nicht der Fall ist, ist verbürgt.
Ich habe mich an den c't-Artikel gehalten, aber damit keinen Erfolg gehabt (wie schon geschrieben, das Recovery-Tool hat in vielen Versuchen keine Verbindung bekommen.

Die Methode mit PUT auf MTD1 habe ich mehrfach als Alternative gesehen, habe gerade mal hier im Forum gesucht, und hätte das wohl vor dem Versuch machen sollen, z.B. war hier ein früherer gescheiterter Versuch:

https://www.ip-phone-forum.de/threads/solved-fritz-box-7362-sl-fail-to-boot.286853/#post-2178028

Aber ich sehe jetzt, dass dieser Versuch naiv war - das ging wohl nur mit sehr viel früheren Boxen und seit den 73xx schon nicht mehr ...

Gibt es irgend eine Möglichkeit, ein "gesundes" Image auf die Box zu bekommen (abgesehen davon, dass AVM das wohl könnte, oder bauen die einen vorprogrammierten Flash-Chip mit Boot-Loader ein und können auch nur darüber Firmware einspielen)?

Vielen Dank für die Antwort - den nächsten Versuch etwas an einer Fritz!box zu machen starte ich jedenfalls erst nach einer gründlichen Recherche hier im Forum!

Edit: doppelten Link korrigiert
 

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
13,937
Punkte für Reaktionen
1,301
Punkte
113
das Recovery-Tool hat in vielen Versuchen keine Verbindung bekommen
Es hilft Dir zwar nicht mehr, aber für andere halte ich dennoch erneut fest, daß solche Probleme (erst recht dann, wenn eine FTP-Verbindung von demselben System funktioniert) zu > 99% "hausgemacht" sind.

Anstatt dann auf andere Optionen zu verfallen (außer ggf. das Befolgen der hier im Board empfohlenen Schritte beim Verwandeln einer 7520 in eine 7530, wo aber ebenfalls das passende Recovery-Programm benötigt wird: https://www.ip-phone-forum.de/threads/sammelthema-zur-avm-fritz-box-7520.302364/post-2366333), sollte man sich in diesem Falle einfach vergewissern, WARUM das mit dem Recovery-Programm nicht funktioniert.

Bei passendem Windows-System, passender Verkabelung (das muß nicht zwangsläufig die von AVM empfohlene sein) und einer funktionierenden FRITZ!Box gibt es (egal mit welchem Recovery-Programm man arbeitet, das kann auch eines für ein falsches Modell sein) keinen objektiven Grund, warum das nicht funktionieren sollte ... und die Zeit, die man in "Umgehungslösungen" steckt, ist in die Fehlersuche bei der Verwendung des Recovery-Programms deutlich besser investiert.

Dem einen oder anderen hat auch schon mein "Erklärungsversuch", wie das eigentlich funktioniert, dabei geholfen, letztlich doch noch zum Erfolg zu kommen: https://www.ip-phone-forum.de/threads/wie-recovere-ich-eigentlich-richtig.299790/
 

Fritzbox_7490

Neuer User
Mitglied seit
1 Okt 2017
Beiträge
11
Punkte für Reaktionen
1
Punkte
3
Hallo,

ich hab heute nach der Anleitung die Box aktualisiert. Meine alte "7520" ist jetzt 7530 mit FRITZ!OS: 07.27 - Update verfügbar und will auf die 07.25 zurück.
Hab ich doch was falsch gemacht? Das FRITZ.Box_7530-07.27-recover hat alles OK ausgegeben.
 

genuede

Neuer User
Mitglied seit
25 Mrz 2009
Beiträge
92
Punkte für Reaktionen
8
Punkte
8
@Fritzbox_7490
Alles richtig gemacht. Ansonsten hier im Forum noch mal nachlesen, warum die Box zurück will. Also Updatemeldung einfach ignorieren.
 
Zuletzt bearbeitet:

st.esser

Neuer User
Mitglied seit
10 Sep 2006
Beiträge
22
Punkte für Reaktionen
1
Punkte
3
Vollzitat gemäß Boardregeln entfernt by stoney
Vielen Dank für die Antwort - ich verstehe sie so, dass jetzt höchstens noch das Auslöten der Flash-Chips und Programmierung mit einem externen Programmier-Gerät weiter helfen könnte.

Warum das mit dem Recovery-Tool nicht geklappt hat ist mir aber immer noch nicht klar - aber ich bin eigentlich kein Windows-User, habe mir für die Aktion ein Windows-Notebook ausleihen müssen.
Die Verbindung ging aber über einen Switch mit ping in 2. Fenster um zu sehen, wann die Box auf 192.168.178.1 gesetzt ist, das Recovery-Tool hat aber dieses Zeitfenster nie genutzt.

Würde AVM für so eine kaputte Box Fall eine Reparatur anbieten können/wollen?
(Dass da keine Garantie oder Gewährleistung greift ist mir natürlich klar ...)
 
Zuletzt bearbeitet von einem Moderator:

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
13,937
Punkte für Reaktionen
1,301
Punkte
113
Die Verbindung ging aber über einen Switch mit ping in 2. Fenster um zu sehen, wann die Box auf 192.168.178.1 gesetzt ist, das Recovery-Tool hat aber dieses Zeitfenster nie genutzt.
Das liegt einfach daran, daß das Recovery-Programm nicht einfach nach irgendeinem Client mit der Adresse 192.168.178.1 pingt, sondern die Box ganz gezielt sucht und zwar mit UDP-Broadcasts (aber nochmal: das ist alles mehr als einmal ausführlich erklärt und beschrieben). Solange die Antworten auf diese Broadcasts nicht bis zum Recovery-Programm durchdringen, weil das irgendeine Firewall verhindert (das wäre auch meine erste Vermutung hinsichtlich eines Problems), wartet das Programm eben auf solche Antworten. Die Firewall kann dabei entweder die eingebaute von Windows sein (die gibt es auch schon seit vielen Versionen und nicht erst seit Windows 10) oder irgendwelches Schlangenöl - bei ordentlich konfiguriertem System fragt diese Software dann auch beim ersten Versuch nach, wie mit solchen Zugriffsversuchen (Öffnen eines Ports, der von anderen Clients aus erreichbar sein soll) zu verfahren wäre.

Leider sind auch dabei die vorgeschlagenen Standardwerte nicht immer sinnvoll (erst recht nicht dann, wenn sich jemand ein Windows-System erst ausleihen muß - dann darf man zumindest mal unterstellen, daß das Netzwerk der FRITZ!Box als "öffentlich" angesehen wird, was ein anderes Firewall-Profil aktiviert) und wenn man von Windows obendrein keine Ahnung hat, sorgt ein falscher Klick (über den man sich gar keine Gedanken macht) ganz schnell dafür, daß mit genau dieser Version des Recovery-Programms tatsächlich nichts mehr geht, weil die einmal getroffene Auswahl für ebendieses Programm gespeichert wird und nur das manuelle Entfernen der falschen Entscheidung oder ein anderes Recovery-Programm (weil die Entscheidung eben nach Programmen gespeichert wird) kann das dann wieder in einen Zustand versetzen, der beim nächsten Anlauf mehr Erfolg verspricht.

Aber wenn ich "kein Windows-Benutzer" lese, bleiben ja üblicherweise nur zwei andere Optionen ... entweder jemand benutzt Apple-Geräte und -Software (dann ist ihm halt nicht zu helfen bzw. er hat es nicht besser verdient - um mal wieder ein paar Vorurteile zu kultivieren) oder er benutzt regelmäßig Linux - zumindest wenn's um PCs geht (Exoten wie ChromeOS lasse ich mal außen vor) und ohne einen solchen, wird man sich ja hoffentlich nicht dazu versteigen, jemand anderem eine FRITZ!Box auf eine andere Software zu aktualisieren.

Und wenn man tatsächlich ohnehin Linux benutzt, braucht es für diese "Operation", die auch bei heise.de beschrieben wurde (halt auch wieder nur für Windows-Benutzer bzw. unter Verwendung des AVM-Recovery-Programms), nur ein paar simple Skripte ... man MUSS diesen ganzen Mummenschanz mit HWRevision nämlich tatsächlich überhaupt nur veranstalten, um das AVM-Programm zu übertölpeln. Macht man das einfach alles selbst (was sowohl unter Windows als auch unter Linux bzw. bei MacOS unter zsh funktionieren sollte - dazu erstellt man sich dann tatsächlich aus der kernel.image und der filesystem.image eine eigene Datei, die man auf die Box lädt, aber vollkommen anders, als das hier versucht wurde), dauert das auch nicht wirklich länger ... das AVM-Programm ist nur (sofern man mit Windows auch umgehen kann) die einfachste Lösung (für diese Aufgabe - während man die anderen Ansätze auch für viele weitere Zwecke verwenden kann).

Ich habe keine Ahnung, was EVA überschrieben hat bei diesem Modell (das ich selbst gar nicht besitze), wenn da MTD0 und MTD1 mit irgendwelchen Daten beschrieben wurden - soweit ich das in #1 sehe, wurden sowohl MTD1 als auch MTD0 überschrieben und die Box hat nur NAND-Flash. Ausgehend von diesen Definitionen im EVA-Environment:
Code:
mtd0  0x0,0x2C00000
mtd1  0xB00000,0xF00000
mtd2  0x0,0x2C0000
mtd3  0x2C0000,0xB00000
mtd4  0xF00000,0x1300000
mtd5  0x1300000,0x8000000
läge MTD2 (was bei AVM eigentlich fast immer die Lage und die Größe der EVA-Partition beschreibt) vollständig innerhalb von MTD0 und wenn der Bootloader tatsächlich diese Partition gelöscht haben sollte, bevor er die Daten aus der filesystem.image entgegennahm, dann ist die Box wohl (außer vom Hersteller) nicht mehr zu retten.

Bisher ist es m.W. auch noch keinem Besitzer gelungen, einen Bootloader von einem anderen Gerät desselben Modells auf eine solche Box zu verpflanzen - es gibt aber Berichte, daß schon Versuche, die Basisdaten im Loader zu ändern (speziell HWRevision), was bei anderen Modellen noch einigermaßen verläßlich möglich ist, zu einer nicht mehr startenden Box geführt haben. Da der Flash-Chip hier auch nicht so einfach auszulöten ist oder im eingebauten Zustand neu programmiert werden kann über irgendwelche Adapter, wie das bei SPI-Flash ja leicht machbar wäre, sehe ich keine Möglichkeit, wie man (ohne JTAG o.ä., wofür m.W. auch Infos fehlen) den Bootloader wiederherstellen könnte.

Da wird vermutlich nur der Kauf einer anderen Box bleiben, die man dann - diesmal mit den richtigen Methoden - weiter behandeln kann. Wobei man ja zumindest mal noch einen UART-Adapter anlöten könnte ... die ARM-Chips haben ja alle einen kleinen 1st-Stage-Loader direkt im SoC und mit etwas Glück kriegt man zumindest von dem noch ein paar Infos, bei welcher Stage (EVA ist m.W. erst die dritte) es klemmt.

PS: Es gibt keinen Grund für irgendwelche Vollzitate ... ich lösche NIE irgendwelche Beiträge, auf die schon jemand geantwortet oder Bezug genommen hat. Das solltest Du wenigstens noch korrigieren, BEVOR es die Moderation für Dich macht/machen muß.
 

KunterBunter

IPPF-Urgestein
Mitglied seit
12 Okt 2005
Beiträge
26,331
Punkte für Reaktionen
597
Punkte
113
Würde AVM für so eine kaputte Box Fall eine Reparatur anbieten können/wollen?
(Dass da keine Garantie oder Gewährleistung greift ist mir natürlich klar ...)
AVM bietet nie eine Reparatur an. Dei Fritzbox 7520 wurde aber von 1&1 bezogen. Die tauschen die ganz sicher kostenlos aus, ohne groß zu fragen. :)
 

st.esser

Neuer User
Mitglied seit
10 Sep 2006
Beiträge
22
Punkte für Reaktionen
1
Punkte
3
AVM bietet nie eine Reparatur an. Dei Fritzbox 7520 wurde aber von 1&1 bezogen. Die tauschen die ganz sicher kostenlos aus, ohne groß zu fragen. :)
Nein, das kommt für mich nicht in Frage - ich habe die Dummheit begangen und trage die Konsequenzen.
Wenn es ein (kostenpflichtiges) Reparaturangebot gäbe, hätte ich das angenommen, jedenfalls wenn es nicht über dem Gebrauchtpreis für eine 7520 liegen würde.
 
  • Like
Reaktionen: Profanta

Grisu_

Aktives Mitglied
Mitglied seit
26 Apr 2019
Beiträge
1,458
Punkte für Reaktionen
328
Punkte
83
Wie soll eine Firma das bei dem nötigen Aufwand günstiger als eine Gebrauchte anbieten können bei den hiesigen Stundenlöhnen für doch ziemliche Spezialisten.
Und auch die können sich vorher nicht sicher sein ob es damit getan ist. Nur weil du das schreibst zählt für ein Unternehmen wenig, gibt viel zuviele Falschmeldungen bezügl. Fehler, müssen dann ja auch Gerantie geben für die Reparatur.
 

HabNeFritzbox

IPPF-Urgestein
Mitglied seit
12 Dez 2017
Beiträge
18,262
Punkte für Reaktionen
660
Punkte
113
Gibt doch sonst noch Seriellen Port, oder Flash auslöten und dann neu beschreiben. Ist natürlich Aufwand, und nicht ganz ohne, wobei kaputter bekommst es ja kaum noch.

Sonst halt Elektronik raus und was LED Beleuchtung rein, haste noch ne Deko.

Edit: Ach der liebe Peter hat es ja schon erwähnt mit Löten.
 
Zuletzt bearbeitet:
  • Like
Reaktionen: Karl. und Deckard99

HabNeFritzbox

IPPF-Urgestein
Mitglied seit
12 Dez 2017
Beiträge
18,262
Punkte für Reaktionen
660
Punkte
113
Wenn man ganze Werkzeug nicht hat für Seriellen Port oder um Chips zu flashen usw., kann ja evt. hier wer im Forum ganze erledigen und macht es für kleine Aufwandsentschädigung/Portoauslage.

Wenn 7530 im Angebot ist gibt es die auch für unter 100€ neu, oder bei 1&1 in Aktion gratis dazu.
 

st.esser

Neuer User
Mitglied seit
10 Sep 2006
Beiträge
22
Punkte für Reaktionen
1
Punkte
3
Die Firewall kann dabei entweder die eingebaute von Windows sein (die gibt es auch schon seit vielen Versionen und nicht erst seit Windows 10) oder irgendwelches Schlangenöl - bei ordentlich konfiguriertem System fragt diese Software dann auch beim ersten Versuch nach, wie mit solchen Zugriffsversuchen (Öffnen eines Ports, der von anderen Clients aus erreichbar sein soll) zu verfahren wäre.
Ja, ist mir alles bekannt, den Zugriff habe ich natürlich im Firewall-Popup zugelassen. Ich nutze zwar kein Windows, habe aber 40 Jahre Erfahrung mit Unix, habe Embedded-Control-Hardware entworfen und programmiert, Unix-Kernel-Code etc.

Es war reine Hybris, dass ich ohne Details der Fritz!box zu kennen einen Brute-Force-Programmierversuch unternommen habe. Ich war davon ausgegangen, dass ich den Boot-Loader nicht so einfach überschreiben könnte und dadurch immer einen Fallback-Weg hätte ...
Leider sind auch dabei die vorgeschlagenen Standardwerte nicht immer sinnvoll (erst recht nicht dann, wenn sich jemand ein Windows-System erst ausleihen muß - dann darf man zumindest mal unterstellen, daß das Netzwerk der FRITZ!Box als "öffentlich" angesehen wird, was ein anderes Firewall-Profil aktiviert) und wenn man von Windows obendrein keine Ahnung hat, sorgt ein falscher Klick (über den man sich gar keine Gedanken macht) ganz schnell dafür, daß mit genau dieser Version des Recovery-Programms tatsächlich nichts mehr geht ...
Wie gesagt, ich bin Kernel-Entwickler, nur Windows meide ich wo immer es geht. Das Netzwerk war natürlich auf "privat" gestellt, beruflich bin ich gezwungen mit Windows zu arbeiten (nutze das Notebook aber nicht privat) und kenne alle Versionen seit Windows 2.x, habe aber nie Software dafür entwickelt. Und IP-LANs habe ich schon in den 80er-Jahren konzipiert und administriert, daran liegt es bei mir definitiv nicht.
Aber wenn ich "kein Windows-Benutzer" lese, bleiben ja üblicherweise nur zwei andere Optionen ... entweder jemand benutzt Apple-Geräte und -Software (dann ist ihm halt nicht zu helfen bzw. er hat es nicht besser verdient - um mal wieder ein paar Vorurteile zu kultivieren) oder er benutzt regelmäßig Linux - zumindest wenn's um PCs geht (Exoten wie ChromeOS lasse ich mal außen vor) und ohne einen solchen, wird man sich ja hoffentlich nicht dazu versteigen, jemand anderem eine FRITZ!Box auf eine andere Software zu aktualisieren.
Nein, ich bin BSD-Entwickler und seit über 25 Jahren Committer in FreeBSD, aber Device-Treiber-Code von mir ist auch in den Linux-Kernel eingegangen, da ich kein Problem mit einer Doppellizenzierung unter GPLv2 habe. Linux habe ich entstehen sehen, aber war da schon so lange in den BSD-Sourcen unterwegs, dass es mich nicht sonderlich interessiert hat ...
Und wenn man tatsächlich ohnehin Linux benutzt, braucht es für diese "Operation", die auch bei heise.de beschrieben wurde (halt auch wieder nur für Windows-Benutzer bzw. unter Verwendung des AVM-Recovery-Programms), nur ein paar simple Skripte ... man MUSS diesen ganzen Mummenschanz mit HWRevision nämlich tatsächlich überhaupt nur veranstalten, um das AVM-Programm zu übertölpeln. Macht man das einfach alles selbst (was sowohl unter Windows als auch unter Linux bzw. bei MacOS unter zsh funktionieren sollte - dazu erstellt man sich dann tatsächlich aus der kernel.image und der filesystem.image eine eigene Datei, die man auf die Box lädt, aber vollkommen anders, als das hier versucht wurde), dauert das auch nicht wirklich länger ... das AVM-Programm ist nur (sofern man mit Windows auch umgehen kann) die einfachste Lösung (für diese Aufgabe - während man die anderen Ansätze auch für viele weitere Zwecke verwenden kann).
Wenn ich das geahnt hätte, hätte ich das gemacht. Wie gesagt, ich habe mich an dieses Forum erst erinnert, als es zu spät war. Da hatte ich mich zu Zeiten der 7570-Umwandlung angemeldet und war zwischenzeitlich reiner Fritz!box-Nutzer (da mein Interesse nun mal primär in FreeBSD-Projekten liegt). Ich werde mal im Forum nach einer Anleitung zum Update per Skript suchen ...
Ich habe keine Ahnung, was EVA überschrieben hat bei diesem Modell (das ich selbst gar nicht besitze), wenn da MTD0 und MTD1 mit irgendwelchen Daten beschrieben wurden - soweit ich das in #1 sehe, wurden sowohl MTD1 als auch MTD0 überschrieben und die Box hat nur NAND-Flash. Ausgehend von diesen Definitionen im EVA-Environment:
[...]
läge MTD2 (was bei AVM eigentlich fast immer die Lage und die Größe der EVA-Partition beschreibt) vollständig innerhalb von MTD0 und wenn der Bootloader tatsächlich diese Partition gelöscht haben sollte, bevor er die Daten aus der filesystem.image entgegennahm, dann ist die Box wohl (außer vom Hersteller) nicht mehr zu retten.
Dass mtd2 das erste 1/16 von mtd0 überdeckt war mir aufgefallen, aber ich war davon ausgegangen, dass das Image-File dann Daten für beide Bereiche enthalten würde.
Das Schreiben ging sehr schnell, ich hatte vermutet, dass die hochgeladenen Dateien erst mal nur im RAM abgelegt worden sind und erst beim Reboot dann eine Übertragung in den Flash-Speicher passiert ist. Ich hatte die Box deshalb auch mehrere Minuten nicht vom Stromnetz getrennt, in der Hoffnung, dass sie wieder booten würde.
Bisher ist es m.W. auch noch keinem Besitzer gelungen, einen Bootloader von einem anderen Gerät desselben Modells auf eine solche Box zu verpflanzen - es gibt aber Berichte, daß schon Versuche, die Basisdaten im Loader zu ändern (speziell HWRevision), was bei anderen Modellen noch einigermaßen verläßlich möglich ist, zu einer nicht mehr startenden Box geführt haben. Da der Flash-Chip hier auch nicht so einfach auszulöten ist oder im eingebauten Zustand neu programmiert werden kann über irgendwelche Adapter, wie das bei SPI-Flash ja leicht machbar wäre, sehe ich keine Möglichkeit, wie man (ohne JTAG o.ä., wofür m.W. auch Infos fehlen) den Bootloader wiederherstellen könnte.
Ich gehe davon aus, dass AVM es per JTAG könnte, aber ich habe mich vor etwa 25 Jahren komplett vom Thema Hardware-Entwicklung verabschiedet. Dass ich da selber nicht weiterkomme ist mir klar, selbst wenn die JTAG-Pins zugänglich wären und JTAG nicht per Fuse deaktivert worden ist.
Da wird vermutlich nur der Kauf einer anderen Box bleiben, die man dann - diesmal mit den richtigen Methoden - weiter behandeln kann. Wobei man ja zumindest mal noch einen UART-Adapter anlöten könnte ... die ARM-Chips haben ja alle einen kleinen 1st-Stage-Loader direkt im SoC und mit etwas Glück kriegt man zumindest von dem noch ein paar Infos, bei welcher Stage (EVA ist m.W. erst die dritte) es klemmt.
Das Löten wäre nicht das Problem, aber ich fürchte, dass selbst wenn es da einen Debug-Monitor gäbe, der das Beschreiben von RAM-Bereichen erlaubt, nicht weit käme, da ich nicht wüsste, was man da hinein schreiben muss.

Ich habe mir gerade mal das IPQ4019-Datenblatt angeschaut. Der Chip unterstützt ja u.a. auch das Booten von USB (über 2 GPIO-Pins gesteuert). Wenn das aktiviert werden könnte, dann sollte eine Recovery (theoretisch) möglich sein. Ich fürchte nur, dass diese PINs so verdrahtet sind, dass man sie nicht auf "high"-Level ziehen kann.

Aber auch dann ist nicht klar, dass ein Image auf dem USB-Stick identisch zum Flash-ROM organisiert sein müsste. Mir würde es aber schon reichen, wenn ich nur den überschriebenen Boot-Loader so ersetzen könnte. Der ist aber wahrscheinlich nicht in den Update- oder Recovery-Images enthalten, sondern müsste aus einer Box ausgelesen werden. (?)
PS: Es gibt keinen Grund für irgendwelche Vollzitate ... ich lösche NIE irgendwelche Beiträge, auf die schon jemand geantwortet oder Bezug genommen hat. Das solltest Du wenigstens noch korrigieren, BEVOR es die Moderation für Dich macht/machen muß.
Zu spät, das Löschen war schon passiert - tut mir Leid, ich kenne die Foren-Regeln hier offensichtlich nicht gut genug.

Ich hoffe, dass die Zitate in dieser Antwort OK sind, da ich mich direkt auf sie beziehe. Ansonsten werde ich den Beitrag natürlich so editieren, dass er den Regeln entspricht. Ich habe aber nicht gesehen, wie ich die zitierten Blöcke sinnerhaltend hätte verkürzen können.

Was das Recover-Tool am Erkennen der Fritzbox gehindert hat, ist mir nicht klar, m.E. war die Firewall offen (privates LAN und Firewall für das Tool freigegeben). Ich hatte ja extra ein privates Notebook geliehen, da ich auf dem Firmen-Notebook keine Admin-Rechte habe ...

Aber jetzt suche ich erst mal im Forum die Anleitung fürs Flashen per Skript von Unix/Linux.
Vielen Dank für die Antworten und insbesondere den Hinweis auf diese Skripte!

-- Zusammenführung Doppelpost gemäß Boardregeln by stoney

Wenn man ganze Werkzeug nicht hat für Seriellen Port oder um Chips zu flashen usw., kann ja evt. hier wer im Forum ganze erledigen und macht es für kleine Aufwandsentschädigung/Portoauslage.
Falls jemand das machen könnte, dann würde ich es gerne annehmen. Aber ich fürchte, dass bei dieser Box der Flash-Chip ausgelötet werden müsste, um ihn neu zu programmieren.
Aber ich habe gerade im Datenblatt gesehen, dass der ARM-Chip in der 7520/7530 das Booten von USB unterstützt. Dazu muss man aber einen Pin des Chips (V25 / GPIO51) von 0 auf 1 ziehen können. Dann würde der Boot-Loader auf einem USB-Stick für die Revory ausreichen.
Wenn 7530 im Angebot ist gibt es die auch für unter 100€ neu, oder bei 1&1 in Aktion gratis dazu.
Es gibt Angebote zwischen 60 und 70 Euro bei Ebay-Kleinanzeigen, da habe ich schon geschaut ob es etwas in der Nähe gibt.
Letztes Jahr hatte ich da schon mal eine Box für jemand anderen gekauft aber nicht geliefert bekommen (Strafanzeige erstattet, Anbieter ist ermittelt und verurteilt worden da er das gewerbsmäßig gemacht hat und ich nur einer von mehreren Geschädigten war). Für mich kommt da nur noch direkte Abholung oder sichere Bezahlung in Frage.
Für 100 Euro würde ich aber eine neue 7530 mit Garantie vorziehen. Ich muss jetzt nur kurzfristig die 7520 ersetzen, das war ja nicht meine, sondern ich wollte die Umstellung auf 7530 für jemand anderen machen ...

-- Zusammenführung Doppelpost gemäß Boardregeln by stoney

@st.esser
Lass dich nicht runterziehen besorg dir eine bei Ebay
Danke, aber bei eBay sind das ja meist Versteigerungen, die nach mehreren Tagen bei 80 bis 90 Euro enden, oder 100 Euro oder mehr für direkte Verkäufe.

Mit eBay-Kleinanzeigen hatte ich schon einmal Probleme (habe einem vertrauenswürdig erscheinenden Verkäufer Geld vorab überwiesen und nichts geliefert bekommen), deshalb würde ich das nur noch mit Abholung oder "Sicherer Bezahlung" machen.

Da gibt es Angebote für 60 bis 70 Euro - aber bei zwei Anfragen die ich heute losgeschickt habe war die erste Box schon verkauft und der Anbieter der zweiten Box wollte sie nur gegen eBay-Friends-Zahlung verkaufen, da kann ich das Geld gleich verbrennen ...
 
Zuletzt bearbeitet von einem Moderator:

Olga66

Aktives Mitglied
Mitglied seit
21 Mai 2013
Beiträge
818
Punkte für Reaktionen
133
Punkte
43
Hier im Forum werden auch Boxen angeboten, stelle einfach eine Anfrage oder schau ob einer eine anbietet.
 

Zurzeit aktive Besucher

3CX

Neueste Beiträge

Statistik des Forums

Themen
238,449
Beiträge
2,112,734
Mitglieder
361,205
Neuestes Mitglied
andivialli

Erhalten Sie 3CX für 1 Jahr kostenlos!

Gehostet, in Ihrer privaten Cloud oder on-Premise! Ganz ohne Haken. Geben Sie Ihren Namen und Ihre E-Mail an und los geht´s:

3CX
Für diese E-Mail-Adresse besteht bereits ein 3CX-Konto. Sie werden zum Kundenportal weitergeleitet, wo Sie sich anmelden oder Ihr Passwort zurücksetzen können, falls Sie dieses vergessen haben.
oder via