Fritz!Box Fon Wlan 08.04.49 downgrade?

blackbile

Neuer User
Mitglied seit
2 Feb 2006
Beiträge
57
Punkte für Reaktionen
0
Punkte
0
Hello,

is it possible to flash an older firmware onto this ?

I cant enable/switch on the telnet too!

It does not enable any patch or older firmware to flashing...
(english firmware)

Thanks, Zsolt /Hungary
 

el_valiente

Aktives Mitglied
Mitglied seit
9 Aug 2005
Beiträge
2,222
Punkte für Reaktionen
0
Punkte
36
is it possible to flash an older firmware onto this ?
Yeah, it's possible, but a little sophisticated.
Starting approximately with FW version xx.04.30 avm changed the bootloader.
Thus for downgrade you must replace the bootloader. That's dangerous.
The "how to" is described for FB7050 in [post=833677]this thread[/post].
I did it with different FB7050 - it works. I also did it with FB Fon WLAN (the one you have), and it works, too. But you need a copy of the "old" mtd2.
I suggest you to carefully read about the topic and decide by yourself, if you should try it.
.
 

blackbile

Neuer User
Mitglied seit
2 Feb 2006
Beiträge
57
Punkte für Reaktionen
0
Punkte
0
Thank you.

I saw that thread and I just want to say that I cant reach the telnet... so I cant flash mtd2 to mtd3 place...

I just reach the ADAM2 ftp login.
 

el_valiente

Aktives Mitglied
Mitglied seit
9 Aug 2005
Beiträge
2,222
Punkte für Reaktionen
0
Punkte
36
I saw that thread and I just want to say that I cant reach the telnet ...
I know. FW 08.04.49 uses the whole flash-memory, there is no room for any telnet daemon.
I described [post=1149633]here[/post] how to solve this problem.
Hopefully you understand a little german ...
.
 

imagomundi

IPPF-Promi
Mitglied seit
27 Okt 2006
Beiträge
3,700
Punkte für Reaktionen
3
Punkte
38
More information ALWAYS helps both sides! I understand: Your FBFW runs on fw 08.04.49 which is ENGLISH and you want to DOWNGRADE it - to a lower ENGLISH fw or a German fw? WHY DOU YOU WANT TO DOWNGRADE? Which ANNEX is your FB? Some more words to make other users understand your situation would certainly be useful.
 

blackbile

Neuer User
Mitglied seit
2 Feb 2006
Beiträge
57
Punkte für Reaktionen
0
Punkte
0
to a lower ENGLISH fw or a German fw? WHY DOU YOU WANT TO DOWNGRADE? Which ANNEX is your FB?
Ok, here it is:

I want to have a english firmware with Annex-B. I have problem with my ADSL line quality and I thought that maybe the latest firmware has some problem related of it...

08.04.49. is on the official avm ftp site.
 

imagomundi

IPPF-Promi
Mitglied seit
27 Okt 2006
Beiträge
3,700
Punkte für Reaktionen
3
Punkte
38
I have problem with my ADSL line quality
Poor line/poor signal receiving will not change through downgrade. Recently I tested several FB's on a poor line. None of them got a sync - except the 7270. All others (FBF, FBFW, 7050, 7170, 7150) showed the same (bad) signal quality indicating numbers. It's a question of poor line AND the quality of the modem installed in the FB by AVM. If both are poor - no chance. As to the line you can't do much. As to the modem you can either try the 7270 that has the best modem of all FB's or simply run the FB BEHIND another router/modem connecting the FB through LAN1 to this modem/router.
 

blackbile

Neuer User
Mitglied seit
2 Feb 2006
Beiträge
57
Punkte für Reaktionen
0
Punkte
0
imagomundi: Thanks for your help

yes, you are right because I tried a comtrend ADSL modem and it had a much better Attainable data rate than my FBFW...

My only problem that in this case I have to connect via USB to the PC! Has it any negative issue?
 

el_valiente

Aktives Mitglied
Mitglied seit
9 Aug 2005
Beiträge
2,222
Punkte für Reaktionen
0
Punkte
36
My only problem that in this case I have to connect via USB to the PC! Has it any negative issue?
Imagomundi is totally right in pointing out that "More information ALWAYS helps both sides!"
And in principle he is right in suggesting "simply run the FB BEHIND another router/modem".
But he forgot one important point: The FW 08.04.49 has a terrible bug: it doesn't work in modus "Internet access via LAN1" ! See [post=1149633]this thread[/post].
If you want to use the FB FON WLAN behind another router, you must load the german FW version 08.04.34.
Changing from english FW 08.04.49 to german FW 08.04.34 is easy: Just replace "firmware_version avme" by "firmware_version_avm" and load the FW via the update option in the web interface.
.
 

el_valiente

Aktives Mitglied
Mitglied seit
9 Aug 2005
Beiträge
2,222
Punkte für Reaktionen
0
Punkte
36
How can I change?
The easiest way: Load the pseudo-FW using the normal update option in the web-GUI. Ignore any error messages.
The correct pseudo-FW is [post=971638]fritz_as_avm_newer.tar[/post] ... thanks to the author telefonicus!
Good luck!
.
 

blackbile

Neuer User
Mitglied seit
2 Feb 2006
Beiträge
57
Punkte für Reaktionen
0
Punkte
0
el_valiente: I did it, but the next problem is that the german recover software want to find the Fritz on the 192.168.178.2 while it is ...178.1 ?!

edited: I cant update the 08.04.01 avm German firmware too on the webinterface!!!

Any idea?
 
Zuletzt bearbeitet:

imagomundi

IPPF-Promi
Mitglied seit
27 Okt 2006
Beiträge
3,700
Punkte für Reaktionen
3
Punkte
38
I did it, but the next problem is that the german recover software want to find the Fritz on the 192.168.178.2 while it is ...178.1 ?!
THIS IS OK anyway! During recover process Fritz does not have an "own" IP - gets default 192.168.178.1 again at the end of recover procedure as part of that.

blackbile<1188161 schrieb:
cant update the 08.04.01 avm German firmware too on the webinterface!!!

Any idea?
To upload (better: downgrade to) a fw lower than 04.30 (at fw 04.30 AVM changed the Linux kernel of their boxes from Linux version 2.4 to 2.6 and consequently partitioned differently the whole flash area) you must first change the bootloader -more precisely: flash memory part mtd2- of the box.This is a rather difficult action. At the stage where you are now you will be able to recover with the GERMAN fw 04.34 without any problem after you changed fw-version to AVM as you already did.
 

blackbile

Neuer User
Mitglied seit
2 Feb 2006
Beiträge
57
Punkte für Reaktionen
0
Punkte
0
You say that I just need to wait while my Fritz has "avm" and the 04.01 recover imageis working??? Because as I said earlier it seems to me that it cant find the Fritz...
 

imagomundi

IPPF-Promi
Mitglied seit
27 Okt 2006
Beiträge
3,700
Punkte für Reaktionen
3
Punkte
38
Without replacing the actual bootloader of your box you will NEVER be able to upload a fw lower than 04.30 = you cannot simply upload (or recover) fw 04.01!!
The utmost you can do is upload the recovery fw (German) 04.34. This will work and with this fw you can run your FBFW BEHIND another modem/router getting FBFW its dsl signal through LAN1. BUT: FW 04.34 (or even 04.01) will NOT solve your poor line quality problem - and the modem of your box always remains the same independent of its fw. It will not be more "sensible" to improve its sync quality.
 

blackbile

Neuer User
Mitglied seit
2 Feb 2006
Beiträge
57
Punkte für Reaktionen
0
Punkte
0
So I rather do nothing ? With older firmware it will not better at all?
 

el_valiente

Aktives Mitglied
Mitglied seit
9 Aug 2005
Beiträge
2,222
Punkte für Reaktionen
0
Punkte
36
So I rather do nothing ? With older firmware it will not better at all?
Older FW is not better. The best solution for you is german FW 08.04.34. If this one is already running at your FB, be happy and don't change it any more.
Do as imagomundi suggested: Use the FB behind your standard router. Configure the router as "transparent" or "bridged" (see the manual of your router) and the FB as "Internet access via LAN1".
.
 

blackbile

Neuer User
Mitglied seit
2 Feb 2006
Beiträge
57
Punkte für Reaktionen
0
Punkte
0
Ok, but yesterday night I stopped at the firmware upload, because the recover didnot do it.

And just for the exact info I need Annex-B so the 08.04.34 German version is not good for me.
 

el_valiente

Aktives Mitglied
Mitglied seit
9 Aug 2005
Beiträge
2,222
Punkte für Reaktionen
0
Punkte
36
And just for the exact info I need Annex-B so the 08.04.34 German version is not good for me.
You are confused! Where from did you get such info? German FW 08.04.34 is Annex B !!!
In Germany all lines (ISDN and POTS) are Annex B! For that reason most FW versions are Annex B. Only some special editions (international and Austria/Switzerland) are Annex A.
Thus you should load FW 08.04.34 - it is what you need.
.
One more info: The Annex can be easily changed in any FW version! The pseudo-images written by telefonicus do that (see [post=971638]here[/post])
.
 

Zurzeit aktive Besucher

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,831
Beiträge
2,027,213
Mitglieder
350,919
Neuestes Mitglied
patka