[Problem] Fritz!NAS hängt irgendwie

s'KATERchen

Mitglied
Mitglied seit
4 Aug 2006
Beiträge
324
Punkte für Reaktionen
1
Punkte
18
Hallo,
ich war gerade dabei über Fritz!NAS meine Musiksammlung auf dem USB-Stick etwas zu sortieren. Da das einfache verschieben von Dateien ja offenbar nicht geht, habe ich eine Datei ausgeschnitten und in einen anderen Ordner eingefügt. Das funktionierte auch - eine Weile.
Irgendwann bekam ich dann eine Fehlermedlung, "Fehler beim Einfügen" und "Einer der Uebergebenen Parameter war falsch, das Verschieben der Daten wurde abgebrochen."
Laut NAS ist die Datei immer noch im ursprünglichen Ordner. In der App von meinen Wlan-Lautprecher wird sie auch dort angezeigt, aber abspielen lässt sie sich nicht. Wenn ich nun im Windows-Explorer nachschaue, ist die Datei aber doch schon im neuen Ordner. Ach mit anderen Dateien ist es das Gleiche.
Kann mir wer nen Tip geben?
Fritz!OS: 06.87

P.S.
Im NAS der MyFritz App sind die Dateien auch richtig verschoben.

PPS
Hab jetzt die Box einfach mal neu gestartet, jetzt geht es wieder.
 
Zuletzt bearbeitet:
Das Thema ist doch noch nicht erledigt. Hab gerade wieder Zeit gefunden, mich ans Sortieren zu machen - und es geht nicht.
Ich habe einen Ordner, in dem mp3-Dateien liegen. In diesem Ordner habe ich Unterordner, in die die Dateien entsprechend des Genres einsortiert, also verschoben, werden sollen.
Wenn ich nun eine Datei im Hauptordner markiere ausschneide und im Unterordner einfüge, bekomme ich eine Fehlermeldung oder auch das noch nicht mal. Die verschobene Datei wird im Unterordner nicht angezeigt, befindet sich angeblich aber noch im Hauptordner. Wenn ich nun mir dem Windows-Explorer nachsehe, ist die Datei im Unterorder, im Hauptordner nicht mehr.
Neustart der Box bringt da auch nichts.
Wenn ich einen komplett neuen Unterorder erstelle, geht es wieder.
 
Das NAS-GUI ist nicht wirklich dafür gemacht, damit große Mengen von Dateien durch die Gegend zu schieben. Jede Dateioperation löst eine Benachrichtigung bei einem bestimmten AVM-Daemon aus (oder auch nicht, weil die Anzahl der Dateien, die auf diesem Wege überwacht werden können, auf 30.000 limitiert ist) und der muß dann erst einmal diese Aktion in der Index-Datenbank "nachbiilden" (also die Datei am alten Ort entfernen und am neuen Ort eintragen, wenn der Daemon das überhaupt erfährt, wo die gelandet ist). Dann muß noch das GUI die Daten aus der Index-DB neu lesen, denn nach meinem Eindruck wird auch da ein zusätzlicher Cache verwendet - aber das kann sich inzwischen sogar geändert haben.

Jedenfalls zeigt das GUI die Ansicht anhand der Index-Datenbank und sowohl FTP als auch Samba zeigen den realen Datenträgerinhalt (weil sie das Dateisystem lesen und nicht die Index-Datenbank). Wenn man solche Verschiebungen also ausführen will, nimmt man dafür besser einen der beiden letzteren Services und stößt nach dem Abschluß der Arbeiten ein Neu-Indexieren des Volumes über das GUI an (unter "Heimnetz").
 
Die Indexierung kann auch bequem vom Sofa aus über FRITZ!Fon gestartet werden.
Menü > Heimnetz > OK > Mediaplayer > OK > AVM FRITZ!Mediaserver > OK > Datei-Index > OK > Indexierung starten > OK

Selbst bei einer 7580 dauert der Vorgang der Indexierung eine gefühlte Ewigkeit.
 
Mir kommt es ja gerade auf die sofortige Indexierung an. Ich höre mir einen Titel über eine WLAN-Lautsprecher an und entscheide dann, in welchen Unterordner er kommt.
Aber ich vermute ich bin auf einen Bug in der Software gestoßen.
Ich habe mehrere Order (01-09) in denen die Dateien liegen. Das habe ich nur gemacht, damit ich die Übersicht ein wenig behalte. Als ich dann den Ordner 01 bearbeitet habe, habe ich dort vier Unterverzeichnisse mit den Genres angelegt. Nachdem ich mit 01 fertig war, habe ich die Ordner einfach in 02 verschoben - und genau das war das Problem. Mit dem Verschieben kommt die Box irgendwie nicht klar. Wenn ich jedes Mal neue Order anlege, funktioniert es ohne Probleme.

Nen Fritz!FON habe ich nicht.
 
s'KATERchen hattest Du den Fehler damals an AVM gemeldet? Hast Du den Fehler heute noch?
Einer der Uebergebenen Parameter war falsch […] die Box einfach mal neu gestartet, jetzt geht es wieder.
Hatte eben genau die selbe Fehlermeldung mit dem aktuellen FRITZ!OS 7.25. AVM kennt die Fehlermeldung offensichtlich nur in Zusammhang mit dem Microsoft Internet Explorer: 1502. Den Web-Browser verwende ich gar nicht.

In meinem Fall hatte ich genau eine Datei hochgeladen – in den internen Ordner „Dokumente“. Bei mir war die Ursache, dass der Dateiname einen Umlaut enthielt – bei mir „ü“. Weder Umbenennen, Löschen noch Verschieben ging. Ich bin dann einen Ordner höher (ins Wurzelverzeichnis) gegangen und dann wieder in den Ordner zurück. Voilà, jetzt gehen alle Aktionen.
 
Zuletzt bearbeitet:
Kostenlos!

Statistik des Forums

Themen
248,916
Beiträge
2,304,992
Mitglieder
378,631
Neuestes Mitglied
realprogrammer