[Frage] FritzBox https Weiterleitung funktioniert nicht

groovesurfer1

Neuer User
Mitglied seit
1 Nov 2020
Beiträge
4
Punkte für Reaktionen
0
Punkte
1
Hallo,

ich möchte den Port 443 (https) an einen Rechner weiterleiten. Im Grunde eine ganz easy Sache.
Leider funktioniert es bei der FritzBox 7362 SL wohl nicht wie bei den anderen 1000 mal (andere Router) als ich das gemacht habe.
Zuerst habe ich folgendes versucht: unter Internet - Freigaben - Portfreigaben einen neuen Eintrag erstellt: mein Gerät wird dort aufgelistet. Neue Freigabe - Anwendung https Server, Port an Gerät 1234, Port extern: 443. Wenn ich dann versuche von außen darauf zuzugreifen https://meineip = funktioniert nicht. Es funktioniert nur http://meineip:443. Das ist doch dann kein https??? Wenn ich nicht https Server sondern andere Anwendung auswähle mit den selben Ports, das gleiche Ergebniss.
Wenn ich es über myFritz versuche, bekomme ich ja eine Adresse zugewiesen: https://meinGerät.1231321231.myfritz.net:1234. Wenn ich hiermit darauf zugreifen möchte, kommt die Meldung:
Beim Verbinden mit meinGerät.1231321231.myfritz.net:8123 trat ein Fehler auf. SSL hat einen Eintrag erhalten, der die maximal erlaubte Länge überschritten hat. Fehlercode: SSL_ERROR_RX_RECORD_TOO_LONG.
Das kann doch nicht so schwer sein...
 

KunterBunter

IPPF-Urgestein
Mitglied seit
12 Okt 2005
Beiträge
26,002
Punkte für Reaktionen
541
Punkte
113
Leider funktioniert es bei der FritzBox 7362 SL wohl nicht wie bei den anderen 1000 mal (andere Router) als ich das gemacht habe.
1000 mal ist ja wirklich ganz schön beachtlich. :) Da war wohl nie eine Fritzbox dabei. Leider funktioniert es bei der FritzBox nämlich nicht, wenn die Fritzbox den Port 443 selber benutzt, wie du schon festgestellt hast.
 

groovesurfer1

Neuer User
Mitglied seit
1 Nov 2020
Beiträge
4
Punkte für Reaktionen
0
Punkte
1
Wie meinst Du das? Bedeutet es dass man keine https Weiterleitung machen kann?
 

KunterBunter

IPPF-Urgestein
Mitglied seit
12 Okt 2005
Beiträge
26,002
Punkte für Reaktionen
541
Punkte
113
Ich habe es noch keine 1000 mal gemacht, aber bei meiner Fritzbox 7362 SL kann man eine https Weiterleitung machen, weil sie den Port 443 nicht selber benutzt.
 

Benares

Aktives Mitglied
Mitglied seit
15 Jan 2006
Beiträge
2,549
Punkte für Reaktionen
69
Punkte
48
@groovesurfer1, schau in den Bericht Diagnose, Sicherheit, ob da 443 dabei steht, wenn die Weiterleitung nicht aktiv ist.
Ich habe da auch eine Weiterleitung, die ich temporär einschalte, wenn ich sie brauche - das funktioniert.
Ist der Server, der unter 1234 auf dem "Gerät" läuft wirklich ein https-Server, sprich funktioniert https://LokaleIP (von der evtl. fehlenden Gültigkeit des Zertifikats mal abgesehen)?
 

groovesurfer1

Neuer User
Mitglied seit
1 Nov 2020
Beiträge
4
Punkte für Reaktionen
0
Punkte
1
OK, aber mit der myFritz Geschichte kann ich über https darauf zugreifen. Es gibt ja auch den Punkt " Internetzugriff auf die FRITZ!Box über HTTPS aktivieren". Dann erhalte ich eine Adresse: https://123123123213.myfritz.net:1234 (natürlich abgeändert). Mit dieser Adresse kann ich dann von außerhalb auf die FritzBox auf die FritzBox Oberfläche zugreifen. Bei weiteren Freigaben auf andere lokale Geräte erhält man dann wie oben beschrieben Adressen auf die Geräte zugreifen (z.B. https://gerät.123123123213.myfritz.net:5678). Das sollte ja eigentlich funktionieren. Warum sollte die FritzBox sondt die Adresse anlegen? Ed kommt halt nur die SSL Fehlermeldung. Irgendetwas ist doch da komisch...
 

Benares

Aktives Mitglied
Mitglied seit
15 Jan 2006
Beiträge
2,549
Punkte für Reaktionen
69
Punkte
48
"Internetzugriff auf die FRITZ!Box über HTTPS aktivieren" nutzt einen anderen Port. Dadurch wird 443 nicht belegt.
Was sagt denn nun Diagnose, Sicherheit im Bereich "Übersicht der geöffneten Ports für den Zugriff aus dem Internet" ohne aktivierte Portweiterleitungen?
 

groovesurfer1

Neuer User
Mitglied seit
1 Nov 2020
Beiträge
4
Punkte für Reaktionen
0
Punkte
1
Danke für eure Antworten. War leider ein Fehler bei der Software von dem Rechner. Jetzt geht es.
 

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
13,765
Punkte für Reaktionen
1,261
Punkte
113
War leider ein Fehler bei der Software von dem Rechner.
Wahnsinn, wie schnell der offenbar behoben werden konnte - da bringt "continuous delivery" oder auch "continuous integration" dann seine Vorteile so richtig zur Geltung. :cool:

Und wenn die Software dann so richtig "smart" ist und nicht nur die eigenen Fehler, sondern auch noch diejenigen, die vom Benutzer bei der Konfiguration/Anwendung begangen werden, von selbst behebt (das ist üblicherweise der weit überwiegende Teil), dann "drohen" uns goldene Zeiten.
 
  • Sad
Reaktionen: sonyKatze

HabNeFritzbox

IPPF-Urgestein
Mitglied seit
12 Dez 2017
Beiträge
17,839
Punkte für Reaktionen
592
Punkte
113
Zudem würde es keinen SSL Fehler geben wenn Freigabe nicht funktioniert, sondern eher nen Netzwerkfehler bzw. Timeout, je nach Browser.

Damit man intern und extern nicht andere Ports verwendet, würde ich den Dienst auf dem Server auch entsprechend anpassen.
 

Zurzeit aktive Besucher

Keine Mitglieder online.
3CX

Statistik des Forums

Themen
237,879
Beiträge
2,102,242
Mitglieder
360,374
Neuestes Mitglied
ffwit

Erhalten Sie 3CX für 1 Jahr kostenlos!

Gehostet, in Ihrer privaten Cloud oder on-Premise! Ganz ohne Haken. Geben Sie Ihren Namen und Ihre E-Mail an und los geht´s:

3CX
Für diese E-Mail-Adresse besteht bereits ein 3CX-Konto. Sie werden zum Kundenportal weitergeleitet, wo Sie sich anmelden oder Ihr Passwort zurücksetzen können, falls Sie dieses vergessen haben.
oder via

IPPF im Überblick

Neueste Beiträge

Website-Sponsoren


Kontaktieren Sie uns bei Interesse