[Problem] FTDI Module nicht ladbar ?

greg54321

Neuer User
Mitglied seit
5 Jun 2009
Beiträge
30
Punkte für Reaktionen
0
Punkte
0
Hallo zusammen!
Ich versuche einen USB-Seriell AdapterChip in Betrieb zu nehmen. Nach dem Anstecken an die Box wird immerhin schon folgendes angezeigt:
Code:
cat /proc/bus/usb/devices

T:  Bus=01 Lev=02 Prnt=02 Port=02 Cnt=02 Dev#=  4 Spd=12   MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0403 ProdID=6001 Rev= 6.00
S:  Manufacturer=FTDI
S: [B] Product=FT232R USB UART[/B]
S:  SerialNumber=A5002jlQ
C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr= 90mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E:  Ad=81(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
Allerdings gibt es unter /dev kein ttyUSB*
lediglich tty tty0 ttyS0..1 und ttyp0..1 ttypa..f


lsmod listet mir kein ftdi_sio oder usbserial auf.

Allerdings wird beim make ausgegeben:

Code:
installing modules
  ftdi_sio.ko ..................   16.90 Kb 
  usbserial.ko .................   15.44 Kb
und die module sind später auch vorhanden:

Code:
find / -iname '*ftdi*'
/lib/modules/2.6.32.41/kernel/drivers/usb/serial/ftdi_sio.ko
/usr/lib/freetz/libftdi.so
/usr/lib/freetz/libftdi.so.1
/usr/lib/freetz/libftdi.so.1.19.0

find / -iname '*usbserial*'
/lib/modules/2.6.32.41/kernel/drivers/usb/serial/usbserial.ko
Obwohl ich die Module über http://fritz.box:81/cgi-bin/file/mod/modules eingetragen hatte, wurde diese nicht geladen
Code:
 cat /var/tmp/flash/mod/modules
usbserial.ko
ftdi_sio.ko
usbserial
ftdi_sio
Nachträgliches laden funktioniert auch nicht:

Code:
modprobe  usbserial.ko
modprobe: can't load module usbserial.ko (kernel/drivers/usb/serial/usbserial.ko): invalid module format
modprobe ftdi_sio
modprobe: can't load module usbserial (kernel/drivers/usb/serial/usbserial.ko): invalid module format
Trunk 8737

Was mache ich falsch?

Vielen Dank für Eure Unterstützung!

Grüße, Gregor
 

markuschen

Mitglied
Mitglied seit
23 Okt 2005
Beiträge
370
Punkte für Reaktionen
0
Punkte
16
Wenn ich mir die Kernelversion anschaue, nutzt du die Labor-Preview für die 7270. Damit wirst du keine Kernel-Module einbinden können, da die Sourcen für diesen Kernel noch nicht veröffentlicht wurden. Mit "dmesg" müsstest du einen entsprechenden Fehler angezeigt bekommen.
Sollte ich falsch liegen, bitte deine .config posten.
 

greg54321

Neuer User
Mitglied seit
5 Jun 2009
Beiträge
30
Punkte für Reaktionen
0
Punkte
0
stimmt:
Code:
dmesg
usbserial: version magic '2.6.32.21 mod_unload MIPS32_R2 32BIT ' should be '2.6.32.41 mod_unload MIPS32_R2 32BIT '
Hab jetzt die Beta abgewählt und es läuft! ttyUSB0 vorhanden und Module geladen.
Vielen Dank für den Tipp!
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Und die Module im Webinterface bitte ohne .ko eintragen. Oder geht das auch mit?

Gruß
Oliver
 

markuschen

Mitglied
Mitglied seit
23 Okt 2005
Beiträge
370
Punkte für Reaktionen
0
Punkte
16
Geht wohl auch mit .ko