[geklärt] Probleme beim Sambastart

technorocka123

Neuer User
Mitglied seit
8 Feb 2007
Beiträge
102
Punkte für Reaktionen
0
Punkte
16
Hallo,

ich hab gestern abend die Version 2900 ausgecheckt und für meine 7170 kompiliert. Nach dem aufspielen lief samba nichtmehr.
Noch nen bisschen rumprobiert, wurde aber nix.
Recovery auf die 49er Firmware und dann weil ich die Version 2887 nichtmehr kompiliert bekam die stable 1.0.1 mit der 57er Firmware.

Nun läuft mein Samba aber immer noch nicht! Hat da irgendwer ne Vermutung, was das seien könnte?

Achso und Logfiles wusste ich nicht, wo die zu finden sind. Kann mir ja wer nen Tipp geben! :)

lg

Sebi
 
Zuletzt bearbeitet:

cuma

Aktives Mitglied
Mitglied seit
16 Dez 2006
Beiträge
2,756
Punkte für Reaktionen
7
Punkte
38
Logfiles sind leider von AVM rausgepatcht. Poste mal die Ausgabe von "sh -x /etc/init.d/rc.samba start"
 

technorocka123

Neuer User
Mitglied seit
8 Feb 2007
Beiträge
102
Punkte für Reaktionen
0
Punkte
16
Code:
/var/mod/root # sh -x /etc/init.d/rc.samba start
+ export PATH=/sbin:/bin:/usr/sbin:/usr/bin:/mod/sbin:/mod/bin:/mod/usr/sbin:/mo
d/usr/bin
+ export LD_LIBRARY_PATH=/mod/lib:/mod/usr/lib
+ BDIR=/sbin
+ DAEMON=samba
+ SMBD=smbd
+ NMBD=nmbd
+ MODPATH=/mod/etc
+ CONF=/mod/etc/smb.conf
+ . /etc/init.d/modlibrc
+ export PATH=/sbin:/bin:/usr/sbin:/usr/bin:/mod/sbin:/mod/bin:/mod/usr/sbin:/mo
d/usr/bin
+ export LD_LIBRARY_PATH=/mod/lib:/mod/usr/lib
+ [ -n samba ]
+ [ ! -r /mod/etc/conf/samba.cfg ]
+ . /mod/etc/conf/samba.cfg
+ export SAMBA_ENABLED=yes
+ export SAMBA_INTERFACES=192.168.178.1/255.255.255.0
+ export SAMBA_MASTER=no
+ export SAMBA_NETBIOS_NAME=FRITZ.BOX
+ export SAMBA_OS_LEVEL=20
+ export SAMBA_SERVER_STRING=%h (Samba %v)
+ export SAMBA_WORKGROUP=Arbeitsgruppe
+ start
+ echo -n Starting samba...
Starting samba...+ config
+ mkdir -p /var/locks
+ mkdir -p /var/samba/lib
+ mkdir -p /var/samba/private
+ modlib_adduser ftpuser -G users -D -S -h /var/media/ftp -g ftp user
+ local user=ftpuser
+ shift
+ echo -n Looking for user 'ftpuser' ...
Looking for user 'ftpuser' ... + grep -q ^ftpuser: /etc/passwd
+ echo found
found
+ return 0
+ /mod/etc/default.samba/samba_conf
+ [ -r /var/tmp/smbpasswd.cleartext ]
+ pidof smbd
+ smbd -D -s /mod/etc/smb.conf
+ exitvals=0
+ NST=1
+ [ 0 -ge 1 ]
+ exitvaln=0
+ [ -x /sbin/nmbd -a 1 -eq 1 ]
+ nmbd -D -s /mod/etc/smb.conf
+ exitvaln=0
+ [ 0 -eq 0 -a 0 -eq 0 ]
+ echo done.
done.
+ exit 0
 

cuma

Aktives Mitglied
Mitglied seit
16 Dez 2006
Beiträge
2,756
Punkte für Reaktionen
7
Punkte
38
Samba startet doch ^^
 

technorocka123

Neuer User
Mitglied seit
8 Feb 2007
Beiträge
102
Punkte für Reaktionen
0
Punkte
16
hmm seh ich jetzt auch..

aber im interface wird mir das nicht angezeigt [stopped] und Zugriff auf \\fritz.box bleibt aussenvor! Genausowenig mit der ip.. keine chance!

ich versteh das nicht

edit:ich doof.... hab die Standard IP geändert und vergessen, sie im samba umzuändern!.. Das passiert, wenn man nicht richtig in die Ausgabe schaut!
 

Zurzeit aktive Besucher

3CX

Statistik des Forums

Themen
235,914
Beiträge
2,067,826
Mitglieder
356,957
Neuestes Mitglied
IBimsShweit