.titleBar { margin-bottom: 5px!important; }

[GELÖST] Probleme mit https beim Snom320

Dieses Thema im Forum "snom" wurde erstellt von whiskey, 19 Jan. 2007.

  1. whiskey

    whiskey Neuer User

    Registriert seit:
    17 Jan. 2007
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo, nach meinem peinlichen Thread unter

    http://www.ip-phone-forum.de/showthread.php?t=126045 :-Ö

    habe ich nun allerdings ein neues Problem, welches ich nicht alleine lösen kann:

    Da die gesamte Kommunikation in unserem Netzwerk über das Protokoll HTTPS laufen soll, habe ich die Telefone (Snom320, 360) entsprechend konfiguriert. Nun versuche ich über die exec-Funktion über PHP einen wget-Aufruf (der mit dem HTTP-Protokoll prima läuft), welcher folgendermaßen aussieht:

    wget --delete-after https://IPADR/dummy.htm?settings=save&language=Deutsch

    Da das Protokoll aber nun HTTPS ist, habe ich noch folgenden Parameter für wget ergänzt:

    --no-check-certificate

    Lasse ich das --delete-after weg, wird die Datei auch gespeichert, aber die Telefoneinstellungen ändern sich nicht.
    Versuche ich das Ganze mit einem einfachen Parameter, also z.B.

    wget --no-check-certificate https://IPADR/command.htm?key=OFFHOOK

    reagiert das Telefon, es nimmt den Hörer ab...
    Es scheint also ein Problem mit der Anzahl der übergebenen Parameter zu geben, weiß jemand Rat? Habe keine Ideen mehr...

    Ach ja: Gebe ich das Ganze direkt im Browser ein, funktioniert es auch mit mehreren Parametern, also ein wget-Problem? :noidea:

    PS: Die Firmware ist bei den Telefonen auf dem aktuellsten Stand!
     
  2. cibi

    cibi Mitglied

    Registriert seit:
    6 Apr. 2005
    Beiträge:
    561
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Ba-Wü
    Schon mal probiert die URL in " " zu setzen? Damit sollte es gehen
     
  3. whiskey

    whiskey Neuer User

    Registriert seit:
    17 Jan. 2007
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    wget

    Hat geklappt, vielen Dank... Hätte ich auch drauf kommen müssen...