.titleBar { margin-bottom: 5px!important; }

[gelöst] 79x1 am Asterisk, kein "remote ringback" ( SIP 8.4.3 )

Dieses Thema im Forum "Cisco" wurde erstellt von dynamic, 28 Jan. 2009.

  1. dynamic

    dynamic Aktives Mitglied

    Registriert seit:
    1 Apr. 2006
    Beiträge:
    1,154
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    #1 dynamic, 28 Jan. 2009
    Zuletzt bearbeitet: 10 Apr. 2009
    Hi,
    habe auf meiner 7961 sowohl die 8.4.2'er als auch die 8.4.3'er SIP FW getestet und bekomme beim Anruf kein "ringback" Signal ( d.h. bis zur Annahme des Gespräch höre ich statt des Klingelzeichens einfach nur Stille ).
    Das Gespräch kann ohne Probleme angenommen und geführt werden, d.h. two-way Audio funktioniert.

    Ein paar Infos zur Konstellation:
    • kein NAT, d.h. 7961 als auch Asterisk-Server befinden sich im gleichen LAN
    • 7961 ist via SIP am * v1.6.0.1 angemeldet.
    • Im SIP-Debug sehe ich folgende SIP-Status Meldungen:
      - Invite
      - 100 Trying
      - 183 Session Progress
      - 180 Ringing
      - 200 OK
    • Obwohl der Ringing Status gemeldet wird, höre ich kein ringback Signal
    Mit der "alten" 8.0.2SR1 funktioniert das "ringback" jedoch trotz unveränderter Config ohne Probleme?!

    Gibt es in den aktuelleren Firmwares evtl. ein gesondertes Setting, über den man das ringback Verhalten beeinflussen kann / soll ?

    Hat evtl. jemand ein 79x1 mit 8.4.x SIP FW im Einsatz, bei dem auch das ringback funktioniert ?

    Gruß
    dynamic
     
  2. dynamic

    dynamic Aktives Mitglied

    Registriert seit:
    1 Apr. 2006
    Beiträge:
    1,154
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Für Interessierte hier die Lösung des "no remote ringback" Problems bei neueren SIP Firmwares.

    Das Durchreichen des Remote Ringback Signals bei Status "180 Ringing" kann mit folgender Änderung in der sip.conf erreicht werden ( entweder unter [general] oder bei dem jeweiligen [sip-client] ):


    Code:
    progressinband = yes ;  ensures passing of remote ringback singal with "180 Ringing" status
    progressinband = no ;  used ringtone signal generated by asterisk instead with "100 Ringing" status
    ;
    
    Gruß
    dynamic