.titleBar { margin-bottom: 5px!important; }

[gelöst] Asterisk & Mitacs

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von Markus_, 4 Feb. 2009.

  1. Markus_

    Markus_ Neuer User

    Registriert seit:
    23 Juni 2008
    Beiträge:
    54
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    System Administrator
    Ort:
    nahe Wien
    #1 Markus_, 4 Feb. 2009
    Zuletzt bearbeitet: 12 Feb. 2009
    Ich hab leider ein Problem mit meinem Sipprovider (Mitacs) und Asterisk (1.4.23.1). Eingestellt habe ich alles wie früher bei meinem alten Sip Provider Sipgate, nur klappt bei Mitacs die Registrierung nicht.

    ein Ausschnitt aus der sip.conf:

    Code:
    [general]
    register => 43720XXXXXX:MITACS-PW@sip001.mitacs.com/43720XXXXXX
    
    [43720XXXXXX]
    type=friend
    context=from-mitacs
    username=43720XXXXXX
    fromuser=43720XXXXXX
    secret=MITACS-PW
    host=sip001.mitacs.com
    fromdomain=sip001.mitacs.com
    qualify=yes
    insecure=very
    nat=yes
    
    [mitacs-in]
    type=friend
    fromdomain=sip001.mitacs.com
    host=sip001.mitacs.com
    context=ankommend
    
    und die extensions.conf dazu:

    Code:
    [from-mitacs]
    exten => 43720XXXXXX,1,Dial(SIP/${EXTEN},20)
    exten => 43720XXXXXX,2,VoiceMail(u${EXTEN})
    exten => 43720XXXXXX,102,VoiceMail(b${EXTEN})
    
    [ankommend]
    exten => 43720XXXXXX,1,Dial(SIP/85,30)
    
    sip show peers zeigt:

    Code:
    asterisk*CLI> sip show peers
    Name/username              Host            Dyn Nat ACL Port     Status               
    mitacs-in                  213.185.164.123             5060     Unmonitored           
    43720XXXXXX/43720XXXXXX    213.185.164.123      N      5060     UNREACHABLE    
    
    sip show registry:
    Code:
    asterisk*CLI> sip show registry 
    Host                            Username       Refresh State                Reg.Time                 
    sip001.mitacs.com:5060          43720721954        120 Request Sent 
    
    hier die Ausgabe der Registrierung am Asterisk:

    Code:
    REGISTER attempt 3470 to 43720XXXXXX@sip001.mitacs.com
    Really destroying SIP dialog '491a198d4141747d7c4fd52f4e50196b@10.10.10.116' Method: REGISTER
    Really destroying SIP dialog '29af78f112797aa756611c85681b527f@10.10.10.116' Method: OPTIONS
    [Feb  4 09:31:06] NOTICE[28656]: chan_sip.c:7618 sip_reg_timeout:    -- Registration for '43720XXXXXX@sip001.mitacs.com' timed out, trying again (Attempt #3470)
    Meiner Meinung nach sollte alles soweit richtig eingestellt sein, nur leider klappt die Registrierung nicht. Hat jemand eine Idee was ich probieren könnte?
     
  2. beowulf

    beowulf Neuer User

    Registriert seit:
    28 Mai 2004
    Beiträge:
    161
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Singapore & Vienna
    Hallo!

    Ich hatte auch Mitacs und weiß, daß deren Setup total mühsam ist. Es gelang mir aber mich zu registern und Mitacs dann zu verwenden. Werde zu Hause nach den Einträgen suchen und sie Dir dann schicken.

    Nikolaus
     
  3. beowulf

    beowulf Neuer User

    Registriert seit:
    28 Mai 2004
    Beiträge:
    161
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Singapore & Vienna
    Ich hatte das hier stehen

    Code:
    [43720xxxxxx]
    type=peer
    username=xxxxxx
    fromuser=xxxxxx
    secret=MITACS-passwd
    host=sip001.mitacs.com
    fromdomain=sip001.mitacs.com
    insecure=very
    nat=yes
    qualify=yes
    canreinvite=no
    context=blabla
    
    Nikolaus
     
  4. Markus_

    Markus_ Neuer User

    Registriert seit:
    23 Juni 2008
    Beiträge:
    54
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    System Administrator
    Ort:
    nahe Wien
    danke auf jeden Fall. Problem hat sich inzwischen gelöst seit Asterisk eine externe IP bekommen hat.

    Davor hatte ich error 408 - Request Timeout

    Hat mich nur gewundert, da ich (glaube ich) damals bei Sipgate keine externe IP für den Asterisk hatte - kann mich aber auch täuschen