[gelöst]Benötige Hilfe nach Umfritzversuch eines W900V

sevenfifty

Neuer User
Mitglied seit
4 Mrz 2012
Beiträge
13
Punkte für Reaktionen
0
Punkte
0
Ich habe versucht anhand der Anleitung meinen Speedport W900V umzufritzen.
Leider ist irgendwas in die Hose gegangen und aktuell habe ich eine nicht funktionierenden Speedport W900V mit blinkender WLan-LED. Desweiteren leuchtet die LAN1 Led an dem der W7/32b-Rechner hängt.

Was habe ich gemacht?
1. Alles bis auf LAN1 abgesteckt und alle anderen Netzwerkkarten im Rechner deaktiviert.
2. VMWare Player 4.0.2 aufgespielt und als Administrator geöffnet.
3. Aktuelle Ubuntu_10.04_32-Bit Image downgeloaded, entpackt und mit VMW Player gestartet.
4. Auf download_speed-to-fritz.sh geklickt, Passwort "Box" eingegeben und updates durchlaufen lassen.
5. Bei Speed-to-fritz-Configuration meinen Speedport W900V ausgewählt und weiter nichts geändert.
6. Auf EXIT und bestätigt.
7. Wenn ich mich richtig erinnere, zweimal Enter, dann kamen die Punkte mit Rebootaufforderung
8. Speedport rebootet.
9. Dann kam für eine Zeit"---> STOR mtd1...."
Danach hat er abgebrochen, weil er "irgendwas nicht gefunden" und mir noch viel SPass gewünscht.

Anlage ist natürlich aktuell völlig ohne Funktion! Nur oben genannten LEDs blinken/sind an.
Leider kann ich jetzt nur via EDGE aufs Forum zugreifen, was die Suche im Forum nach einer Lösung extrem zieht! Sorry!
Bin ich etwas ratlos und würde mich sehr über etwas Hilfe freuen!

Danke und ganz lieben Gruß
Didi
 
Zuletzt bearbeitet:

KunterBunter

IPPF-Urgestein
Mitglied seit
12 Okt 2005
Beiträge
24,634
Punkte für Reaktionen
330
Punkte
83
Man sollte sich immer vorher schon Gedanken über den Weg zurück machen, falls es nicht so klappt wie gewünscht. :)
In deinem Fall kannst du natürlich mit dem ruKernelTool jederzeit wieder die Original Telekom Firmware-Version 34.04.57 zurückflashen.
 

Marsupilami

IPPF-Promi
Mitglied seit
31 Jan 2006
Beiträge
4,999
Punkte für Reaktionen
0
Punkte
36
Es empfiehlt sich, bei einem Speedport2Fritz-Durchlauf immer die Recover mit erstellen zu lassen. Außerdem macht es durchaus Sinn, einmal eine Recover für die Original-Firmware zu erstellen.
Wenn du die beide hast, kannst du auch per Recover zwischen gefritzt und Original-Telekom-Firmware hin und zurück wechseln.
Ansonsten kann auch das Speedport2Fritz-Skript die Original-Firmware per Skript auf die Box schieben.
 

sevenfifty

Neuer User
Mitglied seit
4 Mrz 2012
Beiträge
13
Punkte für Reaktionen
0
Punkte
0
Nach dem ich mich jetzt ein paar Stunden mit der Materie beschäftigt habe/musste, läuft der Kasten!
Ich habe aus lauter Verzweiflung jetzt mit dem ruKernelTool den in der VMW erstellten Kernel geflasht!

Vermutlich nicht der richtige Weg, aber meine Frau kann erst mal wieder telefonieren, was GAAAANZ wichtig war!! ;-)

Unter Modinfo finde ich einen Hinweis auf das Imagefile "FRITZ.Box_Fon_WLan_7170.29.04.87.image" und dem Hinweis, dass der AVM Kernel beibehalten wurde.
Als Script "speed2fritz" Revision 1473!

Grundsätzlich bin ich jetzt erstmal erleichtert, dass Telefon und Internet wieder laufen!
Aber mich würde trotzdem interessieren, ob ich mir da jetzt eine alte Version geflasht habe?!
Gibt es da schon was Neueres?

Ich Danke Euch soweit für Eure Hilfe!!!!
 

Marsupilami

IPPF-Promi
Mitglied seit
31 Jan 2006
Beiträge
4,999
Punkte für Reaktionen
0
Punkte
36
Was soll daran alt sein? Eine neuere Firmware für die 7170 gibt es nicht.
 

sevenfifty

Neuer User
Mitglied seit
4 Mrz 2012
Beiträge
13
Punkte für Reaktionen
0
Punkte
0
Nach dem Ernest mir die Versionierung ausführlich erklärt hat, ist jetzt alles klar!
Box läuft soweit einwandfrei!
Somit kann ich mich nachher in Ruhe mal mit den neuen Funktionen beschäftigen.

Danke an dieser Stelle an alle, die geholfen haben, Licht ins Dunkel zu kriegen!!!!

*case closed* :)
 

Alkibiades

Neuer User
Mitglied seit
4 Mrz 2012
Beiträge
1
Punkte für Reaktionen
0
Punkte
0
Ein einfacher Weg um sicher ans Ziel zu kommen:Speed2fritz für w900v zu 7170

Vorbereitung: Sicherung Image-Datei der Speedport aus entpackter !! Firmware
Programm dazu ist 7o zip
Dann folgende Programme: recovery image von avm zum offen halten des ftp-ports!!
Und Total comander für ftp-file transfer
Im ersten Schritt nach der bekannten Anleitung über Virtual Monitor das gefritzte Image erzeugen, egal ob es erfolgreich mit dem Script übertragen wird – wenn ja dann o.k. – bei mir leider nicht! – rebootschleife oder ähnliches
Nun zum Verfahren: 1. Die gefritzte Image-Datei aus dem Ordner FirmwareNew (KERNAL.IMA) sichern (nicht unter windows kompatibel!) , z.Bsp. auf CD und dann unter Windows in kernel.image umbenennen.
2. Mit recovery image von avm den ftp port öffnen, das Programm erkennt die IP, der Trick ist dann das Programm einfach beenden !! nicht auf weiter im Programm zu gehen
3. Die speedport ist jetzt ftp-bereit und es kann mittels Total comander die im ersten Schritt gesicherte und umbenannte Datei kernel.image eingespielt werden – das Verfahren ist hier im Thread auch beschrieben. REBOOT scheint allerdings nicht zu funktionieren- also im Anschluß einfach hardreset an der speedport durch Stecker ziehen !
Mit der gesicherten Image-Datei (siehe Vorbereitung) kann man einfach nach den Schritten 2 und 3 zurück zur Speedport kommen – funktioniert problemlos
 

KunterBunter

IPPF-Urgestein
Mitglied seit
12 Okt 2005
Beiträge
24,634
Punkte für Reaktionen
330
Punkte
83
Genau, warum einfach per ruKernelTool, wenn es umständlich auch geht! ;)
 

Jpascher

IPPF-Promi
Mitglied seit
31 Mrz 2007
Beiträge
6,120
Punkte für Reaktionen
0
Punkte
36
@ Alkibiades
Zumindest hat es geklappt, auch wenn der einfachste und sicherste Weg natürlich ein anderer ist.

Man erstellt sich gleich mit dem Skript ein recover.exe, in dem die neu Firmware einbaut ist.

Alternative Methoden wir den FTP_uploader gibt es natürlich auch.
 
3CX

Statistik des Forums

Themen
235,885
Beiträge
2,067,232
Mitglieder
356,872
Neuestes Mitglied
Machsgut