[gelöst] Clutch (transmission webiface + transmission-daemon) auf fbox - läuft

coolphoenix

Mitglied
Mitglied seit
21 Jul 2005
Beiträge
234
Punkte für Reaktionen
0
Punkte
0
hallo leute,

ich habe die letzten paar stunden versucht, das "offizielle" webinterface clutch für transmission (http://clutchbt.com/) zum laufen zu bringen.

dazu habe ich apache und php aus freetz statisch kompiliert. eine modifizierung in der php.mk für clutch war nötig, um sockets zu ermöglichen:

Code:
$(PKG)_CONFIGURE_OPTIONS += --enable-sockets

so habe ich php und apache compiliert und es läuft (mit ein paar modifizierungen der apache.conf).

danach habe ich transmission kompiliert mit folgender änderung in der transmission.mk:
folgender eintrag wurde auskommentiert, sodass der daemon gebaut wird

Code:
$(PKG)_CONFIGURE_OPTIONS += --disable-daemon

dann aus transmission-1.11/daemon/ die files transmission-daemon, -remote und -proxy auf die box kopiert und auch transmission-daemon gestartet: läuft.

nur scheitert das webiface clutch daran, dass keine connects zu dem socket-file möglich sind das von transmission-daemon erstellt wird ("permission denied" sagt mir das apache error.log).

auch "transmission-remote" beschwert sich (liegt also nicht an dem webiface):

Code:
transmission-remote -f /var/media/ftp/uStor01/
transmission-remote: failed to connect to socket file: /mod/root/.transmission/daemon/socket: Connection refused

ein
Code:
chmod 777 -R /mod/root/.transmission/* 
ls -lh /var/mod/root/.transmission/daemon/ 
-rwxrwxrwx    1 root     root            0 May  5 22:50 lock
srwxrwxrwx    1 root     root            0 May  5 23:10 socket
bringt leider nix. ebenso ein starten des apache mit rootrechten bzw. als root ändert daran nichts.


dass "connection refused" von transmission-remote und "permission denied" aus dem error.log von apache wohl das gleiche sind, ahbe ich mit einem chmod 000 auf den socket verifiziert: keine der fehlermeldungen ändert sich.

es scheint also irgendwie an den sockets zu liegen (von denen ich ehrlich gesagt keine ahnung habe) - sind sockets dieser art einfach nicht möglich auf der fritzbox?

hat jemand vielleicht eine idee?

mfg


EDIT:

hab es geschaft, nun läufts! man muss den socket unter /var/tmp/ erstellen, z.B.:
Code:
transmission-daemon -s /var/tmp/transmissionsocket
und alles läuft wunderbar.

ich kann mich ja mal daran setzen, ein packet für freetz zu bauen, sodass es evtl in der nächsten version integriert werden kann, sofern das jemand will.


EDIT:

doch nicht! es liegt daran, dass transmission-daemon in den hintergrund wechselt. sofern man ihn mit dem parameter -f startet, klappt es.
 
Zuletzt bearbeitet:
Interessant, ich habe mich unabhängig von dir auch vor ein paar Tagen an Clutch gemacht.
--enable-sockets könnte IMHO standardmässig gesetzt werden. Kostet ca. 30KB, was bei PHP ja kaum mehr ins Gewicht fällt.

Folgendes habe ich zusätzlich zu dir gemacht:
1. In der php.ini wird
Code:
upload_tmp_dir = /var/tmp/php
gesetzt. Ich habe das Verzeichnis angelegt und ein
Code:
chown ftpuser /var/tmp/php
gemacht, weil ich Probleme beim Upload eines Torrents über das Frontend bekommen habe.
2. Wo der Socket für transmission-daemon liegt ist bei mir egal. Allerdings erwartet transmission-remote einen Socket unter $HOME/.transmission/remote/socket. Ein einfacher Symlink tuts aber.

Das Problem, dass der Zugriff nicht funzt, wenn der daemon im Hintergrund läuft habe ich leider auch, und habe bisher noch keine Lösung :-( Mit -f läufts aber wunderbar.

Resümee:
Clutch sieht chic aus, die etwas üppigen Anforderungen (Apache mit PHP) stören mich nicht, weil ich für die Torrents eh externen Speicher brauche und meine Box genügend RAM hat. Auch die Geschwindigkeit finde ich überraschend gut.
Allerdings habe ich bisher noch nicht gefunden, wie per Clutch ich innerhalb eines Torrents einzelne Dateien priorisiere oder skippe - damit ist das Frontend für mich bisher unbrauchbar.
 
Resümee:
Clutch sieht chic aus, die etwas üppigen Anforderungen (Apache mit PHP) stören mich nicht, weil ich für die Torrents eh externen Speicher brauche und meine Box genügend RAM hat. Auch die Geschwindigkeit finde ich überraschend gut.
Allerdings habe ich bisher noch nicht gefunden, wie per Clutch ich innerhalb eines Torrents einzelne Dateien priorisiere oder skippe - damit ist das Frontend für mich bisher unbrauchbar.

hast recht, das feature gibt es nicht, ist in planung (laut clutchs forum).

ansonsten gibt es ja noch das (etwas verbuggte) webtransmission aus dem modifikations-forum, das läuft mit dateiauswahl und ohne "üppige" anforderungen - wenn das noch bisschen perfektioniert wird, passt das wohl eher auf so ein system wie die fbox (keine weiteren anforderungen).
 
Kostenlos!

Statistik des Forums

Themen
248,906
Beiträge
2,304,654
Mitglieder
378,611
Neuestes Mitglied
AlexSuess