.titleBar { margin-bottom: 5px!important; }

[Gelöst] Interne ISDN-Nummer auf SIP umleiten

Dieses Thema im Forum "Asterisk auf FBF" wurde erstellt von Silvio2508, 29 Jan. 2009.

  1. Silvio2508

    Silvio2508 Neuer User

    Registriert seit:
    27 Jan. 2009
    Beiträge:
    29
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #1 Silvio2508, 29 Jan. 2009
    Zuletzt bearbeitet: 30 Jan. 2009
    Hallo liebes Forum,
    wie man sieht bin ich Neuling und benötige etwas Unterstützung.

    Installation von Asterisk16 auf FritzBox 7170 hat soweit funktioniert.
    Jetzt gehts an die Konfiguration.

    Ich möchte:
    * Anrufe von extern ISDN and SIP-Phones bzw. interne ISDN-Telefone umleiten
    -> geht prima

    * Intern zwischen ISDN telefonieren geht mit ** vor interner Nummer
    -> ist doof, weil das die Fritzbox macht, gibt es eine bessere Lösung?

    * Anrufe mit einem internen ISDN-Telefon über meinen SIP-Provider führen
    -> geht nicht (Provider melded busy zurück und Anruf rutscht durch zur Fritzbox, welche dann über ISDN wählt)
    Der Provider ist aber nicht busy (es ist die Telefonanlage in unserer Firmenzentrale, mit der ich via VPN verbunden bin und die ich überwache).
    Telefonieren mit Softphone über diese Telefonanlage geht, hier sollte der Fehler nicht liegen.
    Hier mal das genaue Log:
    Code:
     == ISDN3#02: Incoming call '55' -> '0162xxxxxxx'
        -- ISDN3#02: Updated channel name: CAPI/ISDN3#02/0162xxxxxxx-4
        -- Executing [0162xxxxxxx@capi_intern:1] Dial("CAPI/ISDN3#02/0162xxxxxxx-4", "SIP/0162xxxxxxx@User") in new stack
    
      == Using SIP RTP CoS mark 5
    
        -- Called 0162xxxxxxx@User
    
        -- Got SIP response 486 "Busy Here" back from 192.168.8.8
    
        -- SIP/User-0060d320 is busy
      == Everyone is busy/congested at this time (1:1/0/0)
        -- Auto fallthrough, channel 'CAPI/ISDN3#02/0162xxxxxxx-4' status is 'BUSY'
      == ISDN3#02: CAPI Hangingup for PLCI=0xdead0000 in state 4
    
    Was habe ich gemacht (Nummern habe ich ausge-x-t):
    * Standardinstallation
    * In Fritzbox keine Telefone und keine Internettelefone eingetragen
    * voip.cfg Port auf 5061 gelegt
    * sip.conf:
    Code:
    [general]
    context=default			; Default context for incoming calls
    bindport=5060			; UDP Port to bind to (SIP standard port is 5060)
    bindaddr=0.0.0.0		; IP address to bind to (0.0.0.0 binds to all)
    tcpenable=yes
    tcpbindaddr=0.0.0.0:5060
    ;tlsenable=yes                 	; tls is not enabled by default
    ;tlsbindaddr=0.0.0.0:5062      	; default tls port is 5061 which conflicts with
    				; default fritzbox asterisk sip port 5061
    srvlookup=yes			; Enable DNS SRV lookups on outbound calls
    language=de
    
    register => User:Passwort@192.168.8.8/User
    
    [User]
    type=peer
    username=User
    FromUser=User
    secret=Passwort
    host=192.168.8.8
    fromdomain=192.168.8.8
    insecure=very
    caninvite=no
    canreinvite=no
    nat=no
    disallow=all
    allow=ulaw
    
    [sip_in]
    type=peer
    fromdomain=192.168.8.8
    host=192.168.8.8
    context=sip_in
     
    * extensions.conf:
    Code:
    [globals]
    CAPI_CALLERID=xxxxx
    
    [general]
    static=yes
    writeprotect=no
    
    [default]
    
    [capi_extern]
    exten => xxxx1,1,Dial(CAPI/ISDN3/54)
    
    exten => xxxx2,1,Dial(CAPI/ISDN3/55)
    
    [capi_intern]
    exten => _0.,1,Dial(SIP/${EXTEN}@User)
    
    [sip_in]
    exten => User,1,Dial(CAPI/ISDN3/55)
    
    Nummer xxxx1, klingelt also bei intern 54, Nummer xxxx2 klingelt bei intern 55.
    Wenn man SIP anruft, klingelt auch intern 55.

    Wenn intern 55 ein externes Gespräch führen möchte soll das über SIP geführt werden. Fehler siehe oben.


    Ich mache sicher was ganz einfaches falsch, aber was?
     
  2. Silvio2508

    Silvio2508 Neuer User

    Registriert seit:
    27 Jan. 2009
    Beiträge:
    29
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Fehler selbst gefunden

    1. benötigt die SIP-Telefonanlage zu weiter rauswählen eine führende 0
    -> dann wählte aber SIP und gleichzeitig die Fritzbox (und brachte die "Nummer nicht vergeben-Ansage"
    2. in extensions.conf habe ich beim ausgehenden Anruf über capi-intern als erste Aktion Answer() davorgeschrieben. Nun geht alles prima.