.titleBar { margin-bottom: 5px!important; }

[gelöst] Kernel image too big - alle Module viel zu groß

Dieses Thema im Forum "Freetz" wurde erstellt von elmicha, 21 Sep. 2008.

  1. elmicha

    elmicha Neuer User

    Registriert seit:
    24 Aug. 2008
    Beiträge:
    90
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Ort:
    Bonn
    #1 elmicha, 21 Sep. 2008
    Zuletzt bearbeitet: 21 Sep. 2008
    Hi,

    ich bekomme neuerdings bei make fast immer "kernel image too big":

    Code:
    ERROR: kernel image is 125440 bytes too big
    make: *** [firmware-nocompile] Fehler 1
    
    Nur wenn ich recht viele Sachen abwähle, wird überhaupt noch ein Image erzeugt.

    Das kernel.image, das ich vor ein paar Wochen erstellt hatte, ist gerade mal 12 MB gross, hat also noch 4 MB Platz (16 MB 7270).

    Nachdem ich mir das nicht erklären konnte, hab' ich mal in die kernel.image reingeschaut und festgestellt, dass viele der Kernel-Module viel größer geworden sind, z.B. ist usbcore.ko von 178348 auf 1496598 Bytes angeschwollen.

    Ich hab's auch schon mit "make distclean" und mit der alten .config probiert, aber das Problem bleibt bestehen. Nach "make" sehe ich in der .config diese Unterschiede:

    -FREETZ_AVM_VERSION_7270=y
    +FREETZ_AVM_VERSION_12043=y
    -FREETZ_AVM_VERSION_STRING="7270"
    +FREETZ_AVM_VERSION_STRING="12043"

    Ist das ok so?

    Und wie krieg' ich die Module wieder klein?
     
  2. McNetic

    McNetic Mitglied

    Registriert seit:
    7 Feb. 2007
    Beiträge:
    672
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Aachen
    Die Änderung an der Config sollte so weit in Ordnung sein. Dass die Module so groß sind, deutet darauf hin, dass die nicht mehr 'gestrippt' werden. Das sollte eigentlich nicht sein. Hast Du es mal mit einem komplett neu ausgecheckten Trunk probiert?
     
  3. sf3978

    sf3978 IPPF-Promi

    Registriert seit:
    2 Dez. 2007
    Beiträge:
    7,613
    Zustimmungen:
    3
    Punkte für Erfolge:
    38
    @elmicha:

    Welche Build-Umgebung verwendest Du? Ich habe auch das Problem, aber nur wenn ich Knoppix verwende. Verwende ich OpenSUSE, dann haben die Images die "normale" Größe. Den Vergleich habe ich mit einem neu ausgecheckten Trunk gemacht.
     
  4. elmicha

    elmicha Neuer User

    Registriert seit:
    24 Aug. 2008
    Beiträge:
    90
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Ort:
    Bonn
    Ergänzung:

    Nach "svn up -r 2472" sind die Module wieder brav klein, bei r2481 sind sie wieder zu gross.
     
  5. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Ich hatte das irgendwann in der Kernel config geändert. Nutzt du den stable branch? Eventuell ist diese Änderung noch nicht gemergt.

    MfG Oliver
     
  6. elmicha

    elmicha Neuer User

    Registriert seit:
    24 Aug. 2008
    Beiträge:
    90
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Ort:
    Bonn
    Ich habe bisher den freetz-1.0 benutzt (gerade hab' ich den stable branch neu ausgecheckt; compiliert aber noch). Build-Umgebung ist Gentoo.

    Im "svn log" sehe ich bei r2479 u.a.:

    * kernel:
    * add squashfs-3.3 patch to 7270 kernel patches
    * update 120-missing_pcmlink_header.patch
    * activate "replace kernel" option in menuconfig
    * add new open source package (12043)
    * make it default for 7270 54.04.58 and allow Labor All In One "replace kernel"

    Hängt's damit zusammen, gibt's einen neuen Schalter "strip modules" o.ä., den ich übersehen habe? Sollte ich FREETZ_STRIP_LIBRARIES einschalten?

    Viele Grüsse...
    Michael
     
  7. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Der Fix ist in r2485. Das müsstest du per "make kernel-menuconfig" machen.

    MfG Oliver
     
  8. elmicha

    elmicha Neuer User

    Registriert seit:
    24 Aug. 2008
    Beiträge:
    90
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Ort:
    Bonn
    Ja, danke!

    Nach "make kernel-menuconfig" (ohne Änderung darin) sind die Module wieder klein.

    Viele Grüsse...
    Michael