.titleBar { margin-bottom: 5px!important; }

[gelöst] Sipgate - * meldet keine gültige Rufnummer

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von beckmann, 8 Jan. 2005.

  1. beckmann

    beckmann Guest

    #1 beckmann, 8 Jan. 2005
    Zuletzt von einem Moderator bearbeitet: 18 Aug. 2008
    Hallo,
    ich habe meinen Asterisk so eingerichtet, dass er mehere VOIP Anschlüße auf einem VOIP Telefon ausgibt. Wenn man die 9 wählt kommt man in das Sipgate Netz und kann in das Festnetz telefonieren. Leider bekomme ich nachdm das erste Freiziechen zu hören ist von Asterisk die Ansage: Dies ist keine gültige Rufnummer. Nummer wie 50000 und 10000 kann ich aber erriehcne. Ab und zu komme ich auch mal ins Festnetz.
    Hier die Einstellungen:
    sip.conf
    Code:
     [general]
     localnet=192.168.123.0/255.255.255.0
     port = 5060
     bindaddr = 0.0.0.0
     context = default
     disallow=all
     allow=gsm
     allow=ulaw
     allow=alaw
     nat=yes
     externip=www.******.ipme.de
     srvlookup=yes
     canreinvite=no
     tos=0x18
     insecure=very
     dtmfmode=info
     maxexpirey=3600
     defaultexpirey=120
     register => UUUUUU:********@sipgate.de/UUUUUU
     ;register => UUUUU:*********@sipgate.de/UUUUU
     register => UUUUU:********@sip.purtel.de/55555
     register => UUUUU:*******@deu1.purtel.com/55555
     register => UUUUU:********@calamar0.nikotel.com/55555
     register => UUUUU:*******@sipsnip.com/55555
    
    [55555]
     type=friend
     username=55555
     secret=******
     host=dynamic
     disallow=all
     allow=ulaw
     allow=alaw
     dtmfmode=rfc2833
     context=sipgate
     mailbox=55555
     nat=no
    
    [55556]
     type=friend
     username=55556
     secret=********
     host=dynamic
     disallow=all
     allow=ulaw
     allow=alaw
     dtmfmode=rfc2833
     context=sipgate
     mailbox=55556
     nat=no
    
     [sipgate]
     type=friend
     username=UUUUUUUU
     secret=*******
     host=sipgate.de
     fromuser=UUUUUUU
     nat=yes
     context=sipgate
     canreinvite=no
     qualify=yes
     insecure=very
     fromdomain=sipgate.de 
     disallow=all 
     allow=g726 
     allow=alaw 
     allow=ulaw 
     
     [purtel_de]
     type=friend
     username=UUUUUUU
     host=sip.purtel.de
     secret=*******
     qualify=yes
     trunk=no ; If the ztdummy-Kernel Module is enabled
     context=fromPurtel
     nat=yes
    
     [purtel_com]
     type=friend
     username=UUUUUUUU
     host=deu1.purtel.com
     secret=*******
     qualify=yes
     trunk=no ; If the ztdummy-Kernel Module is enabled
     context=fromPurtel
     nat=yes
    
    extensions.conf
    Code:
    [default]
    ;user 55555
    exten => 55555,1,Dial(SIP/${EXTEN},60)
    exten => 55555,2,Voicemail2(u55555)
    exten => 55555,102,Voicemail2(b55555)
    
    ;user 55556
    exten => 55556,1,Dial(SIP/${EXTEN},60)
    exten => 55556,2,Voicemail2(u55556)
    exten => 55556,102,Voicemail2(b55556)
    
    [sipgate]
    include => default
    ;Mailbox
    exten => 333/_[1-9].,1,Answer
    exten => 333/_[1-9].,2,Wait(1)
    exten => 333/_[1-9].,3,VoicemailMain2(s${CALLERIDNUM})
    exten => 333/_[1-9].,4,Hangup
    
    ;für Sipgate
     exten=> _9.,1,Dial(SIP/${EXTEN:1}@sipgate,60,tr)
     exten=> _9.,2,Playback(invalid)
     exten=> _9.,3,Hangup
    
    ;Anrufe für sipgate-Account  an 55555 leiten
     exten =>UUUUUU,1,Dial(sip/55555,30,tr) ;UUUUU ist das gleiche wie in der Sip.conf bei Sipgate
    
    ;für Purtel.de
    exten => _8.,1,Dial(SIP/${EXTEN:1}@purtel_de,60)
    exten => _8.,2,Congestion
    exten => _8.,102,Busy
    
    ;für Purtel.com
    exten => _7.,1,Dial(SIP/${EXTEN:1}@purtel_com,60)
    exten => _7.,2,Congestion
    exten => _7.,102,Busy
    
    
    Ein weiters Problem ist, dass die eingehen Anrufe von Sipgate bei besetzt und nicht erreichbar nicht an die Mailbox weiter geleitet werden.

    Edit: Wie ich gerade feststellen mußte lag das nicht an meinen Einstellungen sondern an den Fehlern die Sipgate seit Samstag hat, die heute behoben wurden.