.titleBar { margin-bottom: 5px!important; }

[Gelöst]Verbindungen nur in eine Richtung bei Asterisk - ISDN-Anlagen-Kopplung

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von ennofm, 7 Feb. 2007.

  1. ennofm

    ennofm Neuer User

    Registriert seit:
    29 März 2006
    Beiträge:
    27
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #1 ennofm, 7 Feb. 2007
    Zuletzt bearbeitet: 7 Feb. 2007
    Hallo,

    wir haben hier eine ältere ISDN- Anlage ( Teles DOS- PABX V2.92t ), die
    wir mit Asterisk ( TrixBox 1.2.13 bristuffed... ) aufpeppen wollten...
    funktioniert auch -- bis auf das eine:
    Verbindungen von Asterisk nach der ISDN- Anlage (intern) klappen nicht!

    Wir haben 2x HFC (Billion) zur Kopplung ( 2x TE ) an 2 Ports der PABX (2xNT).
    Von der alten ISDN-Anlage aus geht es prima in den Asterisk rein - keine Probleme ( es klingelt, Gespräche können geführt werden, u.s.w )...
    Nur umgekehrt kommt zuerst immer ein Rufton und dann entweder ein
    besetzt oder die Ansage "I´m Sorry an Error occured".

    Bei der Durchsicht der ISDN- Protokolle ist mir aufgefallen, daß
    bei der Richtung ISDN-->Asterisk als called number unknown
    angezeigt wird und als Protokoll Audio 3.1kHz...
    In der Gegenrichtung aber called number =national number ist und das Protokoll SPEECH.
    Der Signalisierte Fehler auf dem BUS ist dann immer Nummernlänge falsch - da bei den internen Nummer (2stellig) ja keine Verbindung zu irgendeinem externen zustande kommen kann...
    Hängen wir ein Telefon ( ISDN ) an den BUS zur alten Anlage, bekommen wir ganz normal einen internen Wählton und können auch interne Verbindungen
    aufbauen oder ein Amt holen...
    So hätten wir das auch gerne mit dem Asterisk...

    Bis jetzt haben wir es nicht geschafft da was dran zu drehen...
    Wahrscheinlich versteht die alte Anlage da was nicht.
    Ich hänge bei der Wahl aus dem Asterisk raus somit immer sofort auf einem Amt! Kann also intern gar nichts machen...

    Vielleicht hat jemand Ideen wo man noch drehen kann um das hinzubekommen???
     
  2. ennofm

    ennofm Neuer User

    Registriert seit:
    29 März 2006
    Beiträge:
    27
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    pridialplan=local ist die Lösung!

    Hallo,

    bin jetzt selber drauf gekommen...

    mit

    pridialplan=local
    prilocaldialplan=local

    in der zapata.conf bzw. bri-zapata-hfc.conf

    und anschließendem service zaptel restart und amportal start ist alles in Butter!