.titleBar { margin-bottom: 5px!important; }

IAX bind problem

Dieses Thema im Forum "Asterisk ISDN Allgemein" wurde erstellt von exciler, 11 Feb. 2009.

  1. exciler

    exciler Neuer User

    Registriert seit:
    4 Nov. 2007
    Beiträge:
    10
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo!

    Ich hab bei meinem Asterisk folgendes Problem:
    Mein Asterisk-Rechner hat zwei IP-Adressen (eth0 und eth1). Alle SIP-Clients (eth0 und eth1) funktionieren prächtig. Die IAX-Geräte funktionieren jedoch nur aus eth0, nicht von eth1 aus.

    Hier meine iax.conf:
    Code:
    [general]
    bindport = 4569
    bindaddr = 0.0.0.0
    bandwidth=low
    disallow=lpc10
    jitterbuffer=no
    forcejitterbuffer=no
    ;maxjitterbuffer=1000
    ;maxjitterinterps=10
    ;resyncthreshold=1000
    ;jittertargetextra=40
    minregexpire = 30
    maxregexpire = 180
    autokill=yes
    
    [iaxmodem]
    type=friend
    secret=
    port=4570
    host=localhost
    context=fax-out
    disallow=all
    allow=alaw
    callerid=<iaxmodem>
    
    
    [24]
    type=friend
    secret=
    host=dynamic
    nat=yes
    context=voip-clients-in
    port=4579
    
    bindaddr ist auf 0.0.0.0 gesetzt, was meiner Meinung nach doch eigentlich ausreichen müsste, oder?

    Laut netstat horcht er auch auf 0.0.0.0:
    Code:
    tcp        0      0 0.0.0.0:2000            0.0.0.0:*               LISTEN      3678/asterisk
    udp        0      0 0.0.0.0:5000            0.0.0.0:*                           3678/asterisk
    udp        0      0 0.0.0.0:2727            0.0.0.0:*                           3678/asterisk
    udp        0      0 0.0.0.0:5060            0.0.0.0:*                           3678/asterisk
    udp        0      0 0.0.0.0:4569            0.0.0.0:*                           3678/asterisk
    
    Firewall ist auch offen für beide LANs...

    Hab echt keine Idee mehr, was kann das sein???
    Wenn ihr nochwas braucht, einfach Bescheid sagen. Ich hoffe ihr könnt mir helfen...

    Viele Grüße
    Andreas
     
  2. Burmann

    Burmann Mitglied

    Registriert seit:
    16 Feb. 2005
    Beiträge:
    372
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Vieleicht hilft dir iax2 set debug weiter oder direkt auf die Leitung schauen mit "tcpdump -npli eth1 -E and not port 22" oder wireshark weiter. Dann kann man sehen wer was sendet und ob 'ne Antwort kommt.
     
  3. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Weiss dein IAX-Telefon was von Port 4579?
     
  4. exciler

    exciler Neuer User

    Registriert seit:
    4 Nov. 2007
    Beiträge:
    10
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi!

    Danke schonmal für die Antworten.

    Ja, mein Telefon weiß von 4579. Wenn ich es auf das andere LAN per Kabel umstecke, funktioniert es sofort. Die Config des Telefons muss also korrekt sein. Nur hört der Asterisk wohl nicht auf beiden Interfaces, obwohl ich es ihm gesagt habe.

    Wireshark werde ich mich am Wochenende jetzt mal mit beschäftigen, ist ne gute Idee damit mal zu "horchen", hatte nur gehofft es gäb vielleicht ne simple Erklärung die ich nicht bedacht habe.

    Viele Grüße
    Andreas
     
  5. Burmann

    Burmann Mitglied

    Registriert seit:
    16 Feb. 2005
    Beiträge:
    372
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich könnte mir vorstellen, das es Routing liegt. Aber bevor wir hier 20 Posts über die Möglichen Fehler tauschen, einfach mal tcpdump gestartet und anschauen mit welcher IP Asterisk sendet und was zurückkommt.
     
  6. doxon

    doxon Mitglied

    Registriert seit:
    11 Juni 2006
    Beiträge:
    781
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    IT-Systemelektroniker
    Ort:
    Aurich
    In der sip.conf gibt es die Option "localnet".

    Dort kannst du für jedes deiner Netze einen Eintrag hinzufügen.

    z.b.
    Code:
    localnet = 192.169.0.0/255.255.255.0
    localnet = 192.169.1.0/255.255.255.0
    
    Daran erkennt der Asterisk wo er NAT'en muss.

    Ich bin mir aber nicht sicher ob das bei IAX auch geht.