.titleBar { margin-bottom: 5px!important; }

im SIP-Request ein route-header zu viel

Dieses Thema im Forum "FRITZ!Box Fon: Modifikationen" wurde erstellt von simsboard, 22 Dez. 2008.

  1. simsboard

    simsboard Neuer User

    Registriert seit:
    22 Okt. 2007
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hi zusammen,
    ich würde gerne einen parameter in der /var/flash/voip.cfg ändern - der parameter lautet:
    outboundproxy_without_route_header = no;

    und mein ziel wäre ihn auf
    outboundproxy_without_route_header = yes;

    zu haben => ich erwarte mir dabei, daß in SIP-Requests die die fritz!box ausschickt nicht mehr 2 route-header eingetragen sind - im moment ist 1.header: enthält die daten vom SIP-registrar / 2.header enthält die daten des service-route headers die zur fritz!box auf 200OK der REGISTER-message kommen)

    mein problem ist, daß jedesmal wenn ich diesen parameter auf "yes" ändere er automatisch wieder auf "no" zurückgesetzt wird? :confused::confused:

    gibt es dafür einen speziellen grund? welche möglichkeiten gibt es diese änderung zu unterdrücken?

    kennst sonst noch jemand eine möglichkeit zu verhindern, daß die fritz!box 2 route-header verwendet??

    vielen dank für euere hilfe!
    simsboard
     
  2. frank_m24

    frank_m24 IPPF-Urgestein

    Registriert seit:
    20 Aug. 2005
    Beiträge:
    17,571
    Zustimmungen:
    1
    Punkte für Erfolge:
    36
    Ort:
    Niederrhein
    Hallo,

    wie hast du denn versucht, die voip.cfg zu verändern? nvi? fbeditor?
     
  3. simsboard

    simsboard Neuer User

    Registriert seit:
    22 Okt. 2007
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ich habs anfänglich mit nvi versucht
    gestern abend hab ich dann aber noch einen eintrag irgendwo gefunden der das editieren so beschrieben hat:

    cat /var/flash/voip.cfg > /var/tmp/voip.cfg
    vi /var/tmp/voip.cfg
    und nach dem editieren:
    cat /var/tmp/voip.cfg > /var/flash/voip.cfg

    ich hab noch ein paar andere dinge ausprobiert aber ich denke, daß das der grund war warum es dann schlußendlich funktioniert hat!
    dummerweise: mein eigentlich problem hat es nicht gelöst!
    dieser parameter löscht nur den outboundproxy aus dem route-header => ich dachte dadurch würden alle route-header rausgenommen



    irgendwie verstehe ich die implementierung der registrierung sowieso nicht ganz!! route-header sollten bei einem REGISTER maximal die IP oder der FQDN des outboundproxy's sein
    der implementierte SIP-client schickt aber entweder
    a) 2 route-header: outboundproxy plus die kopie des service-route headers
    oder
    b) nur die kopie des serice-route headers

    beides ist aber meines erachtens nicht korrekt! :confused::confused:
    oder seit ihr anderer meinung?
    mfg
    simsboard