Installationsproblem

Timo34317

Neuer User
Mitglied seit
22 Jan 2006
Beiträge
32
Punkte für Reaktionen
0
Punkte
0
Hallo zusammen,
ich probiere jetzt schon seit 3 Tagen erfolglos meine HFC "Billig" Karte zum laufen zubekommen.

Gibt es irgendwo eine aktuelle Anleitung?

Nutze PBXinaFlash.
Nachdem mit install-ZAPHFC gar nichts funktioniert hatte habe ich zuletzt folgendes probiert:


HTML:
cd /usr/src
ln -s /usr/srckernels/`uname -r` /usr/src/linux
ln -s /usr/srckernels/`uname -r` /usr/src/linux-2.6 # bei Kernel 2.6.xxx

cd /usr/src
wget http://www.junghanns.net/downloads/bristuff-0.4.0-RC3c.tar.gz
tar -zxvf bristuff-0.4.0-RC3c.tar.gz
cd bristuff-0.4.0-RC3c
./download.sh

cd ..
cd zaptel-1.4.12
make clean
make
make install

cd ..
cd libpri-1.4.3
make clean
make
make install

cd ..
cd zaptel
make clean
make
make install

cd /usr/src/bristuff-0.4.0-RC3c/asterisk-1.4.21.2
make clean
./configure
 

kombjuder

IPPF-Promi
Mitglied seit
2 Nov 2004
Beiträge
3,086
Punkte für Reaktionen
0
Punkte
0

Timo34317

Neuer User
Mitglied seit
22 Jan 2006
Beiträge
32
Punkte für Reaktionen
0
Punkte
0
Danke

Sieht ja fast identisch aus ;-)
Mit einer alten Trixbox Version habe ich es auf Anhieb hinbekommen. Irgendo ist wohl noch ein Denkfehler drin.

Werd noch ein bißchen ausprobieren.
 
Zuletzt bearbeitet:

Timo34317

Neuer User
Mitglied seit
22 Jan 2006
Beiträge
32
Punkte für Reaktionen
0
Punkte
0
Manchmal steht man einfach auf dem Schlauch. Jetzt funktioniert alles.
 

kamui76

Neuer User
Mitglied seit
12 Nov 2008
Beiträge
6
Punkte für Reaktionen
0
Punkte
0
Hallo Timo

stehe auch auf dem "Schlauch". Deiner Antwort entnehme ich, dass du es geschafft hast die Treiber zu installieren und das System zum Laufen zu bekommen.

Vielleicht kannst du hier noch mal die Punkte reinschreiben , wie du es geschafft hast!?

Gruß
 

Timo34317

Neuer User
Mitglied seit
22 Jan 2006
Beiträge
32
Punkte für Reaktionen
0
Punkte
0
Lösung

Bei mir hat folgendes geholfen:

Code:
/etc/init.d/zaptel stop
rmmod ztdummy
Nachdem das Zaptel Dummy Modul "entladen" wurde ging auch die HFC Karte
 

kamui76

Neuer User
Mitglied seit
12 Nov 2008
Beiträge
6
Punkte für Reaktionen
0
Punkte
0
Das mit dem Zaptel anhalten hat mit "service zaptel stop" dann funktioniert.
Nun steht das nächste Problem an:

Saving to: `asterisk-1.4.2.tar.gz'

100%[====================================================================================>] 17,055,659 221K/s in 83s

11:47:05 (201 KB/s) - `asterisk-1.4.2.tar.gz' saved [17055659/17055659]

/usr/local/sbin/install-ZAPHFC: line 1182: patch: command not found
Failed to sucessfully patch asterisk-1.4.2. Exiting script.
Das Skript (install zaphfc) bricht ab vermutlich wegen dem falschen Asterisk kernel.
Ne Idee wie man weiter vorgehen kann? Treiber einzeln installieren?

Gruß
 

Timo34317

Neuer User
Mitglied seit
22 Jan 2006
Beiträge
32
Punkte für Reaktionen
0
Punkte
0
Welche install-ZAPHFC Version benutzt du? Poste mal die Zeile 1182.
 
Zuletzt bearbeitet:

Thomas007

Aktives Mitglied
Mitglied seit
18 Sep 2005
Beiträge
1,455
Punkte für Reaktionen
0
Punkte
0
Da steht es doch:
/usr/local/sbin/install-ZAPHFC: line 1182: patch: command not found

Offenbar ist da patch nicht installiert
 

kamui76

Neuer User
Mitglied seit
12 Nov 2008
Beiträge
6
Punkte für Reaktionen
0
Punkte
0
Ja wie Thomas es schon sagt, steht es ja schon da, oder eine andere Zeile?
beim patch installieren is mir irgendwie die ganze maschine ausgestigeen und es ging nichts mehr.
Musste jetzt neu Installieren.
Also fange ich noch mal von Neuem an, denke aber das ich bald weder am selbem Problem stehe
 
Zuletzt bearbeitet:

Samurey

Neuer User
Mitglied seit
12 Dez 2008
Beiträge
5
Punkte für Reaktionen
0
Punkte
0
Hallo zusammen, ich möchte das Thema hier auch noch mal aufgreifen.

Habe nun versucht das install-ZAPHFC zu benutzen, nachdem ich eine HFC-S Karte eingebaut habe.Habe die Anleitung hier aus dem Forum benutzt.
Allerdings bleibt die Installation scheinbar hängen, weil ich einen neueren Asterisk Kernel benutze(im aktuelle Trixbox Image enthalten ) als das Scrip zulässt!?
Ich dachte mir nimmst halt den letzten verfügbaren im Auswahlmenü und probierst mal.

Soweit so gut aber dann schließt das script mit:

Code:
Unable to find or update kernel libraries for the currently
running kernel
Expecting to find /usr/src/kernels/2.6.18-53.1.4.el5-i686/

You are running:  2.6.18-53.1.4.el5

The kernel libraries loaded in /usr/src/kernels are:

2.6.18-92.1.18.el5-i686
Zur Vervollständigung habe ich hier noch mal den ganzen verlauf aufgezeichnet.

Code:
[trixbox1.localdomain sbin]# service zaptel stop
Unloading zaptel hardware drivers:.
[trixbox1.localdomain sbin]# install-ZAPHFC -a 1.4.0 -m 1

-----------------------------------------------------
Searching for HFC Chipset based cards.
-----------------------------------------------------

Found a 1 port card (1397:2bd0) with an HFC-PCI chipset.

-----------------------------------------------------
Checking for updates from [url]http://brightheadtechnology.com/other/aah[/url]
-----------------------------------------------------


-----------------------------------------------------
Determining which version of asterisk to build.
-----------------------------------------------------



Unable to find a version of BRIstuff to match the version quoted on the command line (1.4.0) version of Asterisk
Choose the version of Asterisk you want to patch with BRIstuff
Going back a version or two appears to be OK.
It is not recommended to go forward to a version above what you have installed.

1) 1.0.9     7) 1.2.4   13) 1.2.10  19) 1.2.19  25) 1.4.2   31) QUIT
2) 1.0.10    8) 1.2.5   14) 1.2.12  20) 1.2.22  26) 1.4.7
3) 1.2.0     9) 1.2.6   15) 1.2.13  21) 1.2.23  27) 1.4.8
4) 1.2.1    10) 1.2.7   16) 1.2.14  22) 1.2.24  28) 1.4.9
5) 1.2.2    11) 1.2.8   17) 1.2.17  23) 1.2.25  29) 1.4.16
6) 1.2.3    12) 1.2.9   18) 1.2.18  24) 1.2.26  30) 1.4.17
Option number: 30

-----------------------------------------------------
Display and confirm build.
-----------------------------------------------------

About to build with the following parameters:

Asterisk:       1.4.17
Zaptel:         1.4.7.1
Libpri:         1.4.3
BRIsttuff:      bristuff-0.4.0-test6
Cards Found:    1
Card1 Port1:    NT mode
Kernel:         2.6.18-53.1.4.el5
                This looks like the first BRIstuff build for this version of the kernel.

*** This is still a test release. ***

**************************************************************
*                                                            *
* As of version 1.0.4 install-ZAPHFC will automatically      *
* create a zapata config for your HFC card(s).               *
*                                                            *
* It puts this config into /etc/asterisk/zapata-BRI-HFC.conf *
*                                                            *
* It also adds an include for this file into zapata.conf     *
*                                                            *
* Please move your existing zapata HFC config statements     *
* into zapata-BRI-HFC.conf                                   *
*                                                            *
* zapata-BRI-HFC.conf will not be over-written unless you    *
* specify the -R command line option. The old version will   *
* be re-named.                                               *
*                                                            *
**************************************************************


If this is not the configuration you require try "install-ZAPHFC -h" for a list of options.

Are you sure you wish to continue this build?
-----------------------------------------------------
Continue? [y/N] :y
OK....

-----------------------------------------------------
Checking Asterisk and shutting down.
-----------------------------------------------------

Asterisk appears to already be stopped.

-----------------------------------------------------
Checking Zaptel and unloading zaptel modules
-----------------------------------------------------


-----------------------------------------------------
Found Trixbox installed.
-----------------------------------------------------

warning: /etc/zaptel.conf saved as /etc/zaptel.conf.rpmsave

-----------------------------------------------------
 Attempting to download/update kernel libraries...
-----------------------------------------------------

Running yum to install kernel-devel
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
addons                    100% |=========================|  951 B    00:00
trixbox                   100% |=========================| 1.1 kB    00:00
base                      100% |=========================| 1.1 kB    00:00
trixboxaddons             100% |=========================|  951 B    00:00
updates                   100% |=========================|  951 B    00:00
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================|  157 B    00:00
primary.xml.gz            100% |=========================| 142 kB    00:06
################################################## 307/307
primary.xml.gz            100% |=========================| 853 kB    00:03
################################################## 2458/2458
primary.xml.gz            100% |=========================| 5.9 kB    00:00
################################################## 16/16
primary.xml.gz            100% |=========================| 368 kB    00:01
################################################## 794/794
primary.xml.gz            100% |=========================|  90 kB    00:00
################################################## 295/295
Excluding Packages from CentOS-5 - Addons
Finished
Excluding Packages from CentOS-5 - Base
Finished
Excluding Packages from CentOS-5 - Updates
Finished
Excluding Packages from CentOS-5 - Extras
Finished
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for kernel-devel to pack into transaction set.
kernel-devel-2.6.18-92.1. 100% |=========================| 819 kB    00:09
---> Package kernel-devel.i686 0:2.6.18-92.1.18.el5 set to be installed
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 kernel-devel            i686       2.6.18-92.1.18.el5  trixbox           4.8 M

Transaction Summary
=============================================================================
Install      1 Package(s)
Update       0 Package(s)
Remove       0 Package(s)

Total download size: 4.8 M
Downloading Packages:
(1/1): kernel-devel-2.6.1 100% |=========================| 4.8 MB    02:22
Running Transaction Test
warning: kernel-devel-2.6.18-92.1.18.el5: Header V3 DSA signature: NOKEY, key ID e8562897
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: kernel-devel                 ######################### [1/1]

Installed: kernel-devel.i686 0:2.6.18-92.1.18.el5
Complete!

-----------------------------------------------------
Unable to find or update kernel libraries for the currently
running kernel
Expecting to find /usr/src/kernels/2.6.18-53.1.4.el5-i686/

You are running:  2.6.18-53.1.4.el5

The kernel libraries loaded in /usr/src/kernels are:

2.6.18-92.1.18.el5-i686
Wäre für jede Anregung dankbar!

Gruß