interner S0-Bus will nicht

realgoth

Neuer User
Mitglied seit
24 Mai 2004
Beiträge
35
Punkte für Reaktionen
0
Punkte
0
Hallo Gemeinde!

Nun dachte ich fast, dass ich soweit wäre, nachdem alles dann doch irgendwie compilierte, etc. aber das war wohl nichts. Nun denn:

Startzustand: Asterisk (CVS über bristuff) installiert, chan_capi 0.3.5 hinterher. Rechner neu gestartet. Er hat keine Treiber für ISDN-Karten geladen.

Code:
#modprobe zaptel
#cd /usr/src/bri-stuff.0.1.0-RC4/zaphfc/
#insmod zaphfc.o modes=1
Ergebnis von "tail /var/log/messages"
Code:
Aug 27 18:39:36 comdoxx kernel: Zapata Telephony Interface Registered on major 196
Aug 27 18:40:03 comdoxx kernel: PCI: Found IRQ 11 for device 00:0e.0
Aug 27 18:40:03 comdoxx kernel: zaphfc: CCD/Billion/Asuscom 2BD0 configured at mem 0xcc8c2000 fifo 0xc6dc8000(0x6dc8000) IRQ 11 HZ 100
Aug 27 18:40:03 comdoxx kernel: zaphfc: Card 0 configured for NT mode
Aug 27 18:40:03 comdoxx kernel: zaphfc: 1 hfc-pci card(s) in this box.
Ergebnis von "lsmod"
Code:
Module                  Size  Used by    Not tainted
zaphfc                  9864   0  (unused)
zaptel                178624   0  [zaphfc]
...
OK: Weiter im Text:
Code:
#modprobe capi
#modprobe fcpci
(nur damit asterisk vernünftig startet: chan_capi ist ja aktiviert).

Auf der Hardware-Seite:
HFC-ISDN Karte mit Crosskabel an NTBA (3-4, 4-3, 5-6, 6-5)
NTBA mit Strom versorgt ;-)
NTBA an "Telnet Verona" mit normalem ISDN-Kabel (bzw. korrekt an die Steckerleiste angebrachtem halben Netzwerkkabel).
Telefon an Telnet Verona

Nun aber:
Code:
#asterisk -cvvv

...tonnenweise output...

Asterisk Ready.
*CLI>
Keinerlei beschwerden beim Modul zap...

Todesmutig nehme ich den Telefonhörer ab... und? Nix. Gar nix.
Kein Wählgeräusch, kein Output vom Asterisk, nada, niente.

Euch interessiert noch die zapata.conf? Nix leichter als das:
Code:
[channels]
context=default
switchtype=euroisdn
pridialplan=local
signalling=bri_cpe_ptmp
echocancel=yes
group=1
immediate=yes
channel => 1-2
ztcfg -vv wollt ihr auch noch?

Code:
Zaptel Configuration
======================

SPAN 1: CCS/ AMI Build-out: 399-533 feet (DSX-1)

Channel map:

Channel 01: Individual Clear channel (Default) (Slaves: 01)
Channel 02: Individual Clear channel (Default) (Slaves: 02)
Channel 03: D-channel (Default) (Slaves: 03)

3 channels configured.
Verzweifelnd
Goth
 

realgoth

Neuer User
Mitglied seit
24 Mai 2004
Beiträge
35
Punkte für Reaktionen
0
Punkte
0
By the way:

Code:
-- Executing Dial("SIP/5001-7b91", "Zap/1/MSN|60|tT") in new stack
Aug 27 19:34:25 NOTICE[1116969776]: app_dial.c:727 dial_exec: Unable to create channel of type 'Zap'
*wunder*
 

realgoth

Neuer User
Mitglied seit
24 Mai 2004
Beiträge
35
Punkte für Reaktionen
0
Punkte
0
Die CAPI-Treiber sind für die zweite Karte, die nach extern geht... Hab ich ganz vergessen, dabei zu schreiben.

By the way: Nun geht es. Ich habe erstmal getestet, ob die Karte noch geht, indem ich sie als TE-Mode-Karte nach Extern genutzt habe (hatte erst ein falsch gecrimptes Kabel: Aber die 40V haben die Karte anscheinend nicht zerstört :lamer: ).

Dann habe ich alles noch mal umgesteckt (wie hier beschrieben) und nach reboot, laden der Treiber und start des * gings dann:
#modprobe zaptel
#insmod /usr/src/bristuff.0.1.0-RC?/zaphfc/zaphfc.o modes=1
#ztcfg -vv

Gruß
Goth
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,370
Beiträge
2,021,621
Mitglieder
349,955
Neuestes Mitglied
brmbrm