iPhone mit VPN Fritz!Box 7270v3 aber kein Zugriff

tschewski

Neuer User
Mitglied seit
17 Okt 2011
Beiträge
3
Punkte für Reaktionen
0
Punkte
0
Hallo zusammen,

ich habe mich hier schon ein bisschen durchgelesen, aber kann mein Problem noch nicht beheben...

Ich habe eine VPN Konfig auf die Fritz Box gespielt und kann auch eine Verbindung vom iPhone auf die Box herstellen. Nun komme ich aber leider auf keinelei Internetseiten, geschweige denn die Seite der Fritz Box.

Ich hänge euch hier mal meine Konfig an und hoffe, dass ihr den Fehler finden könnt:

Code:
vpncfg {
        connections {
                enabled = yes;
                conn_type = conntype_user;
                name = "name";
                always_renew = no;
                reject_not_encrypted = no;
                dont_filter_netbios = yes;
                localip = 0.0.0.0;
                local_virtualip = 0.0.0.0;
                remoteip = 0.0.0.0;
                remote_virtualip = 192.168.178.1;
                remoteid {
                        key_id = "mail";
                }
                mode = phase1_mode_aggressive;
                phase1ss = "all/all/all";
                keytype = connkeytype_pre_shared;
                key = "key";
                cert_do_server_auth = no;
                use_nat_t = yes;
                use_xauth = yes;
                use_cfgmode = no;
				xauth {
					valid = yes;
					username = "user";
					passwd = "passwd";
					}
                phase2localid {
                        ipnet {
                                ipaddr = 0.0.0.0;
                                mask = 0.0.0.0;
                        }
                }
                phase2remoteid {
                        ipaddr = 192.168.178.1;
                }
                phase2ss = "esp-all-all/ah-none/comp-all/no-pfs";
                accesslist = 
                             "permit ip 192.168.178.0 255.255.255.0 192.168.178.1 255.255.255.255";
        }
        ike_forward_rules = "udp 0.0.0.0:500 0.0.0.0:500", 
                            "udp 0.0.0.0:4500 0.0.0.0:4500";
}


// EOF
Was ich schon ausprobiert habe, aber nichts gebracht hat ist folgendes:

Code:
accesslist = 
                             "permit ip any 192.168.178.1 255.255.255.255";
Code:
accesslist = 
                             "permit ip any 192.168.178.1 255.255.255.0";
Code:
accesslist = 
                             "permit ip 192.168.178.0 255.255.255.255 192.168.178.1 255.255.255.255";
Code:
accesslist = 
                             "permit ip 192.168.178.0 255.255.255.255 192.168.178.1 255.255.255.0";

Ich hoffe ihr könnt mir helfen!

Vielen Dank schonmal im Voraus :)

MFG Tschewski
 

tschewski

Neuer User
Mitglied seit
17 Okt 2011
Beiträge
3
Punkte für Reaktionen
0
Punkte
0
...danke für den Hinweis, aber leider klappt auch das nicht...s wird nur die Meldung "Server antwortet nicht" auf dem iPhone ausgegeben...
 

frank_m24

IPPF-Urgestein
Mitglied seit
20 Aug 2005
Beiträge
17,571
Punkte für Reaktionen
1
Punkte
38
remote_virtualip = 192.168.178.1;
Die gleiche IP, wie die Fritzbox benutzt? Das kann nicht funktionieren. Oder hast du den Router umkonfiguriert? Das gibt bei VPN immer wieder Probleme. Belasse bei VPN so viele wie möglich Einstellungen auf Default. Alles andere wird kritisch.
 

tschewski

Neuer User
Mitglied seit
17 Okt 2011
Beiträge
3
Punkte für Reaktionen
0
Punkte
0
Ich habe die Konfig ein bisschen angepasst, weil ich die xauth vergessen hatte, die wohl für das vpn vom ipone aus nötig ist.

Meine Konfig sieht nun folgendermaßen aus, funktioniert jedoch noch immer nicht.

Code:
vpncfg {
        connections {
                enabled = yes;
                conn_type = conntype_user;
                name = "name";
                always_renew = no;
                reject_not_encrypted = no;
                dont_filter_netbios = yes;
                localip = 0.0.0.0;
                local_virtualip = 0.0.0.0;
                remoteip = 0.0.0.0;
                remote_virtualip = 192.168.178.201;
                remoteid {
                        key_id = "name";
                }
                mode = phase1_mode_aggressive;
                phase1ss = "all/all/all";
                keytype = connkeytype_pre_shared;
                key = "key";
                cert_do_server_auth = no;
                use_nat_t = yes;
                use_xauth = yes;
                use_cfgmode = no;
                xauth {
                        valid = yes;
                        username = "user";
                        passwd = "passwd";
                }
                phase2localid {
                        ipnet {
                                ipaddr = 192.168.178.0;
                                mask = 255.255.255.0;
                        }
                }
                phase2remoteid {
                        ipaddr = 192.168.178.201;
                }
                phase2ss = "esp-all-all/ah-none/comp-all/no-pfs";
                accesslist = 
                             "permit ip any 192.168.178.201 255.255.255.255";
        }
        ike_forward_rules = "udp 0.0.0.0:500 0.0.0.0:500", 
                            "udp 0.0.0.0:4500 0.0.0.0:4500";
}
Noch jemand Abhilfe dabei? ;)
Posting 2:
Mit folgender Konfig funktioniert es nun!

Ich komme auf die FritzBox und ins Internet.

Code:
vpncfg {
        connections {
                enabled = yes;
                conn_type = conntype_user;
                name = "name";
                always_renew = no;
                reject_not_encrypted = no;
                dont_filter_netbios = yes;
                localip = 0.0.0.0;
                local_virtualip = 0.0.0.0;
                remoteip = 0.0.0.0;
                remote_virtualip = 192.168.178.201;
                remoteid {
                        key_id = "name";
                }
                mode = phase1_mode_aggressive;
                phase1ss = "all/all/all";
                keytype = connkeytype_pre_shared;
                key = "key";
                cert_do_server_auth = no;
                use_nat_t = yes;
                use_xauth = yes;
                use_cfgmode = no;
                xauth {
                        valid = yes;
                        username = "user";
                        passwd = "passwd";
                }
                phase2localid {
                        ipnet {
                                ipaddr = 0.0.0.0;
                                mask = 0.0.0.0;
                        }
                }
                phase2remoteid {
                        ipaddr = 192.168.178.201;
                }
                phase2ss = "esp-all-all/ah-none/comp-all/no-pfs";
                accesslist = 
                             "permit ip any 192.168.178.201 255.255.255.255";
        }
        ike_forward_rules = "udp 0.0.0.0:500 0.0.0.0:500", 
                            "udp 0.0.0.0:4500 0.0.0.0:4500";
}
Danke für eure Beiträge!

ABER: Noch bin ich nicht fertig mit euch ;)

Da das alles nun funktioniert, würde ich gerne wissen in wie weit ich nun Zugriff auf meine Daten in freigegebenen Ordnern auf meinem PCs zuhause erlangen kann.

Habt ihr da hilfreiche Themen oder Beiträge für mich?


Schöne Grüße

Tschewski
 
Zuletzt bearbeitet von einem Moderator: