.titleBar { margin-bottom: 5px!important; }

ISDN Kopplung: Singalisierung geht/Voice nicht

Dieses Thema im Forum "Asterisk ISDN mit CAPI (chan_capi, chan_capi_cm)" wurde erstellt von knoesel, 3 Dez. 2004.

  1. knoesel

    knoesel Neuer User

    Registriert seit:
    3 Dez. 2004
    Beiträge:
    6
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hallo zusammen,

    ich habe einen asterisk server über s0 an eine legacy pbx angeschlossen und kann nun von meinem sip-phone über die pbx ins pstn anrufen, jedenfalls klingelt der isdn-apparat, den ich anwähle. wenn ich dann drangehe, höre ich allerdings nichts! woran kann das liegen?

    danke,
    der knoesel
     
  2. Hupe

    Hupe Aktives Mitglied

    Registriert seit:
    8 Apr. 2004
    Beiträge:
    2,586
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Vielleicht ein Portproblem zwischen Asterisk und dem Sip-Phone? (Firewall/Falsche RTP-Ports). Vielleicht ein Codec Problem zwischen Sip-Phone und Asterisk (einfach mal "sip show channels" bei bestehender Verbindung eintippen). Poste im Zweifelsfall mal sip.conf/capi.conf/extensions.conf (passwörter und Nutzername nicht mitposten).
     
  3. knoesel

    knoesel Neuer User

    Registriert seit:
    3 Dez. 2004
    Beiträge:
    6
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    die kommunikation zwischen sip-phones funktioniert - deswegen denke ich nicht, dass es an den rtp-ports liegt... ein coding problem ist da schon eher denkbar, z.z. sprechen die phones g711 - evtl im falschen modus? was muss ich nehmen ulaw oder alaw?

    Also, intern solltest du alaw nehmen. ulaw ist aber auch ok. Einfach bei:
    disallow=all
    allow=alaw
    allow=ulaw
    bei den Clients reinsetzen. Bei Sipgate (und bei default) sollte auch etwas stehen. Das ist aber geschmackssachen.
     
  4. knoesel

    knoesel Neuer User

    Registriert seit:
    3 Dez. 2004
    Beiträge:
    6
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    Fehler ist behoben. Lag scheinbar an der ISDN Karte?! Jedenfalls läufts jetzt mit einer neueren PCI Karte problemlos.