.titleBar { margin-bottom: 5px!important; }

ISH Telefonie zusammen mit Sipura-Voip kein ausgehender Ton

Dieses Thema im Forum "Linksys (VoIP)" wurde erstellt von Max_Punktezahl, 2 Nov. 2005.

  1. Max_Punktezahl

    Max_Punktezahl Neuer User

    Registriert seit:
    19 Apr. 2005
    Beiträge:
    13
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Sipura-Fans,

    ich betreibe hier einen Sipura SPA-2100 seit 10 Monaten an einem ISH-Kabelmodem (eine echte IP kein NAT!) und Sipgate funtioniert prima. Aber seitdem ich ISH-Telefonie dazu gebucht habe gibt es folgendes Problem:
    Sobald die ISH-Leitung aktiv ist kann mich mein Gegenüber nicht mehr hören (auch mitten im Gespräch!).

    Die ISH-Telefonie-Bandbreite wird offensichtlich NICHT von der Internet-Bandreite bei einem Telefonat abgezogen (Ist wohl H.323 und kein SIP beim Motorola-Kabelmodem, glaube ich, das Kabelmodem hat wie der Sipura RJ11-Anschlüsse für VoIP).

    Mit X-Lite funktioniert es weiterhin, also kann es eigentlich nicht an der Bandbreite (Uplink 128k) liegen. Auch die ISH-Telefonie selber scheint kein grundsätzliches Problem zu sein, da X-Lite ja weiterhin funktioniert. Über PM zu anderen ISH-Nutzern habe ich herausgefunden das ISH wohl angeblich Ports > 16000 blockiert. (zwei Voip-Forum Benutzer die ich angeschrieben habe benutzen jetzt die FritzBox und haben damit keine Probleme mehr, einer hatte vorher mit einem CISCO-Telefon ähnliche Probleme.) Ich habe die RTP-Ports in alle möglichen Bereiche gelegt (auch unterhalb 1024) bekomme aber immer wieder das gleiche Verhalten. Auch die Firmware habe ich inzwischen zwei Mal erneuert (obwohl ich kein Freund solcher Aktionen bin ;-). Meine aktuelle Firmware ist die 3.2.2 Version. Alles wie gehabt.
    Ich glaube allerdings nicht, dass es die RTP-Ports sind, ich kann den Sipura da fast unbeschränkt einstellen, meine Befürchtung ist, dass die ISH-Leute im Modem eingehende UDP-Streams ganz blocken (während eines ISH-Telefonats, aber warum geht dann X-Lite?). Das X-Lite hinter dem Sipura geht über STUN während der Sipura eine echte IP bekommt. Trozdem habe ich mit und ohne STUN-Server probiert, mit dem selben Ergebnis :-( Ich habe auch bandbreitenschonende Codecs probiert, aber es fruchtet alles nichts.

    In den Sipura-Einstellungen findet sich in der Router-Konfiguration unter Application ein Punkt "System Reserved Ports Range" und diese Ports kann man leider nicht unter 10000 konfigurieren, weiß jemand wozu der Sipura diese Ports benötigt? Mit SIP sollte das doch nichts zu tun haben? Kann natürlich sein, dass ISH alles oberhalb 10000 dichtmacht, dann habe ich verlohren, oder muss versuchen die Firmware zu patchen ;-).

    Die diversen Konfigurationsseiten zum Sipura hier habe ich schon durchgesehen, ich denke eigentlich, dass ich keine schwerwiegenden Fehler gemacht habe.
    Wie gesagt, solange das ISH-Telefon nicht benutzt wird ist alles in Ordnung.
    Tja, ich bin mit meinem Voip-Latein am Ende. Vielleicht weiß hier ein Sipura-Spezialist Rat? Funktioniert der Sipura wenn die Ports > 10000 blockiert sind?

    Tschüss

    Andreas
     
  2. Robinson

    Robinson Aktives Mitglied

    Registriert seit:
    24 März 2004
    Beiträge:
    1,751
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Wismar
    1. Hast Du mal ISH darauf angesprochen?

    2. Das eigentliche SIP-Handling funktioniert? Sonst mal andere Ports für SIP nehmen als 5060 und 5061.
     
  3. Max_Punktezahl

    Max_Punktezahl Neuer User

    Registriert seit:
    19 Apr. 2005
    Beiträge:
    13
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Habe ich per Mail, ich weiß von anderen ISH-Kunden hier im Forum, dass ISH so ca. 3 Wochen für eine Antwort benötigt :-(


    Der Tel.-Support ist kostenpflichtig und leider wenig kompetent. Außerdem geht es mit X-Lite, also ist der Sipura "schuld".

    Ja Rufsignalisierung und so funktioniert, sobald das ISH-Telefon aufgelegt ist, ist auch der Ton wieder da (das Telefonat wir auch nicht beendet, nur es geht kein Ton mehr raus). Ich denke die blockieren irgendwelche ausgehenden UDP-Ports während eines Anrufes (vielleicht deren QoS?). Ich hatte die Hoffnung das hier irgendjemand weiß was es mit der "System Reserved Ports Range" auf sich hat. Im Manual steht:

    The “Starting Port” has a fixed base of 10000. For example, by default it is set to
    50000, thus the system reserved ports range will be [60000, 60256].
    System Reserved Ports Range defines the random TCP/UDP ports used by the
    application running on the SPA-2100. These ports and other system reserved
    ports CANNOT be used by Port Forwarding and/or DMZ service.
    For example, 5060 is reserved if line 1 of the SPA-2100 is enabled.


    Das deutet für mich darauf hin, dass dynamische UDP-Ports während eines VoIP-Telefonats auch auf Ports über 10000 landen. Warum man dann in der Voice-Config für die UDP-Ports auch noch etwas einstellen kann ist mir schleierhaft. Die letzte Zeile zeigt ja ,dass die reserved ports etwas mit der VoIp-Funktionalität zu tun haben.

    Gibt es ein öffentliches Sipura Supportforum bei sipura.com? Ich finde nur ein Forum für Provider.

    Ich hänge meinen Sipura mal zum Test hinter einen fli4l den ich hier noch
    habe (der ist normalerweise nicht in Betrieb), und versuche mal unter linux zu schauen welche Ports offen sind...

    Tschüss

    Andreas